Author Topic: How can I setup which sound card to use with Simplephone ?  (Read 1803 times)

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 909
  • Living with LMCE
    • View Profile
How can I setup which sound card to use with Simplephone ?
« on: October 09, 2009, 01:40:55 pm »
Hi,

I've attached Phoenix under 710 and it seems to appear as second alsa device.

How can I setup Simplephone to use second alsa device ? Maybe config file or database setting out there...

Thanks in advance,

regards,

Bulek.
Thanks in advance,

regards,

Bulek.

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 909
  • Living with LMCE
    • View Profile
Re: How can I setup which sound card to use with Simplephone ?
« Reply #1 on: October 09, 2009, 01:53:52 pm »
Hi,

it seems there is a simplephone.conf in /etc/pluto. Will start there...

Regards,

Bulek.
Thanks in advance,

regards,

Bulek.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: How can I setup which sound card to use with Simplephone ?
« Reply #2 on: October 09, 2009, 02:47:06 pm »
dude, JUST UPGRADE TO 0810! IT WORKS OUT OF THE BOX!!!

-Thom

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 909
  • Living with LMCE
    • View Profile
Re: How can I setup which sound card to use with Simplephone ?
« Reply #3 on: October 09, 2009, 03:14:47 pm »
dude, JUST UPGRADE TO 0810! IT WORKS OUT OF THE BOX!!!

-Thom
I know, but I don't want to make that transition yet on our family 24hrs a day system....

I did this, but it seems that it's not working ...

I've added new device to /etc/asound.conf :
Code: [Select]
pcm.phoenix_analog {
type asym
playback.pcm "plughw:1"
capture.pcm "plughw:1"
}

and this into /etc/pluto/simplephone.conf :
Code: [Select]
[sip]
sip_port=5061
use_ipv6=0
[sound]
local_ring=/usr/share/sounds/linphone/rings/orig.wav
alsadev=phoenix_analog
[video]
enabled=0

but it seems that this file is overwritten on each reboot...

1. Is there a chance that Simplephone will work with Phoenix under 710 ?
2. if yes, how can I change that alsadev setting not to be overwritten ?

Thanks in advance,

regards,

Bulek.
Thanks in advance,

regards,

Bulek.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: How can I setup which sound card to use with Simplephone ?
« Reply #4 on: October 09, 2009, 03:16:31 pm »
No. The linphone library under 0710 is too old, and has a bug that causes buffer underruns when using USB microphones. You are wasting your time.

-Thom