Author Topic: Error: cannot connect to router  (Read 1633 times)

samsung

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Error: cannot connect to router
« on: October 01, 2009, 09:00:20 pm »
hello,
I have attempted to boot all the MD's which were working prior to a 8.10 reinstall.  After going through to a particular step in the pxe boot.... I receive a message "ERROR: cannot connect to router: rebooting in 5 secs".  I have had no equipment changes since the last install i had working.  I have attempted to connect MD's directly to core ethernet port to ensure switch is in working order.  What log should i dig into or what could be the issue? thank you.   

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: Error: cannot connect to router
« Reply #1 on: October 01, 2009, 09:54:32 pm »
can you try to run make a quick reload of the router and then boot the md again?
can you try to boot the server again and then start the md?

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Error: cannot connect to router
« Reply #2 on: October 01, 2009, 10:27:25 pm »
Just to weigh in here, you're not alone.  I too, have tried similar things and yes, Murcel- have tried that.  Also tried connecting direct to my core with a MD and changing to a static external IP rather than DHCP as suggested in a previous forum.

This same thing happened a couple alphas ago- can't seem to figure out which one at the moment, but it was resolved.  Unfortunately I do not know how...
« Last Edit: October 01, 2009, 10:29:12 pm by huh »

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: Error: cannot connect to router
« Reply #3 on: October 02, 2009, 12:08:04 am »
can you try to run

/usr/pluto/bin/startup-script.sh

and after that start md?

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Error: cannot connect to router
« Reply #4 on: October 02, 2009, 01:13:44 am »
Mine goes through a number of processes:

Starting MySQL, starting DHCP server, starting DNS server, configuring network firewall, setting SSH keys, then this:

--2009-10-01 18:09:07--  (try:13)  http://www.linuxmce.org/new_installation.php
Connecting to www.linuxmce.org|193.200.113.133|:80... connected.
                                        Read error (Connection timed out) in headers.
Retrying.


as you can see, this was from try 13, not sure how long it will go... will let it go.  MD still would not boot.

I can connect to the internet on my core- currently posting from it.

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Error: cannot connect to router
« Reply #5 on: October 02, 2009, 01:16:13 am »
Well, 15 is the magic number- tries 15 times.  Then kicked out this:

--2009-10-01 18:13:29--  (try:15)  http://www.linuxmce.org/new_installation.php
Connecting to www.linuxmce.org|193.200.113.133|:80... connected.               
HTTP request sent, awaiting response... 200 OK                                 
Length: 412 [text/html]                                                       
Saving to: `STDOUT'                                                           

     0K                                                       100% 29.8M=0s

2009-10-01 18:13:29 (29.8 MB/s) - `-' saved [412/412]

Running command: /usr/pluto/bin/sqlCVS -h localhost -P 3306 -u root -D pluto_main -t Installation -O 1 -N <br /> <b>Warning</b>: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections in <b>/usr/share/php/adodb/drivers/adodb-mysql.inc.php</b> on line <b>358</b><br /> <br /> <b>Fatal error</b>: mysql error: [1040: Too many connections] in CONNECT(localhost, main_sqlcvs) in <b>/usr/share/php/adodb/adodb-errorhandler.inc.php</b> on line <b>77</b><br /> change_key                                                                                     
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation                                                                 
 www.plutohome.com                                                                                                     
 Phone: +1 (877) 758-8648                                                                                             
This program is distributed according to the terms                                                                     
of the Pluto Public License, available at:                                                                             
 http://plutohome.com/index.php?section=public_license                                                                 
This program is distributed in the hope that it will be useful,                                                       
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY                                         
or FITNESS FOR A PARTICULAR PURPOSE. See the Pluto Public License for more details.                                   

-------

Database host:localhost user:root pass: name:pluto_main port:3306
Users:                                                           
Updating repository 'constants' schema version from: 4           
Updating repository 'dce' schema version from: 45               
Updating repository 'designer' schema version from: 39           
Updating repository 'document' schema version from: 1           
Updating repository 'ir' schema version from: 4                 
Updating repository 'local' schema version from: 51             
Updating repository 'website' schema version from: 2             
01      10/01/09 18:13:41.645           Query failed (You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'function.mysql-connect'>function.mysql-connect</a>]: Too many connections in <b>' at line 1): UPDATE `CommandGroup` SET FK_Installation='<br />                         
<b>Warning</b>:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections in <b>/usr/share/php/adodb/drivers/adodb-mysql.inc.php</b> on line <b>358</b><br />                                     
<br />                                                                                                                 
<b>Fatal error</b>:  mysql error: [1040: Too many connections] in CONNECT(localhost, '****', '****', main_sqlcvs)     
 in <b>/usr/share/php/adodb/adodb-errorhandler.inc.php</b> on line <b>77</b><br />' WHERE FK_Installation='1' (1) <0xb79b4b20>                                                                                                               
05      10/01/09 18:13:41.645           Resetting mysql connection <0xb79b4b20>                                       
01      10/01/09 18:13:41.645           Query failed (You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'function.mysql-connect'>function.mysql-connect</a>]: Too many connections in <b>' at line 1): UPDATE `CommandGroup` SET FK_Installation='<br />                         
<b>Warning</b>:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections in <b>/usr/share/php/adodb/drivers/adodb-mysql.inc.php</b> on line <b>358</b><br />                                     
<br />                                                                                                                 
<b>Fatal error</b>:  mysql error: [1040: Too many connections] in CONNECT(localhost, '****', '****', main_sqlcvs)     
 in <b>/usr/share/php/adodb/adodb-errorhandler.inc.php</b> on line <b>77</b><br />' WHERE FK_Installation='1' (1) <0xb79b4b20>                                                                                                               
05      10/01/09 18:13:41.646           Resetting mysql connection <0xb79b4b20>                                       
01      10/01/09 18:13:41.646           Query failed (): UPDATE `CommandGroup` SET FK_Installation='<br />             
<b>Warning</b>:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections in <b>/usr/share/php/adodb/drivers/adodb-mysql.inc.php</b> on line <b>358</b><br />                                     
<br />                                                                                                                 
<b>Fatal error</b>:  mysql error: [1040: Too many connections] in CONNECT(localhost, '****', '****', main_sqlcvs)     
 in <b>/usr/share/php/adodb/adodb-errorhandler.inc.php</b> on line <b>77</b><br />' WHERE FK_Installation='1' retry: -1 <0xb79b4b20>                                                                                                         
Failed to propagate change: UPDATE `CommandGroup` SET FK_Installation='<br />                                         
<b>Warning</b>:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections in <b>/usr/share/php/adodb/drivers/adodb-mysql.inc.php</b> on line <b>358</b><br />                                     
<br />                                                                                                                 
<b>Fatal error</b>:  mysql error: [1040: Too many connections] in CONNECT(localhost, '****', '****', main_sqlcvs)     
 in <b>/usr/share/php/adodb/adodb-errorhandler.inc.php</b> on line <b>77</b><br />' WHERE FK_Installation='1'         
Caught exception: Failed to propagate change                                                                           
mv: target `/>' is not a directory                                                                                     
fail                                                                                                                   
45% Setting Coredump Location                                                                                         
Setting Coredump Location ...ok                                                                                       
50% Starting Dhcp Plugin                                                                                               
Starting Dhcp Plugin ...ok                                                                                             
55% Start PNP MD Plugin                                                                                               
Start PNP MD Plugin ...ok                                                                                             
60% Start Voicemail Monitor                                                                                           
Start Voicemail Monitor ...ok                                                                                         
70% Configuring Pluto Storage Devices                                                                                 
Configuring Pluto Storage Devices ...Starting automounter: done.                                                       
 * Re-exporting directories for NFS kernel daemon...                                                                   
   ...done.                                                                                                           
Backing up old permissions files...                                                                                   
Setting up users...                                                                                                   
Setting up Global Static Directories...                                                                               
Setting up User Static Directories...                                                                                 
Setting up User Directories...                                                                                         
 * Reloading /etc/samba/smb.conf smbd only                                                                             
   ...done.                                                                                                           
 * Stopping Samba daemons                                                                                             
   ...done.                                                                                                           
 * Starting Samba daemons                                                                                             
   ...done.                                                                                                           
make: Entering directory `/var/yp'                                                                                     
make[1]: Entering directory `/var/yp/pluto'                                                                           
Updating passwd.byname...                                                                                             
Updating passwd.byuid...                                                                                               
Updating group.byname...                                                                                               
Updating group.bygid...                                                                                               
Updating netid.byname...                                                                                               
Updating shadow.byname...                                                                                             
make[1]: Leaving directory `/var/yp/pluto'                                                                             
make: Leaving directory `/var/yp'                                                                                     
Thu, 01 Oct 2009 18:13:50 -0500 : Disabling UpdateMediaDaemon on the system(s)                                         
Thu, 01 Oct 2009 18:13:50 -0500 : Enabling UpdateMediaDaemon on the system(s)                                         
 * Reloading /etc/samba/smb.conf smbd only                                                                             
   ...done.                                                                                                           
Creating /home/public paths...                                                                                         
Creating paths for each extra storage device...                                                                       

Thu, 01 Oct 2009 18:13:51 -0500 Removing old symlinks
/home/public/data/other/Windows Share [66]           
/home/public/data/other/Windows Share [64]           

Thu, 01 Oct 2009 18:13:51 -0500 Generating symlinks for storage device Windows Share (64)
/home/public/data/other/Windows Share [64] -> /mnt/device/64/                           

Thu, 01 Oct 2009 18:13:51 -0500 Generating symlinks for storage device Windows Share (66)
/home/public/data/other/Windows Share [66] -> /mnt/device/66/                           
/mnt/upnp is not a mountpoint                                                           
Checking MythTV storage group Default for host localhost...Ok                           
Checking MythTV storage group LiveTV for host localhost...Ok                             
Checking MythTV storage group public for host localhost...Ok                             
Checking MythTV storage group jimmejames for host localhost...Ok                         
Checking MythTV storage group Default for host dcerouter...Ok
Checking MythTV storage group LiveTV for host dcerouter...Ok
Checking MythTV storage group public for host dcerouter...Ok
Checking MythTV storage group jimmejames for host dcerouter...Ok
ok
 * Starting Samba daemons
   ...done.
75% Starting UPNP Server
Starting UPNP Server ...sed: can't read /etc/fuppes/fuppes.cfg: No such file or directory
sed: can't read /etc/fuppes/fuppes.cfg: No such file or directory
sed: can't read /etc/fuppes/fuppes.cfg: No such file or directory
/usr/pluto/bin/StorageDevices_UPNPServer.sh: line 50: /etc/init.d/fuppes: No such file or directory
fail
80% Samba Server Detection
Samba Server Detection ...Backgrounding ...
ok
85% Detecting Timezone
Detecting Timezone ...ok
90% Status Radar
Status Radar ...Backgrounding ...
ok
95% Samba Radar
Samba Radar ...Backgrounding ...
ok
100% PVR-250 tuner restore
PVR-250 tuner restore ...ok

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Error: cannot connect to router
« Reply #6 on: October 02, 2009, 01:20:34 am »
Whoa- Mercul- YOU DA MAN!

Let that run- tried starting the MD before the whole process finished and got the same cannot connect, after it kicked out all those errors and i posted and tried again.  It works this time... now get orbiter already started error...  but progress!!

samsung

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: Error: cannot connect to router
« Reply #7 on: October 02, 2009, 01:39:12 am »
yes murcel, that script did it for me after several attempts too thank you!!!

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Error: cannot connect to router
« Reply #8 on: October 02, 2009, 02:03:27 am »
Samsung-  two questions

1). Did you get the same errors as I did with the multiple tries and then fail and then the mysql errors?

2) are you getting the already started orbiter errors followed by the respawn?

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Error: cannot connect to router
« Reply #9 on: October 02, 2009, 03:30:10 am »
Well, for anyone following this, I rebooted and it fixed things....  not sure what happened, but a reboot stopped the "orbiter already started" and murcel's fix got the MDs going.

Still don't know anything about the mysql errors.  

And, after reboot/the fix, I was again not able to connect to the internet via computers connected to the internet through the core.  A "update" on the network pages of the admin site fixed this.  So, not sure what's next other than to see of the zwave works.


UPDATE:  Hmm, does this:   
Quote
/usr/pluto/bin/startup-script.sh
need to be run before starting each MD?
« Last Edit: October 02, 2009, 03:59:23 am by huh »

samsung

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: Error: cannot connect to router
« Reply #10 on: October 02, 2009, 03:44:58 pm »
Well, for anyone following this, I rebooted and it fixed things....  not sure what happened, but a reboot stopped the "orbiter already started" and murcel's fix got the MDs going.

Still don't know anything about the mysql errors.  

And, after reboot/the fix, I was again not able to connect to the internet via computers connected to the internet through the core.  A "update" on the network pages of the admin site fixed this.  So, not sure what's next other than to see of the zwave works.


UPDATE:  Hmm, does this:   
Quote
/usr/pluto/bin/startup-script.sh
need to be run before starting each MD?

after running the script one MD installed without a hitch, I did not reboot and tried a second md (ati x800 video card) that i had working in 7.10 but was giving me problems in 8.10. Not sure if it's the board itself or the card...anyway, after a few attempts without rebooting core or running the script again, the second older MD finally booted, went through the normal procedures and ran the av wizard. After getting through the wizard, it started to start the orbiter but came up with a error message stating that the device ## was invalid and it just froze up. After that i have been unable to get that MD to the av wizard again, it just hangs at "configuring network interfaces".

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Error: cannot connect to router
« Reply #11 on: October 02, 2009, 05:10:56 pm »
Mine sort of did that too- thought it was because my NAS was finally discovered and in the middle of the MD's installation I did a reload router- before this didn't cause an issue, but I got the NFS loop error.  After going into the admin pages, MANUALLY adding a "generic PC as MD" with my mac address and then starting the computer everything was running as usual- through the AVWizard and what not to that screen you just described with the invalid device. 

I was driving the web admin pages through an xp box with the win orbiter which shows up under orbiter (in the web admin pages) as something like a win xp/tablet oribiter.  When I got that error message you described, I found that another of these win xp/blah blah orbiters was created.   I deleted that oribiter and did a fully regen/restart fully expecting to have to blow away the MD I manually entered and hope everything worked, but after the regen/restart followed by a hard reset of the MD the rest of the process completed basically problem free. 

At some point in the install my cable modem went down so none of the packages downloaded- had to select UI1, reload regen, KDE desktop, restricted driver install (think I remember reading somewhere that you could just select openGL from the admin pages under your MD) and then quickly ran through the AVWizard again, selected the non-alpha, medium UI2 setting and left for work.  Killing me that I don't know if it worked...

samsung

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: Error: cannot connect to router
« Reply #12 on: October 02, 2009, 11:05:27 pm »
  After going into the admin pages, MANUALLY adding a "generic PC as MD" with my mac address and then starting the computer everything was running as usual- through the AVWizard and what not to that screen you just described with the invalid device. 


[/quote]

After doing that, the 810 problem MD works with UI2, it stuck at generating the orbiter, but after a md reboot, it works ok.  It seems as though anytime your reboot the core, that script needs to be run again.  Have you noticed a lag when using any i/o device, whether mouse or keyboard?  i'm getting a two sec lag when move through the UI2 menu.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5502
  • DOES work for LinuxMCE.
    • View Profile
Re: Error: cannot connect to router
« Reply #13 on: October 03, 2009, 01:36:44 am »
there should be absolutely zero reason for manually creating a media director.

-thom

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Error: cannot connect to router
« Reply #14 on: October 03, 2009, 03:33:57 am »
Not to be a smartass, but the reason I did it was that I seemed out of options that I knew how to do and more importantly it worked.   

Samsung- no, I can't seem to get the restricted nvidia drivers to install but other than that no issues, and certainly not the lag you described.   I have an old USB mouse and keyboard- nothing fancy and nothing else hooked up to the machine e.g. Bluetooth