Author Topic: digivox MINI II v.3.0, and kernel  (Read 1069 times)

rages

  • Guru
  • ****
  • Posts: 182
    • View Profile
digivox MINI II v.3.0, and kernel
« on: September 17, 2009, 06:03:39 pm »
Hi,

   
I bought the TV card indicated (USB), to make it work you have to upgrade the driver V4L-DVB as it says in this guide
http://www.linuxtv.org/wiki/index.php/MSI_DigiVox_mini_II_V3.0

but when I compile this with make, gives me errors because I haven't installed a kernel 2.6.31.

I can upgrade the kernel? if so, how can I do?

or are there other possibilities in your opinion?

Emanuele

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: digivox MINI II v.3.0, and kernel
« Reply #1 on: September 18, 2009, 07:45:06 pm »
generally you can upgrade the kernel, yes. google should be able to help you there.

Nuwis

  • Regular Poster
  • **
  • Posts: 43
    • View Profile
Re: digivox MINI II v.3.0, and kernel
« Reply #2 on: September 19, 2009, 06:59:50 pm »
Dear all,

If you have installed the Kernel Above 2.28 the V4L driver should be included in your kernel in this case if it is 2.31 it is ok. Meaby you havent activate the drivers inside the Kernel you can compile the Kernel following this rules:

http://www.howtoforge.com/kernel_compilation_ubuntu

I compiled the Kernel 2.31 for versions 7.10 and 8.10 to run my HVR-4000 with the built in modules for V4L-DVB, you can find it inside the Kernel built configuration on:
Device drivers-->Multimedia-->NEW DVB (or somethig like that)
But, if fit the drivers active inside que configuration of the Kernel never try to install the V4L-DVB drivers manually again or you will get a Kernel Panic (I tryed it)
It is my experience.

Bstrgrds
Frank Galan

An Spanish LMCE user
http://wiki.linuxmce.org/index.php/User:Nuwis

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: digivox MINI II v.3.0, and kernel
« Reply #3 on: September 25, 2009, 01:27:37 am »
Hi,

   
I bought the TV card indicated (USB), to make it work you have to upgrade the driver V4L-DVB as it says in this guide
http://www.linuxtv.org/wiki/index.php/MSI_DigiVox_mini_II_V3.0

but when I compile this with make, gives me errors because I haven't installed a kernel 2.6.31.

I can upgrade the kernel? if so, how can I do?

or are there other possibilities in your opinion?

Emanuele


Hi there,

We have a v4l package that may help you with this card. Its still undergoing some development but it is generally stable and has helped others to get their cards working. It uses dkms (you may need to install this package first) and will therefore build/install on any Kernel.

PM me here on the forum with your email address if you'd like to get a copy.

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

Nuwis

  • Regular Poster
  • **
  • Posts: 43
    • View Profile
Re: digivox MINI II v.3.0, and kernel
« Reply #4 on: September 28, 2009, 08:29:14 pm »
Hi Totally,
Do you have some package for HVR-4000?
I installed that and it´s running partial.
Frank Galan

An Spanish LMCE user
http://wiki.linuxmce.org/index.php/User:Nuwis

rages

  • Guru
  • ****
  • Posts: 182
    • View Profile
Re: digivox MINI II v.3.0, and kernel
« Reply #5 on: September 29, 2009, 09:07:42 pm »
Hi

when i tried to install v4l2-firmware, I have this error : Conflicts with the installed package 'linux-firmware'.

Emanuele

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: digivox MINI II v.3.0, and kernel
« Reply #6 on: September 29, 2009, 10:36:40 pm »
Hi

when i tried to install v4l2-firmware, I have this error : Conflicts with the installed package 'linux-firmware'.

Emanuele

Usually you dont need the firmware package if you install the 'modules' package first.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

rages

  • Guru
  • ****
  • Posts: 182
    • View Profile
Re: digivox MINI II v.3.0, and kernel
« Reply #7 on: September 30, 2009, 09:19:49 am »
Hi,



I install the module package, but my DVB-T device is not recognized.


Emanuele

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: digivox MINI II v.3.0, and kernel
« Reply #8 on: September 30, 2009, 10:13:57 am »
Hi,



I install the module package, but my DVB-T device is not recognized.


Emanuele

Hmmm... ok then it looks like you still dont have the right modules loaded I'm afraid.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

rages

  • Guru
  • ****
  • Posts: 182
    • View Profile
Re: digivox MINI II v.3.0, and kernel
« Reply #9 on: September 30, 2009, 10:39:21 am »
Hi,

Andrew, you have seen this link?
Seems to be easily recognized.


Emanuele