Author Topic: [SOLVED] Problem with upgrade to 20090903 (alpha 2.32)  (Read 771 times)

felpouse

  • Veteran
  • ***
  • Posts: 99
    • View Profile
[SOLVED] Problem with upgrade to 20090903 (alpha 2.32)
« on: September 04, 2009, 09:35:42 am »
Dear all,

I saw that was released a new update, with many fixes.

But at the end of the upgrading of pluto-system-database I encounter this problem :


Requesting update table: Template last batch: 61 last id: 30 extra batches:
Requested update
05      09/04/09 9:27:37.294            void ClientSocket::Disconnect() on this socket: 0x85764f0 (m_Socket: 5) <0xb7a12b20>
Transaction 0xbf89b25c is open.  Explicit Commit
Doing a Commit
Can't open perl script "/usr/pluto/bin/update2utf8.pl": No such file or directory
dpkg: error processing pluto-system-database (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 pluto-system-database
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Reading extended state information      
Initializing package states... Done

dcerouter_1001378:~#


I've checked that infact the file recalled from the process is not present on the system.
How could be fixed ?

Best regards

Luke
« Last Edit: September 04, 2009, 05:22:32 pm by felpouse »

felpouse

  • Veteran
  • ***
  • Posts: 99
    • View Profile
Re: Problem with upgrade to 20090903 (alpha 2.32)
« Reply #1 on: September 04, 2009, 12:43:51 pm »
Dear all,

I'd downloaded the perl script from your svn site, put it in /usr/pluto/bin and restart aptitude update and aptitude dist-upgrade.

Now the pluto-system-database complete successfully the procedure and a video I saw the conversion in utf-8 of all the tables. I hope.

No other encounter in this issue ?

Regards

Luke

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Problem with upgrade to 20090903 (alpha 2.32)
« Reply #2 on: September 04, 2009, 04:55:33 pm »
per discussion on irc, there was a mistake in the release that has now been fixed. please try the upgrade again.

felpouse

  • Veteran
  • ***
  • Posts: 99
    • View Profile
Re: Problem with upgrade to 20090903 (alpha 2.32)
« Reply #3 on: September 04, 2009, 05:21:24 pm »
Hi Merkur,

thanks , now it's working perfectly. And also the file that was missing now is present.

Regards,

Luke