Author Topic: 0.40 mysql related upgrade problems  (Read 1969 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
0.40 mysql related upgrade problems
« on: August 25, 2006, 07:12:03 pm »
Hi,

I'm getting these errors when upgrading to 0.40.

First there was libxine1 missing and I did apt-get install libxine1.

Then a bunch of errors that point to some missing tables in mysql. I don't dare to mess with database, so would kindly ask for advice, how to solve this one below....

Thanks in advance,

regards,

Rob.


Code: newbielink:javascript:void(0); [nonactive]
dcerouter_260:~$ apt-get install pluto-audi-database
Reading package lists... Done
Building dependency tree... Done
pluto-audi-database is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
11 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up pluto-audi-database (2.0.0.40) ...


Setting up audi database.
****This may take a long time****
This involves merging all the changes from the
central database back into your local copy.
Please be patient.......
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
 This program is free software; you can redistribute it
 and/or modify it under the terms of the GNU General Public License.
 This program is distributed in the hope that it will be useful,
 but WITHOUT ANY WARRANTY; without even the implied warranty
 of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 See the GNU General Public License for more details.
-------

Database host:localhost user:root pass: name:pluto_main port:3306
Users:
Could not find all the system tables for Repository: constants
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
Could not find all the system tables for Repository: dce
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
Could not find all the system tables for Repository: local
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
01      08/25/06 18:17:56.484           Query failed (Table 'pluto_main.psc_constants_repset' doesn't exist): SELECT Value FROM `psc_constants_repset` WHERE Setting='schema' (-1)
05      08/25/06 18:17:56.484           Resetting mysql connection
01      08/25/06 18:17:56.485           Query failed (Table 'pluto_main.psc_constants_repset' doesn't exist): INSERT INTO `psc_constants_repset` (Setting,Value) VALUES('schema','1') (-1)
05      08/25/06 18:17:56.485           Resetting mysql connection
SQL Failed: INSERT INTO `psc_constants_repset` (Setting,Value) VALUES('schema','1')
Caught exception: Database error
***DATABASE SCHEMA INVALID. IMPORT IS THE ONLY VALID OPTION***
01      08/25/06 18:17:56.648           Query failed (Error writing file './pluto_main/psc_dce_repset.frm' (Errcode: 28)): CREATE TABLE `psc_dce_repset` ( `PK_psc_dce_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_dce_repset` ) ) TYPE=InnoDB (-1)
05      08/25/06 18:17:56.648           Resetting mysql connection
SQL Failed: CREATE TABLE `psc_dce_repset` ( `PK_psc_dce_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_dce_repset` ) ) TYPE=InnoDB
Caught exception: Database error
dpkg: error processing pluto-audi-database (--configure):
 subprocess post-installation script returned error exit status 1
Setting up pluto-system-database (2.0.0.40) ...


Setting up system database.
****This may take a long time****
This involves merging all the changes from the
central database back into your local copy.
Please be patient.......
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
 This program is free software; you can redistribute it
 and/or modify it under the terms of the GNU General Public License.
 This program is distributed in the hope that it will be useful,
 but WITHOUT ANY WARRANTY; without even the implied warranty
 of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 See the GNU General Public License for more details.
-------

Database host:localhost user:root pass: name:pluto_main port:3306
Users:
Could not find all the system tables for Repository: constants
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
Could not find all the system tables for Repository: dce
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
Could not find all the system tables for Repository: local
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
01      08/25/06 18:17:56.945           Query failed (Table 'pluto_main.psc_constants_repset' doesn't exist): SELECT Value FROM `psc_constants_repset` WHERE Setting='schema' (-1)
05      08/25/06 18:17:56.946           Resetting mysql connection
01      08/25/06 18:17:56.946           Query failed (Table 'pluto_main.psc_constants_repset' doesn't exist): INSERT INTO `psc_constants_repset` (Setting,Value) VALUES('schema','1') (-1)
05      08/25/06 18:17:56.946           Resetting mysql connection
SQL Failed: INSERT INTO `psc_constants_repset` (Setting,Value) VALUES('schema','1')
Caught exception: Database error
***DATABASE SCHEMA INVALID. IMPORT IS THE ONLY VALID OPTION***
01      08/25/06 18:17:56.967           Query failed (Error writing file './pluto_main/psc_constants_repset.frm' (Errcode: 28)): CREATE TABLE `psc_constants_repset` ( `PK_psc_constants_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_constants_repset` ) ) TYPE=InnoDB (-1)
05      08/25/06 18:17:56.967           Resetting mysql connection
SQL Failed: CREATE TABLE `psc_constants_repset` ( `PK_psc_constants_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_constants_repset` ) ) TYPE=InnoDB
Caught exception: Database error
dpkg: error processing pluto-system-database (--configure):
 subprocess post-installation script returned error exit status 1
Setting up pluto-media-database (2.0.0.40) ...
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
 This program is free software; you can redistribute it
 and/or modify it under the terms of the GNU General Public License.
 This program is distributed in the hope that it will be useful,
 but WITHOUT ANY WARRANTY; without even the implied warranty
 of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 See the GNU General Public License for more details.
-------

Database host:localhost user:root pass: name:pluto_media port:3306
Users:
Could not find all the system tables for Repository: media
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
01      08/25/06 18:17:57.021           Query failed (Table 'pluto_media.psc_media_repset' doesn't exist): SELECT Value FROM `psc_media_repset` WHERE Setting='schema' (-1)
05      08/25/06 18:17:57.021           Resetting mysql connection
01      08/25/06 18:17:57.022           Query failed (Table 'pluto_media.psc_media_repset' doesn't exist): INSERT INTO `psc_media_repset` (Setting,Value) VALUES('schema','1') (-1)
05      08/25/06 18:17:57.022           Resetting mysql connection
SQL Failed: INSERT INTO `psc_media_repset` (Setting,Value) VALUES('schema','1')
Caught exception: Database error
***DATABASE SCHEMA INVALID. IMPORT IS THE ONLY VALID OPTION***
01      08/25/06 18:17:57.047           Query failed (Error writing file './pluto_media/psc_media_repset.frm' (Errcode: 28)): CREATE TABLE `psc_media_repset` ( `PK_psc_media_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_media_repset` ) ) TYPE=InnoDB (-1)
05      08/25/06 18:17:57.047           Resetting mysql connection
SQL Failed: CREATE TABLE `psc_media_repset` ( `PK_psc_media_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_media_repset` ) ) TYPE=InnoDB
Caught exception: Database error
dpkg: error processing pluto-media-database (--configure):
 subprocess post-installation script returned error exit status 1
Setting up pluto-security-database (2.0.0.40) ...
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
 This program is free software; you can redistribute it
 and/or modify it under the terms of the GNU General Public License.
 This program is distributed in the hope that it will be useful,
 but WITHOUT ANY WARRANTY; without even the implied warranty
 of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 See the GNU General Public License for more details.
-------

Database host:localhost user:root pass: name:pluto_security port:3306
Users:
Could not find all the system tables for Repository: security
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
01      08/25/06 18:17:57.095           Query failed (Table 'pluto_security.psc_security_repset' doesn't exist): SELECT Value FROM `psc_security_repset` WHERE Setting='schema' (-1)
05      08/25/06 18:17:57.095           Resetting mysql connection
01      08/25/06 18:17:57.095           Query failed (Table 'pluto_security.psc_security_repset' doesn't exist): INSERT INTO `psc_security_repset` (Setting,Value) VALUES('schema','1') (-1)
05      08/25/06 18:17:57.096           Resetting mysql connection
SQL Failed: INSERT INTO `psc_security_repset` (Setting,Value) VALUES('schema','1')
Caught exception: Database error
***DATABASE SCHEMA INVALID. IMPORT IS THE ONLY VALID OPTION***
01      08/25/06 18:17:57.106           Query failed (Error writing file './pluto_security/psc_security_repset.frm' (Errcode: 28)): CREATE TABLE `psc_security_repset` ( `PK_psc_security_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_security_repset` ) ) TYPE=InnoDB (-1)
05      08/25/06 18:17:57.106           Resetting mysql connection
SQL Failed: CREATE TABLE `psc_security_repset` ( `PK_psc_security_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_security_repset` ) ) TYPE=InnoDB
Caught exception: Database error
dpkg: error processing pluto-security-database (--configure):
 subprocess post-installation script returned error exit status 1
Setting up pluto-telecom-database (2.0.0.40) ...
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
 This program is free software; you can redistribute it
 and/or modify it under the terms of the GNU General Public License.
 This program is distributed in the hope that it will be useful,
 but WITHOUT ANY WARRANTY; without even the implied warranty
 of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 See the GNU General Public License for more details.
-------

Database host:localhost user:root pass: name:pluto_telecom port:3306
Users:
Could not find all the system tables for Repository: telecom
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
01      08/25/06 18:17:57.181           Query failed (Table 'pluto_telecom.psc_telecom_repset' doesn't exist): SELECT Value FROM `psc_telecom_repset` WHERE Setting='schema' (-1)
05      08/25/06 18:17:57.181           Resetting mysql connection
01      08/25/06 18:17:57.182           Query failed (Table 'pluto_telecom.psc_telecom_repset' doesn't exist): INSERT INTO `psc_telecom_repset` (Setting,Value) VALUES('schema','1') (-1)
05      08/25/06 18:17:57.182           Resetting mysql connection
SQL Failed: INSERT INTO `psc_telecom_repset` (Setting,Value) VALUES('schema','1')
Caught exception: Database error
***DATABASE SCHEMA INVALID. IMPORT IS THE ONLY VALID OPTION***
01      08/25/06 18:17:57.194           Query failed (Error writing file './pluto_telecom/psc_telecom_repset.frm' (Errcode: 28)): CREATE TABLE `psc_telecom_repset` ( `PK_psc_telecom_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_telecom_repset` ) ) TYPE=InnoDB (-1)
05      08/25/06 18:17:57.194           Resetting mysql connection
SQL Failed: CREATE TABLE `psc_telecom_repset` ( `PK_psc_telecom_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_telecom_repset` ) ) TYPE=InnoDB
Caught exception: Database error
dpkg: error processing pluto-telecom-database (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of pluto-std-plugins:
 pluto-std-plugins depends on pluto-system-database (>= 2.0.0.40); however:
  Package pluto-system-database is not configured yet.
 pluto-std-plugins depends on pluto-system-database (<< 2.0.0.41); however:
  Package pluto-system-database is not configured yet.
 pluto-std-plugins depends on pluto-media-database (>= 2.0.0.40); however:
  Package pluto-media-database is not configured yet.
 pluto-std-plugins depends on pluto-media-database (<< 2.0.0.41); however:
  Package pluto-media-database is not configured yet.
 pluto-std-plugins depends on pluto-security-database (>= 2.0.0.40); however:
  Package pluto-security-database is not configured yet.
 pluto-std-plugins depends on pluto-security-database (<< 2.0.0.41); however:
  Package pluto-security-database is not configured yet.
 pluto-std-plugins depends on pluto-telecom-database (>= 2.0.0.40); however:
  Package pluto-telecom-database is not configured yet.
 pluto-std-plugins depends on pluto-telecom-database (<< 2.0.0.41); however:
  Package pluto-telecom-database is not configured yet.
dpkg: error processing pluto-std-plugins (--configure):
 dependency problems - leaving unconfigured
Setting up pluto-local-database (2.0.0.40) ...
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
 This program is free software; you can redistribute it
 and/or modify it under the terms of the GNU General Public License.
 This program is distributed in the hope that it will be useful,
 but WITHOUT ANY WARRANTY; without even the implied warranty
 of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 See the GNU General Public License for more details.
-------

Database host:localhost user:root pass: name:pluto_main port:3306
Users:
Could not find all the system tables for Repository: constants
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
Could not find all the system tables for Repository: dce
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
Could not find all the system tables for Repository: local
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
01      08/25/06 18:17:57.554           Query failed (Table 'pluto_main.psc_constants_repset' doesn't exist): SELECT Value FROM `psc_constants_repset` WHERE Setting='schema' (-1)
05      08/25/06 18:17:57.554           Resetting mysql connection
01      08/25/06 18:17:57.555           Query failed (Table 'pluto_main.psc_constants_repset' doesn't exist): INSERT INTO `psc_constants_repset` (Setting,Value) VALUES('schema','1') (-1)
05      08/25/06 18:17:57.555           Resetting mysql connection
SQL Failed: INSERT INTO `psc_constants_repset` (Setting,Value) VALUES('schema','1')
Caught exception: Database error
***DATABASE SCHEMA INVALID. IMPORT IS THE ONLY VALID OPTION***
01      08/25/06 18:17:57.584           Query failed (Error writing file './pluto_main/psc_local_repset.frm' (Errcode: 28)): CREATE TABLE `psc_local_repset` ( `PK_psc_local_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_local_repset` ) ) TYPE=InnoDB (-1)
05      08/25/06 18:17:57.584           Resetting mysql connection
SQL Failed: CREATE TABLE `psc_local_repset` ( `PK_psc_local_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_local_repset` ) ) TYPE=InnoDB
Caught exception: Database error
dpkg: error processing pluto-local-database (--configure):
 subprocess post-installation script returned error exit status 1
Setting up pluto-updatemedia (2.0.0.40) ...
/var/lib/dpkg/info/pluto-updatemedia.postinst: line 62: 19867 Segmentation fault      (core dumped) /usr/pluto/bin/UpdateMedia -t -s -d /home/public/data
dpkg: error processing pluto-updatemedia (--configure):
 subprocess post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of pluto-website-admin:
 pluto-website-admin depends on pluto-updatemedia (>= 2.0.0.40); however:
  Package pluto-updatemedia is not configured yet.
 pluto-website-admin depends on pluto-updatemedia (<< 2.0.0.41); however:
  Package pluto-updatemedia is not configured yet.
dpkg: error processing pluto-website-admin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pluto-dcerouter:
 pluto-dcerouter depends on pluto-std-plugins (>= 2.0.0.40); however:
  Package pluto-std-plugins is not configured yet.
 pluto-dcerouter depends on pluto-std-plugins (<< 2.0.0.41); however:
  Package pluto-std-plugins is not configured yet.
 pluto-dcerouter depends on pluto-system-database (>= 2.0.0.40); however:
  Package pluto-system-database is not configured yet.
 pluto-dcerouter depends on pluto-system-database (<< 2.0.0.41); however:
  Package pluto-system-database is not configured yet.
 pluto-dcerouter depends on pluto-local-database (>= 2.0.0.40); however:
  Package pluto-local-database is not configured yet.
 pluto-dcerouter depends on pluto-local-database (<< 2.0.0.41); however:
  Package pluto-local-database is not configured yet.
 pluto-dcerouter depends on pluto-website-admin (>= 2.0.0.40); however:
  Package pluto-website-admin is not configured yet.
 pluto-dcerouter depends on pluto-website-admin (<< 2.0.0.41); however:
  Package pluto-website-admin is not configured yet.
dpkg: error processing pluto-dcerouter (--configure):
 dependency problems - leaving unconfigured
Setting up pluto-mythtv-plugin (2.0.0.40) ...
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
 This program is free software; you can redistribute it
 and/or modify it under the terms of the GNU General Public License.
 This program is distributed in the hope that it will be useful,
 but WITHOUT ANY WARRANTY; without even the implied warranty
 of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 See the GNU General Public License for more details.
-------

Database host:localhost user:root pass: name:pluto_myth port:3306
Users:
Could not find all the system tables for Repository: myth
I need _repset, _bathdr, _batuser, _batdet, _tables
This repository has been corrupted, and will need to be rebuilt in order to continue.
01      08/25/06 18:17:57.911           Query failed (Table 'pluto_myth.psc_myth_repset' doesn't exist): SELECT Value FROM `psc_myth_repset` WHERE Setting='schema' (-1)
05      08/25/06 18:17:57.911           Resetting mysql connection
01      08/25/06 18:17:57.912           Query failed (Table 'pluto_myth.psc_myth_repset' doesn't exist): INSERT INTO `psc_myth_repset` (Setting,Value) VALUES('schema','1') (-1)
05      08/25/06 18:17:57.912           Resetting mysql connection
SQL Failed: INSERT INTO `psc_myth_repset` (Setting,Value) VALUES('schema','1')
Caught exception: Database error
***DATABASE SCHEMA INVALID. IMPORT IS THE ONLY VALID OPTION***
01      08/25/06 18:17:57.923           Query failed (Error writing file './pluto_myth/psc_myth_repset.frm' (Errcode: 28)): CREATE TABLE `psc_myth_repset` ( `PK_psc_myth_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_myth_repset` ) ) TYPE=InnoDB (-1)
05      08/25/06 18:17:57.923           Resetting mysql connection
SQL Failed: CREATE TABLE `psc_myth_repset` ( `PK_psc_myth_repset` int(11) NOT NULL  default NULL auto_increment, `Setting` varchar(30) NOT NULL  , `Value` text default NULL , PRIMARY KEY( `PK_psc_myth_repset` ) ) TYPE=InnoDB
Caught exception: Database error
dpkg: error processing pluto-mythtv-plugin (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 pluto-audi-database
 pluto-system-database
 pluto-media-database
 pluto-security-database
 pluto-telecom-database
 pluto-std-plugins
 pluto-local-database
 pluto-updatemedia
 pluto-website-admin
 pluto-dcerouter
 pluto-mythtv-plugin
E: Sub-process /usr/bin/dpkg returned an error code (1)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
0.40 mysql related upgrade problems
« Reply #1 on: August 25, 2006, 09:59:16 pm »
Hi,

further problems. After reboot, core hangs at "starting DCERouter" step - it gives no command line or consoles and can only be remotely ssh-ed. Networking is not working (you can access outside only out of Core - no ssh from outside).

DCERouter is crashing every few seconds leaving coredumps filling up disk....

How to generally tackle such problems ?

Pardon for my lack of Linux knowledge - but is it possible to give consoles and network running before DCERouter starts ? Cause if DCERouter for some reason fails, situation is hard to deal, particularly for end user. Does this make sense ?

Thanks in advance,

regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
0.40 mysql related upgrade problems
« Reply #2 on: August 26, 2006, 01:59:25 pm »
Hi Rob

I'm more or less in the same boat.

At first upgrade attempt there was strange error, and in the end apt-get upgrade was not upgrading 103 packages.

Then I installed gnupg, and something moved on, but still had to install via apt-get the xserver. Then it seems that all packages have been upgraded, linux starts now with new kernel, but still I reboot and stumble in DCE Router Starting, or Starting Local Devices.

I can ssh to my box, but for instance I cannot start vncserver (that is really pity for me as I use this box also for other stuff).

I didn't notice mysql failures, will look some logs to make sure of it.

At this point I am at a dead end.

One idea I have is to remove manually all pluto packages and then reinstall, but if some brighter idea comes out I'll be pleased to try it.

Regards
Marco

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
0.40 mysql related upgrade problems
« Reply #3 on: August 26, 2006, 02:33:30 pm »
Hi,

thanks for info. Well errors stated above are quite explicit. My mysql database obviously didn't upgrade with additional fields and I have 8 packages broken waiting for that to happen.

But what worries me more is that under new 2.6.16 kernel my machine freezes in #loading modules stage and I cannot do anything with it. If I start it with older kernel it stucks at DCERoter starting - and it slowly fills disk with cores and logs. Network doesn't work at that stage, so I'm not sure how this one will be solved....

Surely not a nice thing for a bulletproof end user like system....

Regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
0.40 mysql related upgrade problems
« Reply #4 on: August 27, 2006, 06:53:08 pm »
Small update:

I've cleaned up all old packages/config files and I copied an ApplyUpdates.sh file from a working .39 hybrid. I copied also Config_Ops.sh and SQL_Ops.sh.

Then I ran ApplyUpdates, ant from that point I have a system that is continuously rebooting.

It boots with Pluto logo, reaches the "Updating system" status, then an update script is launched (hitting some deb repositories) then a message appears saying that system will reboot in 10 seconds.

Then again, and again, and again ....

The only way to stop this is to boot in recovery mode, but this unfortunately prevents network from working.

At this point my box is totally useless.

Is there any way to try to recover it?

Regards
MarcoZan

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
0.40 mysql related upgrade problems
« Reply #5 on: August 28, 2006, 12:14:53 pm »
Another update

I've succeeded in stopping the continuously rebooting process by renaming ApplyUpdates.sh in /usr/pluto/bin.

Now system boots and stops in "StartingLocalDevices" status.

As an additional notes I say that on boot some error messages related to udevd. They are showing for very short time, but basically they are saying that some udev rule is wrong.

These messages are not showing if I boot with previous kernel.

I can ssh to my box. Apache is working, but PlutoAdmin site is not showing. A directory listing is showed instead. Apache and PHP are ok, as I have other web stuff on the same box ant these are working fine.

So I think that something during the upgrade went definitely wrong.

Again the question is: can I recover my box by re-firing somehow the upgrade process?

Thanks and regards
Marco