Author Topic: Errors upgrading to .12 release  (Read 3098 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Errors upgrading to .12 release
« on: March 20, 2005, 08:31:53 am »
Hi,

I caught this errors when my Pluto was upgraded to 0.12 release.

10      03/20/05 8:36:20.534            Executed query UPDATE DeviceTemplate_DeviceCategory_ControlledVia SET  `PK_DeviceTemplate_DeviceCategory_ControlledVia`='4638', `FK_DeviceTemplate`='1602', `FK_DeviceCategory`='7', `Description`=NULL, `RerouteMessagesToParent`='0', `AutoCreateChildren`='0', `psc_id`='1575', `psc_batch`=NULL, `psc_user`=NULL, `psc_frozen`='0', `psc_mod`='0' WHERE psc_id=1575
01      03/20/05 8:36:20.534            Query failed (Duplicate entry '4639' for key 1): INSERT INTO DeviceTemplate_DeviceCategory_ControlledVia VALUES( '4639','69','6',NULL,'0','0','1576',NULL,NULL,'0','0' ) (-1)
05      03/20/05 8:36:20.535            Resetting mysql connection
10      03/20/05 8:36:20.535            Executed query INSERT INTO DeviceTemplate_DeviceCategory_ControlledVia VALUES( '4639','69','6',NULL,'0','0','1576',NULL,NULL,'0','0' )
SQL Failed: INSERT INTO DeviceTemplate_DeviceCategory_ControlledVia VALUES( '4639','69','6',NULL,'0','0','1576',NULL,NULL,'0','0' )
Caught exception: Database error
dpkg: error processing pluto-system-database (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of pluto-dcerouter:
 pluto-dcerouter depends on pluto-system-database; however:
  Package pluto-system-database is not configured yet.
dpkg: error processing pluto-dcerouter (--configure):
 dependency problems - leaving unconfigured


Any advice ?

Thanks,

regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Errors upgrading to .12 release
« Reply #1 on: March 20, 2005, 09:34:38 am »
Ouch.  That shouldn't have happened.  This is from sqlCVS when it's merging in database changes we made into your local copy.  The field psc_id is the globally unique id sqlCVS assigns to each row to track changes.  On the surface, this appears to indicate that we added a new record in that table for device template #69 (Generic Serial Device) and Device Category #6 (Computers), but that you already had made such an addition yourself into your local copy, therefore, the merge failed.  But, that seems pretty unlikely.  So, can you ssh over to the Core, run mysql, then type:
use pluto_main;

and then copy/paste the following queries.  For each query, copy/paste the results and post them as a reply to this message.  Sorry about this.

SELECT * FROM DeviceTemplate_DeviceCategory_ControlledVia WHERE PK_DeviceTemplate_DeviceCategory_ControlledVia>4637;


SELECT * FROM DeviceTemplate_DeviceCategory_ControlledVia WHERE FK_DeviceTemplate=69;

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Errors upgrading to .12 release
« Reply #2 on: March 20, 2005, 10:55:57 am »
Actually, never mind.  I found the error.  The table in question has an auto-increment primary key.  You added a record locally (probably one of your own device templates) which added a record with the primary key 4639, and in between 2.0.0.11 and .12 we also added a new device template with that same primary key.

During a 'normal' sqlcvs update (ie syncing with the live host), sqlCVS handles this and re-locates conflicting ID's on your local machine.  However I see that it's not doing this during an update from within a debian package.  I'm fixing this now, and will put a new sqlCVS binary up that fixes this.  Then you can use that binary and it should work.  I'll post a message when I get this going ...  Give me a couple hours.  Thanks.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Errors upgrading to .12 release
« Reply #3 on: March 20, 2005, 11:26:31 am »
I posted a fixed sqlCVS.  I tested it locally by adding a new device template locally and doing an update, confirmed the error during upgrade, and this fixed the problem.  You'll need to ssh over to the core and do this:

cd /usr/pluto/bin
mv sqlCVS sqlCVS.orig
wget plutohome.com/download/sqlCVS.tar.gz
tar zxvf sqlCVS.tar.gz

That will update your sqlCVS binary with the fixed one.  Now you can run:

dpkg --configure

and that should cause it re-attempt to apply the update pluto-system-database package from the 2.0.0.12 update.  This time it should work.  When you're finished, you can do:

dpkg -l "*pluto*"

That will list all the pluto packages.  They should all be version 2.0.0.12, and the status for each should be ii (meaning installed okay).

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Errors upgrading to .12 release
« Reply #4 on: March 20, 2005, 06:00:04 pm »
Quote from: "aaron.b"
I posted a fixed sqlCVS.  I tested it locally by adding a new device template locally and doing an update, confirmed the error during upgrade, and this fixed the problem.  You'll need to ssh over to the core and do this:

cd /usr/pluto/bin
mv sqlCVS sqlCVS.orig
wget plutohome.com/download/sqlCVS.tar.gz
tar zxvf sqlCVS.tar.gz

That will update your sqlCVS binary with the fixed one.  Now you can run:

dpkg --configure

and that should cause it re-attempt to apply the update pluto-system-database package from the 2.0.0.12 update.  This time it should work.  When you're finished, you can do:

dpkg -l "*pluto*"

That will list all the pluto packages.  They should all be version 2.0.0.12, and the status for each should be ii (meaning installed okay).


Hi,

thanks for help. I followed instructions and dpkg --configure complained that it needs package info. Then I just did it my (probably dirty way). Did install HP printer packages (in quest for print server) in parallel and those packages were updated. Error repeated once with another ID, and after second restart it went away, but also dcerouter appeared as not correctly configured. So I remove it and installed again (probably not wise idea).

Somewhere on this way I got into trap, where I'm getting some strange errors with apt-get update - for instance :

Code: newbielink:javascript:void(0); [nonactive]

dcerouter:~/Plutohome# apt-get update
Nap http://deb.plutohome.com sarge/main Packages
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com sarge/main Release
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com sarge/non-free Packages
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com sarge/non-free Release
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com sarge/contrib Packages
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com sarge/contrib Release
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com 20dev/main Packages
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com 20dev/main Release
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com replacements/main Packages
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com replacements/main Release
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com unstable/mythtv Packages
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com unstable/mythtv Release
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com 20dev/contrib Packages
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Nap http://deb.plutohome.com 20dev/contrib Release
  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Prz file: sarge/main Release
Zadetek ftp://ftp.nerim.net unstable/main Packages
Zadetek ftp://ftp.nerim.net unstable/main Release
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/sarge/main/binary-i386/Packages.gz  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/sarge/main/binary-i386/Release  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/sarge/non-free/binary-i386/Packages.gz  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/sarge/non-free/binary-i386/Release  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/sarge/contrib/binary-i386/Packages.gz  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/sarge/contrib/binary-i386/Release  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/20dev/main/binary-i386/Packages.gz  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/20dev/main/binary-i386/Release  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/replacements/main/binary-i386/Packages.gz  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/replacements/main/binary-i386/Release  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/unstable/mythtv/binary-i386/Packages.gz  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/unstable/mythtv/binary-i386/Release  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/20dev/contrib/binary-i386/Packages.gz  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Ni mogoèe dobiti http://deb.plutohome.com/debian/dists/20dev/contrib/binary-i386/Release  Ni se mogoèe povezati z 127.0.0.1:8123 (127.0.0.1). - connect (111 Connection refused)
Branje seznama paketov... Narejeno
W: Ni mogoèe doloèiti seznama izvornih paketov http://deb.plutohome.com 20dev/contrib Packages (/var/lib/apt/lists/deb.plutohome.com_debian_dists_20dev_contrib_binary-i386_Packages) - stat (2 No such file or directory)
W: Èe ¾elite odpraviti te¾ave, poskusite zagnati apt-get update.
E: Nekaterih kazal ni mogoèe prenesti, zato so preklicana, ali pa so uporabljena starej¹a.

Sorry but those messages are in slovenian, if someone tells me how to simply switch to english ...

I'll try to translate :

First it's complaining that it cannot connect to 127.0.0.1:8123 (I've added this port to Firewall, but no go). Then it appears as looking for some package lists that doesn't exist and also for above error. Can I somehow regenerate package lists to correct state ? What could I do to get into clean state ?  

I'm sorry for asking such newbie questions, I remember that installing some other packages on customized Debian distros is a bad idea, but I wanted to set home printer server ...

Any advice on where to send more general Debian Sarge related questions to get quick responses ? It seems like I'll need it more often that I expected ...

Regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Errors upgrading to .12 release
« Reply #5 on: March 20, 2005, 06:06:32 pm »
Sorry, I haven't got a clue--I know nothing about the apt-get stuff.  Radu's in charge of that stuff.  I'll ask him to reply when he comes in tomorrow.