Author Topic: DVB card SkyStar1 is not recognized in the new kernel [FIX]  (Read 1156 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
DVB card SkyStar1 is not recognized in the new kernel [FIX]
« on: August 24, 2006, 03:56:10 pm »
Hi,

I have a DVB card SkyStar1 which worked fine in the Plutohome 2.0.0.39. But after upgrade the code doesn't recognize it anymore. The card is present in the system (lspci):
Code: newbielink:javascript:void(0); [nonactive]
Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
Modules are loaded (saa7146, saa7146_vv, dvb-ttpci etc) but the card is not recognized (device /dev/dvb is missing). I don't seeany error in the logs or dmesg.

This is a peace of kern.log:
Aug 23 02:45:05 192.168.80.2 kernel: cx2388x dvb driver version 0.0.5 loaded
Code: newbielink:javascript:void(0); [nonactive]
Aug 23 02:45:05 192.168.80.2 kernel: ivtv:  ==================== START INIT IVTV ====================
Aug 23 02:45:05 192.168.80.2 kernel: ivtv:  version 0.6.1 (tagged release) loading
Aug 23 02:45:05 192.168.80.2 kernel: ivtv:  Linux version: 2.6.16.20-pluto-1-686 686 gcc-3.3
Aug 23 02:45:06 192.168.80.2 kernel: ivtv:  In case of problems please include the debug info between
Aug 23 02:45:06 192.168.80.2 kernel: ivtv:  the START INIT IVTV and END INIT IVTV lines, along with
Aug 23 02:45:06 192.168.80.2 kernel: ivtv:  any module options, when mailing the ivtv-users mailinglist.
Aug 23 02:45:06 192.168.80.2 kernel: ivtv:  ====================  END INIT IVTV  ====================


Any ideas how to solve it?

Thanks in advance.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
SOLVED
« Reply #1 on: September 21, 2006, 12:41:59 pm »
The problem was related with upgrade from the kernel 2.5 to 2.6. 2.6 uses new device management ideology - udev and, as I understand, the upgrade was not correct.

I made a fresh installation of version 2.0.0.40 and added driver stradis into modprobe blacklist to avoid conflict with saa7146. After that /dev/dvb was created and LiveTV started work properly.

My suggestions: do not do upgrade. You'll waste your time. Install new version from the beginning.
Basically, it isn't good idea to use developer version of the kernel (all odd versions are developer)