Author Topic: HDHomerun MythTV and MD help  (Read 1172 times)

Kaelix

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
HDHomerun MythTV and MD help
« on: August 22, 2009, 05:21:31 am »
I've got a problem that I've been trying to solve for the better part of a week now, I'm at the point where I need some help. I've looked through the forums and the wiki and can't seem to find the answer.

I have a core/hybrid running alpha 2.26. I have a HDHomerun on the network which MythTV is configured for and TV watching works fine (on the core/hybrid). Last week I tried to add a P4 3.2Ghz 2GB RAM with a nvidia 6600GT as a diskless MD in the bedroom. Just plugged it into the network, everything was discovered, nvidia 180.11 was installed, I can watch video from the NAS on it, everything seemed to work well with just the default stuff from the network and A/V wizard.

Then i tried to watch liveTV in mythTV. I get as far seeing the gui (what channel it currently is, and not always this far) then everything goes black. I've waited up to half an hour for something to happen and nothing, it seems the MD freezes.

I've tried setting the backendserver in mythtvfrontend to the ip address of the core. I've tailed the Mythbackend.log file, and nothing seems out of the ordinary compared to when i watch liveTV on the core/hybrid. I've done ls -lat | head -20 in var/log/pluto and the Spawn_Mythtvfrontend_XXX.log never seems to be at the top of the recently written logs (if i look at just the logs with those names it's hard to tell which is which). I've set the MD hardware acceleration on the admin site to xv, reload router, reboot everything - same thing. I've it to opengl, reload router, reboot everything - same thing.

I really don't know what logs I should be looking at anymore or how to get this working.If boot the machine with 810 kubuntu live cd, install and run mythtvfrontend it works fine, choppy video, but I do see video. Could it be something with nvidia drivers? is there a known bug? The core/hybrid has an 8300GS and the same nvidia driver, why does it work there....

(I've tried all the above steps with an AMD san diego 3700+ (nforce 3 chipset) 2GB RAM and nvidia 7800GS as the MD and I get the same result. )

Kaelix

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: HDHomerun MythTV and MD help
« Reply #1 on: August 24, 2009, 07:37:22 pm »
Follow-up post to this since there have been no replies maybe someone can me with this new information. I've been reading the mythTV forums and the mythTV wiki.  The default playback profile that was setup on the MD up is CPU+ which uses XvMC to offload some of the encoding from the cpu. I changed MythTV's playback profile to 'Normal','Slim', or 'CPU++' and LiveTV works, although choppy sometimes, because those profiles only use software rendering (ffmpeg with xv-blit). So it seems that both my MDs (nvidia 6600GT and 7800GS) should be able to take advantage of XvMC but they crash.

I've checked XvMC using these instructions from the mythtv wiki
Quote
Checking your installation

You will have to reboot. To check if XvMC is properly enabled, run:
$ cat /var/log/Xorg.0.log | grep Motion
and you should see:
(II) Loading extension XVideo-MotionCompensation

If you try: cat /var/log/Xorg.0.log | grep -i XvMC your driver might also report loading the options such as:
(**) NVIDIA(0): Option "XvMCUsesTextures" "True"
with VIA SP13000 this will be:
(II) CHROME(0): [XvMC] Registering chromeXvMCPro.
(II) CHROME(0): [XvMC] Initialized XvMC extension.
Success!

Based on the instructions above it appears XvMC is correctly installed. When i try to watch liveTV with player profile that uses XvMC i get the following entries in the terminal window
(sorry noob poster as well, log snapshot in attachment)

The signal i'm receiving from the HDHomerun is OTA with an HD antenna. Anyone have any idea how I correct this issue?