Author Topic: vbox + lmce 0810-alpha + ui2 = working  (Read 4397 times)

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
vbox + lmce 0810-alpha + ui2 = working
« on: August 21, 2009, 12:43:33 am »
As an offshoot from another thread, I wanted to see if I could get 810 alpha working in vbox with ui2 + overlay (opengl).  This isn't a detailed howto, but here are the steps I did.

  • install the latest virtualbox on your host OS.
  • download the kubuntu desktop for i386 iso
  • create a new vbox Machine making sure to enable the 3d accelleration
  • boot off the iso (if you don't mount it first it will prompt you), and install
  • from a terminal window in the new vm:
         aptitude update
         aptitude dist-upgrade
         install the vbox guest additions by mounting the iso from the vm menu, mounting the drive in kde, and running /media/cdrom/VBoxLinuxAdditions.run
  • reboot and verify it's working with the vboxvideo driver.   Easy way to tell, when X is up the mouse pointer isn't captured and "stuck" in the vm when you click in the vm window.
  • follow the directions here to install linuxmce 0810-alpha:  http://wiki.linuxmce.org/index.php/LinuxMCE-0810_alpha2
  • When you go through the AV wizard it will overwrite your xorg.conf file and appears to disable the vboxvideo driver.  It may be using vboxvideo though, my only testing was to see if the mouse pointer was stuck in the vm window.
  • Reboot (you may need to reset the vm from the vm menu), after the OS is up but before lmce boots go to a virtual terminal (hostkey-f2 for example), cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf, then reboot. I first tried putting Driver "vboxvideo" in the xorg.conf the avwizard created, but either I put it in the wrong place in the file or something else is going on because that didn't work.  I'm not an xorg expert nor did I play around with it, so if someone has a better way please share it.  I'm not sure if removing all the extra stuff lmce puts in xorg.conf hurts anything, but in brief testing I seem to be fine.
  • The photo screen saver seems to mess stuff up, basically it appears to be in the foreground at all times, even when switching to a virtual terminal.  To avoid this, watch the boot up, and be ready to click advanced->KDE desktop from the lmce menu as soon as possible before the screensaver kicks on.  Once at a kde desktop, follow this: http://wiki.linuxmce.org/index.php/Turn_off_photo_screensaver
The reason I did this was to get 810-alpha/ui2 working in vbox as I don't have a spare computer, but I hope to have time to work on a new skin idea.  I have not tried ui2+blending.

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: vbox + lmce 0810-alpha + ui2 = working
« Reply #1 on: August 21, 2009, 05:07:01 am »
thats cool that you got it to work :)

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: vbox + lmce 0810-alpha + ui2 = working
« Reply #2 on: June 16, 2010, 11:12:09 pm »
I know this is an old post, but does anybody have lmce running in virtualbox?

If so could you please post a working xorg.conf here.

Thank you,

Richard

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: vbox + lmce 0810-alpha + ui2 = working
« Reply #3 on: June 17, 2010, 10:24:58 am »
I ran it in virtualbox, never had to do anything with the xorg.conf file

valent

  • Guru
  • ****
  • Posts: 381
    • View Profile
    • /kernel_reloaded/
Re: vbox + lmce 0810-alpha + ui2 = working
« Reply #4 on: June 17, 2010, 12:53:10 pm »
Great guide, please post it to the wiki also.

I used latest iso image both in kvm and vbox but couldn't get zwave to work via usb stick :(
LinuxMCE - If it was easy, everybody would be doing it!!
My setup - http://wiki.linuxmce.org/index.php/User:Valent

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: vbox + lmce 0810-alpha + ui2 = working
« Reply #5 on: June 17, 2010, 07:10:14 pm »
i ran the install from my builder and it's not showing up anything.

Strange, i'll re-install and see if it works, i updated virtualbox to 3.2.4 including the guest additions

There are 2 guides in the wiki already.

Mine is showing the white letters, but when the green bar appears to show the orbiter/wizard it goes to 99% paused and than restart the process.

Richard
« Last Edit: June 17, 2010, 07:14:13 pm by rperre »

valent

  • Guru
  • ****
  • Posts: 381
    • View Profile
    • /kernel_reloaded/
Re: vbox + lmce 0810-alpha + ui2 = working
« Reply #6 on: July 01, 2010, 10:58:04 am »
There are two pages in WIKI but one needs to be deleted [1] and other is a stub [2] that needs people's attention to make it usable, currently it is actually not user friendly and also has some outdated info. I fixed some of glaring issues with that page and hope you all jump in and also make it better.

This is the WIKI page that should be edited - http://wiki.linuxmce.org/index.php/Install_LinuxMCE_On_VirtualBox

Cheers.

[1] http://wiki.linuxmce.org/index.php/LinuxMCE_0810_on_Virtualbox_3.1
[2] http://wiki.linuxmce.org/index.php/Install_LinuxMCE_On_VirtualBox
« Last Edit: July 01, 2010, 10:59:54 am by valent »
LinuxMCE - If it was easy, everybody would be doing it!!
My setup - http://wiki.linuxmce.org/index.php/User:Valent

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: vbox + lmce 0810-alpha + ui2 = working
« Reply #7 on: July 01, 2010, 12:05:43 pm »
I will try and update this wiki entry with instructions as to how to run the diskless MD in VBox too.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: vbox + LinuxMCE 0810-alpha + ui2 = working
« Reply #8 on: October 08, 2010, 04:08:11 pm »
This is for UI2 peeps, please don't answer "UI1" is working, I know.

Digging this up, i saw some text in the irc channel that people (Bongowongo?) have this working, can you please post the xorg.conf file here for review and a brief explanation on how you got it to work.

I pretty much tried everything i know of, but still get "Orbiter failed to initialize OpenGL"

This is for running ui2...... ui1 seems to running just fine.

Thank you,

Richard

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: vbox + LinuxMCE 0810-alpha + ui2 = working
« Reply #9 on: October 08, 2010, 04:30:30 pm »
Hmm well I did it a while ago and my brain says everything worked fine.
I will make a new test install soon, but I cannot now because I am waiting for my new switch as soon as possible I will dig in.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: vbox + LinuxMCE 0810-alpha + ui2 = working
« Reply #10 on: October 08, 2010, 05:16:57 pm »
Don't you need to install "guest additions" on the MD for the graphics to work properly?
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

muumu

  • Making baby steps
  • Posts: 2
    • View Profile
Re: vbox + LinuxMCE 0810-alpha + ui2 = working
« Reply #11 on: October 08, 2010, 08:32:28 pm »
Dont know if this helps but managed to installed 8.10 beta 2 to VMware player under Win XP and LinuxMCE appears to work ok. I thin kI was running it without accelerated gfxs. No changes needed to conf files but VMware installed some additions by itself. Nice way to evaluate the LinuxMCE.

I think it would be great to have a virtual appliance for evaluation purposes available.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1026
    • View Profile
Re: vbox + LinuxMCE 0810-alpha + ui2 = working
« Reply #12 on: October 08, 2010, 09:00:34 pm »
Don't you need to install "guest additions" on the MD for the graphics to work properly?

I think you also have to enable 'hardware video acceleration' in vbox for that machine.

J.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: vbox + LinuxMCE 0810-alpha + ui2 = working
« Reply #13 on: October 09, 2010, 01:34:38 pm »
Don't you need to install "guest additions" on the MD for the graphics to work properly?

I think you also have to enable 'hardware video acceleration' in vbox for that machine.

J.

Absolutely. I'm going to give this another go today, see what happens.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: vbox + LinuxMCE 0810-alpha + ui2 = working
« Reply #14 on: October 09, 2010, 07:48:04 pm »
you definitely need guest additions installed imo which i did.

I tried copying the original xorg.conf after installing a "plain" ubuntu 08.10 with guest additions, but no help

I have it setup with Enable 3D Acceleration checked

here is a plain xorg.conf

Code: [Select]
Section "Device"
        Identifier "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
EndSection

here is the one after lmce install

Code: [Select]
Section "Device"
        Identifier "Configured Video Device"
        Option "XvmcUsesTextures" "true"
        Option "renderAccel" "true"
        Option "NoDDCValue"
        Option "UseEDID" "true"
        Option "ExactModeTimingsDVI" "true"
        Option "NoLogo" "true"
        Option "NoBandWidthTest" "true"
        Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes, NoEdidModes"
        Option "DynamicTwinView" "false"
        Option "UseEvents" "true"
        Option "AllowGLXWithComposite" "true"
        Option "AddARGBGLXVisuals" "true"
        Option          "ConnectedMonitor" "CRT"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
        Modeline        "1024x768" 60.80 1024 1056 1128 1272 768 768 770 796
        HorizSync       20-500
        VertRefresh     59-61
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
        Option "XvmcUsesTextures" "true"
        Option "renderAccel" "true"
        Option "NoDDCValue"
        Option "UseEDID" "true"
        Option "ExactModeTimingsDVI" "true"
        Option "NoLogo" "true"
        Option "NoBandWidthTest" "true"
        Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes, NoEdidModes"
        Option "DynamicTwinView" "false"
        Option "UseEvents" "true"
        Option "AllowGLXWithComposite" "true"
        Option "AddARGBGLXVisuals" "true"
        Option  "TVStandard"    "1024x768"
EndSection

Section "Extensions"
        Option "Composite" "false"
        Option "RENDER" "true"
EndSection

Section "ServerFlags"
        Option "AutoAddDevices" "False"
EndSection

here is one where i added vboxvideo as the driver

Code: [Select]
Section "Device"
        Identifier "Configured Video Device"
        Driver "vboxvideo"
        Option "XvmcUsesTextures" "true"
        Option "renderAccel" "true"
        Option "NoDDCValue"
        Option "UseEDID" "true"
        Option "ExactModeTimingsDVI" "true"
        Option "NoLogo" "true"
        Option "NoBandWidthTest" "true"
        Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes, NoEdidModes"
        Option "DynamicTwinView" "false"
        Option "UseEvents" "true"
        Option "AllowGLXWithComposite" "true"
        Option "AddARGBGLXVisuals" "true"
        Option          "ConnectedMonitor" "CRT"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
        Modeline        "1024x768" 60.80 1024 1056 1128 1272 768 768 770 796
        HorizSync       20-500
        VertRefresh     59-61
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
        Option "XvmcUsesTextures" "true"
        Option "renderAccel" "true"
        Option "NoDDCValue"
        Option "UseEDID" "true"
        Option "ExactModeTimingsDVI" "true"
        Option "NoLogo" "true"
        Option "NoBandWidthTest" "true"
        Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes, NoEdidModes"
        Option "DynamicTwinView" "false"
        Option "UseEvents" "true"
        Option "AllowGLXWithComposite" "true"
        Option "AddARGBGLXVisuals" "true"
        Option  "TVStandard"    "1024x768"
EndSection

Section "Extensions"
        Option "Composite" "false"
        Option "RENDER" "true"
EndSection

Section "ServerFlags"
        Option "AutoAddDevices" "False"
EndSection

None of these do ui2 for me,

Richard