Author Topic: Amazon seem no longer working  (Read 1941 times)

struggler

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Amazon seem no longer working
« on: August 19, 2009, 12:26:18 am »
Hello,
Several week from now it seems that DVD's are no longer recognized automatically, but the worst is not only that; when I try to get cover art manually on LinuxMCE Admin page it doesn't find any title I might search. I've tried even with keywords like Iron man or spiderman and always with the "No results, please use the filters and try again." message as result.

Is it just me? Any help will be thankful.

Best Regards
JD

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Amazon seem no longer working
« Reply #1 on: August 19, 2009, 03:57:56 am »
It is not just you, amazon has made a change to their web serves (which this uses) and it now requires some kind of authentication.

struggler

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Amazon seem no longer working
« Reply #2 on: August 20, 2009, 09:22:02 pm »
Is there any solution or alternative for that?

JD

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Amazon seem no longer working
« Reply #3 on: August 20, 2009, 11:24:03 pm »
I don't know enough about the issue to know if a workaround will be possible at this time.

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: Amazon seem no longer working
« Reply #4 on: August 21, 2009, 06:44:06 pm »
I can confirm that lmce cannot identify inserted discs anymore. I live in sweden.
This has happened about 1,5month ago too. And suddenly it started working again.

As far as I know lmce do not use Amazon to detect inserted dvds.
Instead EMI (External Media Identifier) it use windows metaservices a service that Windows Media Player use to identify inserted discs which basically is a proxy to other commercial databases available on internet.

The way it work is by calculate a dvdID(crc). The part that we have in a binary only app.
They way MS calculate dvdID is not generally available and was contributed to pluto back in the old days by an unknown contributor.
The code circulate on hacker forums. So far I have been unable to get hold of it. A guy in xbmc forum claim to have it but won´t share it.

Without looking into this with a sniffer I guess MS have change to a newer protocol or some other minor change.
Me and possy looked into this the last time we experienced these issues.

In webadmin it´s a whole other story. It use Amazon.


As for EMI.
this is an example.
I insert "BadBoys 2"
Then EMI send the following, http://metaservices.windowsmedia.com/pas_dvd_B/template/GetMDRDVDByCRC.xml?CRC=1a4a98d8e0a3ef3b
Tried above url and it work fine. Return a XML with info about "Bad Boys 2".
It´s the CRC part that we are unable to calculate.
As far as I know the crc part include filenames, some id string that is fetched from the disc and probably a lot of other things.


/niz23


I don't know enough about the issue to know if a workaround will be possible at this time.

Zerk

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: Amazon seem no longer working
« Reply #5 on: August 24, 2009, 01:51:53 am »
remembered seeing this while looking for something else. i know i saw a guide to use the IMDB to collect data but cant find the artical.  :-\

donpaul

  • Guru
  • ****
  • Posts: 300
    • View Profile
Re: Amazon seem no longer working
« Reply #6 on: August 24, 2009, 03:15:49 am »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: Amazon seem no longer working
« Reply #7 on: August 24, 2009, 04:47:46 am »
Both of these are included in 0810.

-Thom

struggler

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Amazon seem no longer working
« Reply #8 on: August 28, 2009, 04:01:57 pm »
Please forgive my ignorance, but how do I apply those patches? Is it with svn command?

Please provide the command line to do it.

Thanks

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Amazon seem no longer working
« Reply #9 on: August 29, 2009, 07:26:48 am »
as thom said, both are already included.

struggler

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Amazon seem no longer working
« Reply #10 on: August 29, 2009, 11:49:30 am »
I'm still running 0710, I need to do the patch.

thanks

donpaul

  • Guru
  • ****
  • Posts: 300
    • View Profile
Re: Amazon seem no longer working
« Reply #11 on: August 30, 2009, 04:36:07 am »
Go to the core, and run this
Code: [Select]
patch <original file> <patch file>

Itsik

  • Guru
  • ****
  • Posts: 185
    • View Profile
Re: Amazon seem no longer working
« Reply #12 on: September 07, 2009, 07:39:23 pm »
The imdb_cover_art.patch, contains multiple files, some of which are new and some are patches for existing once. How do I apply this patch ?

Thnx
Itsik

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: Amazon seem no longer working
« Reply #13 on: September 09, 2009, 05:09:51 pm »
for amazon tagging, there is a fix in the trac
http://trac.linuxmce.org/trac.cgi/ticket/307

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: Amazon seem no longer working
« Reply #14 on: September 10, 2009, 10:53:42 pm »
Murcel, thanks for pointing to the patch.
For those interested:
I only copied the patch files in their original place and everything seems to be back to normal again.
At first I tried to get away with the patch command (I'm not familiar with this or diff for that matter), but this is not necessary.
Just chmod the old files to ugo-x, copy the new files over and chmod to ugo+x.

Thanks again!!

Erwin