Author Topic: LinuxMCE Game / MAME - Media can not be played  (Read 2666 times)

PeterSchmid

  • Regular Poster
  • **
  • Posts: 42
    • View Profile
LinuxMCE Game / MAME - Media can not be played
« on: August 19, 2009, 12:00:40 am »
Hello to the Gurus out there.

I'm running LinuxMCE since 704 - now switched to 0810 Alpha 2+ (installed based on 2.27)

Now I added the MAME module.
Install via LMCEAdmin (Mediadirector>SoftwareModules-Edit)
After  several coffes and a lot of download and install
setup was completed successfully. QuickReload  and Game-Button was available:-)

Next step : dowloading some MAME ROMS eg. 64thstrees, Bagman, Golfing Greats....
putting them into /home/public/data/games.

After short time pictures and game attributes are available.

Now my problem
I click on play and get always the error message (translated from german Version):
"Media can not be played.
Maybe a device driver is missing"
So I say ok and nothing :-((  ???

Any idea what went wrong? (several reboots did not change anything)
In the gameplayer.log i get
Wed Aug 19 00:37:00 CEST 2009 Restart
========== NEW LOG SECTION ==========
1       08/19/09 00:37:08       87 (spawning-device)    .[1;00mStarting... 1.[1;00m
1       08/19/09 00:37:08       87 (spawning-device)    .[1;00mFound ./Game_Player.[1;00m
== ATTEMPT FRESH START ==
1       08/19/09 00:37:12       Spawn_Device.sh 87 (spawning-device)    .[1;00m10325 Dev: 87; Already Running list: 15,18,53,16,19,52,21,22,62,6
1,25,23,59,26,.[1;00m
== FRESH START ==
1       08/19/09 00:37:12       Spawn_Device.sh 87 (spawning-device)    .[1;00mdevice: 87 ip: 127.0.0.1 cmd_line: Game_Player.[1;00m
0       08/19/09 00:37:12       87 (spawning-device)    .[1;00mEntering 87.[1;00m
========== NEW LOG SECTION ==========
1       08/19/09 00:37:12       87 (spawning-device)    .[1;00mStarting... 1.[1;00m
1       08/19/09 00:37:12       87 (spawning-device)    .[1;00mFound ./Game_Player.[1;00m
05      08/19/09 0:37:12.666            .[33;1mvoid ClientSocket::Disconnect() on this socket: 0x8c9af98 (m_Socket: 7).[0m <0xb77de6c0>
Return code: 0
2       08/19/09 00:37:12       87 (spawning-device)    .[1;33mShutting down... count=1/50 dev=87.[1;00m
Wed Aug 19 00:37:12 CEST 2009 Shutdown

Edit:

after a reboot log files looks like
Wed Aug 19 00:37:12 CEST 2009 Shutdown
== ATTEMPT FRESH START ==
1       08/19/09 00:44:51       Spawn_Device.sh 87 (spawning-device)    .[1;00m15466 Dev: 87; Already Running list: 15,19,53,16,18,52,21,.[1;00m
== FRESH START ==
1       08/19/09 00:44:51       Spawn_Device.sh 87 (spawning-device)    .[1;00mdevice: 87 ip: 127.0.0.1 cmd_line: Game_Player.[1;00m
0       08/19/09 00:44:51       87 (spawning-device)    .[1;00mEntering 87.[1;00m
========== NEW LOG SECTION ==========
1       08/19/09 00:44:52       87 (spawning-device)    .[1;00mStarting... 1.[1;00m
1       08/19/09 00:44:52       87 (spawning-device)    .[1;00mFound ./Game_Player.[1;00m

But problem still the same


Thanks

Peter
« Last Edit: August 19, 2009, 12:50:46 am by PeterSchmid »

PeterSchmid

  • Regular Poster
  • **
  • Posts: 42
    • View Profile
Re: LinuxMCE Game / MAME - Media can not be played
« Reply #1 on: August 19, 2009, 01:01:36 am »
aome additional informations from DCERouter.log:

08      08/19/09 0:52:54.620            Received Message from 21 (OnScreen Orbiter / Wohnzimmer) to 10 (Media Plug-in / ), type 1 id 43 Command:MH Play Media, retry none, parameters: <0x7e3b8b90>
08      08/19/09 0:52:54.620              Parameter 2(PK_Device): 0 <0x7e3b8b90>
08      08/19/09 0:52:54.620              Parameter 13(Filename): !F560 <0x7e3b8b90>
08      08/19/09 0:52:54.621              Parameter 29(PK_MediaType): 0 <0x7e3b8b90>
08      08/19/09 0:52:54.621              Parameter 44(PK_DeviceTemplate): 0 <0x7e3b8b90>
08      08/19/09 0:52:54.621              Parameter 45(PK_EntertainArea): 1 <0x7e3b8b90>
08      08/19/09 0:52:54.621              Parameter 116(Resume): 0 <0x7e3b8b90>
08      08/19/09 0:52:54.621              Parameter 117(Repeat): 0 <0x7e3b8b90>
08      08/19/09 0:52:54.621              Parameter 253(Queue): 0 <0x7e3b8b90>
08      08/19/09 0:52:54.621              Parameter 254(Bypass Event): 0 <0x7e3b8b90>
08      08/19/09 0:52:54.621              Parameter 276(Dont Setup AV): 0 <0x7e3b8b90>
05      08/19/09 0:52:54.622            Play media type 29 in entertain area 1 but nothing to handle it <0x92be1b90>
01      08/19/09 0:52:54.622            Couldn't find any media handlers for type 29 <0x92be1b90>
08      08/19/09 0:52:54.623            Received Message from 10 (Media Plug-in / ) to 21 (OnScreen Orbiter / Wohnzimmer), type 1 id 741 Command:Goto Screen, retry none, parameters: <0xa9ff1b90>
08      08/19/09 0:52:54.623              Parameter 18(Errors):  <0xa9ff1b90>
08      08/19/09 0:52:54.623              Parameter 159(PK_Screen): 176 <0xa9ff1b90>
08      08/19/09 0:52:54.623              Parameter 251(Interruption): 0 <0xa9ff1b90>
08      08/19/09 0:52:54.623              Parameter 252(Turn On): 0 <0xa9ff1b90>
08      08/19/09 0:52:54.623              Parameter 253(Queue): 0 <0xa9ff1b90>

 ???

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: LinuxMCE Game / MAME - Media can not be played
« Reply #2 on: August 19, 2009, 09:41:38 am »
The game plugin needs to be rebuilt to solve this problem, in the mean-time, you can grab:

http://tschak.homelinux.com/xfer/Game_PlugIn.so

and place it in /usr/pluto/bin

reload router, and try again.

-Thom

PeterSchmid

  • Regular Poster
  • **
  • Posts: 42
    • View Profile
Re: LinuxMCE Game / MAME - Media can not be played
« Reply #3 on: August 20, 2009, 12:16:48 am »
Thanks a lot!
It's working fine with your file.   :D

What did I do wrong?  Or is it still an Alpha issue?
Would be good to know as I want to get more deep into LMCE an all related plugins.

Thanks

Peter

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: LinuxMCE Game / MAME - Media can not be played
« Reply #4 on: August 20, 2009, 12:38:55 am »
long story short, we had a bit of a boo-boo, a couple builds back, was my fault, and some internal structures in the media plugin changed. had to rebuild all the media related plugins again to get everything back in sync.

-Thom

struggler

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: LinuxMCE Game / MAME - Media can not be played
« Reply #5 on: October 29, 2009, 10:44:51 am »
The game plugin needs to be rebuilt to solve this problem, in the mean-time, you can grab:

http://tschak.homelinux.com/xfer/Game_PlugIn.so

and place it in /usr/pluto/bin

reload router, and try again.

-Thom


The refered site no longer exists, could anyone publish the Game_PlugIn.so file.

thanks

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: LinuxMCE Game / MAME - Media can not be played
« Reply #6 on: October 29, 2009, 11:01:57 am »
There is no need for this anymore, the newest package is published in our repository.

-Thom