General > Users

thezfunk LinuxMCE Project build

<< < (5/6) > >>


--- Quote from: thezfunk on September 21, 2009, 04:18:04 am ---The second try with a working Core WAN NIC went slightly better.  Wound up at a Failed to Start X error.  No problem, dove into the wiki here:  Down at the bottom is says to set your xorg.conf to 'vesa' from 'nv'.  Much easier said than done.

Logging into the MD left me at a prompt as the sambahelper user.  That's where I am stuck.  Every time I try doing anything it says I don't have permissions and every time I try logging in as root...I don't know the password and the one I have on the core doesn't seem to work.  I even managed to get into vim and fumble around enough to change 'nv' to 'vesa' but I couldn't save.  Permissions forbade me.  Some prodding or help is politely asked for from the community.

PS...according to the wiki the default password for sambahelper is nothing or just hit enter.  Says I have the wrong password when I try that.

--- End quote ---

I had a similar issue on my Zotac 330 Ion.  I couldn't use sudo on the MD because sambahelper told me I had the wrong password.  To get around this I had to set an actual root password for the MD. 

When you log into the MD your prompt should tell you what moon# the MD is... remember the number.

On the core/hybrid you need to open a terminal in KDE or press Ctrl-Alt-F1 to get tty1.  Login with your username and password.  Then to become superuser type:

--- Code: --- $ sudo su -
--- End code ---

and enter your password.  Change directory to /usr/pluto/diskless and chroot into the MDs structure.  Once you have done this you can change the root password for the MD with the passwd command.

--- Code: ---# cd /usr/pluto/diskless
# chroot XX   <-- replace XX with the moon number (device number) of your MD.
# passwd
Enter new UNIX password:

--- End code ---

Enter the root password for the MD and then exit the chroot environment and give up superuser by typing 'exit' twice.

--- Code: ---# exit
# exit

--- End code ---

Now you can login as root on the MD with the password that you just set and you will be able to edit your xorg.conf file.


Thank you, phenigma.

That is exactly what I needed.  This should probably be added to the wiki.  You have enabled me to get quite a bit farther but now...another roadblock.

After I was able to get root access to the image I loaded it again on the ION.  I installed nano since vim is a pain.  I went to change 'nv' to 'vesa' in the xorg.conf file to find I didn't have a xorg.conf file.  I had a xorg.conf.pluto.avwizard however.  I opened the xorg.conf.pluto.avwizard file, made my changes in nano, and saved it as xorg.conf and presto, on reboot, the config started and I proceeded to follow the rest of the wiki about the ION:

I proceeded to try and update the nividia drivers.  They keep failing.  I am doing it just like I did on the core where it worked just fine.  I don't have the failure from the log here right now but I will post back.

I do have another idea to try.  Now that I have run through the AV wizard and I have UI1 working do I need to change the xorg.conf back to 'nv' before updating the nvidia drivers?  Could this be a missing step?

Once this ION is up and working I plan on adding what I did to the wiki so that others can use this most perfect of boards for their MD!


--- Quote from: JaseP on September 04, 2009, 07:34:02 am ---I can answer your quick question: Yes, the MD's will typically take their drivers from the Core...

I'm not sure about your second question, but I don't think that LinuxMCE was designed to do multi-headed MDs (including the Core/Hybrid).

--- End quote ---

Oh, and unless I did something MD did NOT get it's drivers from the core.  It went out on it's own and tried installing an old 180.xx.xx driver.

w00t!  My ION MD works!  It was three frustrating days thinking I was majorly screwing something up to find out it wasn't my fault.  I would like to thank:


Without their help I probably wouldn't have gotten this far.

I will describe -- as best as I can remember -- the sequence of events that led me to a working ION MD.  This is what I did.  Remember that when reading it.  I ended up not using anything on the ION wiki page.  This way described below worked for me.  Read this post like a fortune cookie.  Instead of 'in bed' at the end of each sentence use something like, "for thezfunk" or "for me".  I find there are a million ways to skin a cat with Linux.  Also, I was using the HDMI port on the ION for this whole procedure

Firstly, make sure your core is up-to-date.  Do your apt-get update and your apt-get upgrade distro.  Boot up your ION and got into the bios.  Head to the southbridge section (which is where they hid the PXE boot option).  Set your gpu buffer to 512mb of your system ram and enable PXE boot.  I think you then have to save and return to the bios to see the network card as a bootable option.  Boot up the ION and if you set the boot options correctly it will boot off the network and LinuxMCE will take over.  You should get all the way to the AVwizard without any problems.  I was on a 61" TV with HDMI and the 1080p option wouldn't display right but the 720p option did.  I went through the AVwizard selecting UI1.  That is very important.  After the AVwizard completed I think I had to reboot.

The ION booted up and it gave the usual messages about loading LinuxMCE and the orbiter will be generated.  I think the orbiter generator ran for 10-15 mins.  There might have been another reboot after the generator ran and then I was in!  UI1 was working and I could get into KDE desktop.  Then some more of the fun began.  I wanted to install the nvidia drivers with a packet manager for dependency reasons.  Luckily the above mentioned guys pointed me in the right direction.  This link:  I will run through the commands I used.  I installed nano with a sudo apt-get install nano.  I like nano the best out of the text editors that I have used.

--- Code: ---sudo nano /etc/apt/sources.list
--- End code ---
Since we are using 0810 we want the Intrepid instructions.
add the following line to the sources.list

--- Code: ---deb intrepid main
deb-src intrepid main
--- End code ---
Save and exit file
Install GPG key using the following command

--- Code: ---sudo apt-key adv -- keyserver -- recv-keys CEC06767
--- End code ---
Update source list

--- Code: ---sudo apt-get update
--- End code ---
Now install the drivers.  If you want the newest 185 which I think are final instead of the 190 betas just replace the 190 with 185.

--- Code: ---sudo apt-get install nvidia-190-modaliases nvidia-glx-190
--- End code ---
I think I then did a

--- Code: ---sudo nvidia-xconfig
--- End code ---
because on reboot I got a black screen with cursor.  You can try rebooting and if you get the black screen use the nvidia-xconfig.  It generates a new xorg.conf file.

Now it was time to rerun the AVwizard.  I rebooted and when the tones started sounding I held down SHIFT.  The screen was black (I think) because the video was being output on something other than the HDMI port.  I sat and hit the numeral keys until I got a picture.  I think it was 5 or 6 but start at 1 and work your way up.  Pause at each one and give it a second to switch.  I went through the AVwizard, set it to 1080p and UI2 with overlay.  After a reboot and orbiter regen I was in the UI at 1080p! 

Some notes:
I originally installed the nvidia 190's.  They seemed to be a little slow.  After I was back in at 1080p with the new drivers I did an update from KDE instead of the command line.  Don't do that.  It screwed up my nvidia drivers and I had to reinstall.  When I reinstalled the nvidia drivers I picked the 185's.  They seemed to run smoother.  I want to try the 190's again but right now it runs fine on the 185's. 

I still need to get the audio working via HDMI.  There seems to be mixed luck with that but I know that I need to install the new ALSA drivers.  Does anyone know of a way to do it with a package manager?

HDMI Audio does not work.  I have been all over the forums.  By 'the forums' I mean every forum ever (I swear).  Out in the wild there is working HDMI audio on Ubuntu 8.10 but not working on LinuxMCE.  I don't feel like typing out everything that I have tried (geekyhawkes has run into all of this before read his posts.  I ran into all of the exact same problems he has and I got no farther than he did) but I will explain how to upgrade your ALSA drivers.  I think it's better than what I did on my core (even though it worked with my core).

The best way I have found to upgrade ALSA is here:

Thanks to tkmedia and merkur2k for providing that link.

One more quick word on HDMI audio...
This guy:
He has my exact hardware.  He got HDMI audio working.  I wanted to use his settings but I was told LinuxMCE over writes the file that you need to modify each and every time it boots.  No dice.  Since, I am lucky enough to have a receiver that accepts optical and coax digital audio I can work around for now (hopefully, I still have to get that to work).

Oh!  One last thing.  Zotac has some Linux drivers for audio and lan on their website.  Could this be useful?  Linux drivers specifically for this board?


[0] Message Index

[#] Next page

[*] Previous page

Go to full version