Author Topic: Orbiter on Zaurus II  (Read 15573 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #15 on: August 23, 2006, 01:55:13 am »
Here is the documentation for the OE build environment:
newbielink:http://www.openembedded.org/user-manual&dpage=ch03 [nonactive]

I am actually still using bitbake 1.42. I think the latest is 1.44 or 1.6. It's a bit of a hairball to get monotone installed (correct version) etc. but its not too bad. Post here or pm me if you have any questions. I have some documentation of what I had to do but it is not really organized.

Also, the reason I am using GPE instead of OPIE is it includes X11 which I believe is required by Orbiter. You would have to add X11 libs/headers etc. to OPIE to compile/run Orbiter. Correct me if I am wrong Chris.

Rob

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #16 on: August 23, 2006, 09:46:06 am »
Hi Rob,

I don't think we would want to include any X11 headers, but for this we'll have to do few changes in Orbiter. There are two classes in Orbiter using X11 headers : OrbiterLinux and OrbiterRenderer_SDL_Linux. The idea would be to get rid of them, removing them from Makefile, then in OrbiterRendererFactory to create an OrbiterRenderer_SDL instead of its derived class and in StartOrbiterSDL.cpp to create an Orbiter instance instead of its derived class, OrbiterLinux.

Best regards,
Cristian Miron

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #17 on: August 23, 2006, 08:15:46 pm »
I guess the next question is, if you didn't use X11, would it take anything else to get it to run in Qtopia besides the SDL stuff? If not then I guess you could run it in OPIE. This is starting to get way over my head ;)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #18 on: August 24, 2006, 09:20:07 am »
Hi,

I guess the best approach is to try first with a simple SDL application on Qtopia or OPIE. If it works, then Orbiter will work too. Here are the SDL extensions used by Orbiter: SDL, SDL_ttf, SDL_image, SGE, SDL_gfx.

Best regards,
Cristian Miron

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #19 on: August 24, 2006, 05:14:53 pm »
So, in order to compile for Collie OPIE, I think the kernel is 2.4.18? and gcc version is 2.9.3/5? I guess I can go back to my notes on when I was trying to compile natively in PocketWorkstation.

I'm pretty sure that SDL apps work on the zaurus sl-c3x00 because I am running nes/snes emulators that require libSDL-1.2. I'm not sure about the extensions though.

Here are the ipks from the 3.5.3 feed.
libsdl-gfx11_2.0.11-r0_arm.ipk
libsdl-image-1.2-0_1.2.3-r0_arm.ipk
libsdl-mixer-1.2-0_1.2.5-r0_arm.ipk
libsdl-net-1.2-0_1.2.5-r0_arm.ipk    
libsdl-ttf_2.0.3-r0_arm.ipk            
libsdl-x11_1.2.7-r3_arm.ipk  

Looks like it is just missing SGE. I have a "recipe" for that one.  My problem now is I don't have any room to build a second environment. Maybe I'll have to buy a bigger Hard Drive ;) to give it a shot.

Rob

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Can't find oz353 anymore
« Reply #20 on: August 30, 2006, 06:36:21 am »
Chris.M,
I found some more disk space and started building an OE environment for Collie, however, I can't seem to find the oz353 environment anywhere. That means if I am to build this for your SL5500 I will have to use the 354 version which is the 2.6 kernel. Would you be willing to give that a try?

Also, on the X11 front. I think what you described is a bit beyond me. However, if you could create unified diff files for the files in question, I could use them as patches and try building them without X11 support. I think that OE uses quilt to create patches.

Let me know.

Rob

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #21 on: August 30, 2006, 04:15:54 pm »
dothedog,
  3.5.4 release on collie still uses 2.4 kernel.  The newer 3.5.4.2 rc1 uses the 2.6 kernel.  3.5.4.1 appears to only be available for collie as an upgrade to the apps, not kernel.  So, 3.5.4 should work fine (running on my collie currently).

Thanks,
Jason

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #22 on: September 04, 2006, 01:55:21 pm »
Hi Rob,

Unfortunatelly, I won't be able to help you next 2 weeks because we are preparing for Cedia. I'm not very familiar with Collie, so I don't think I can help you too much with this. However, if you have question about Orbiter, I will find time and help you.

Thank you,
Cristian Miron

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #23 on: September 12, 2006, 06:46:40 am »
Hi,
I have been having trouble building the oz3.5.4.1 OPIE image for 2.4. I may end up putting a bug report in on it with the OE guys. jspeckman, have you given it a shot yet? If you can get the environment built, I can send you the .bb recipes for all the required packages.

Rob

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Orbiter on Zaurus II
« Reply #24 on: September 12, 2006, 03:53:46 pm »
I have not had a chance yet.  I got halfway through the OE install on my laptop, but have not yet had a chance to finish.  I'll let you know when I'm up and running.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Still no love
« Reply #25 on: September 17, 2006, 12:48:41 am »
jspeckman,
I have been trying to build for oz3.5.4.1 kernel 2.4 for you guys but I am having trouble building the gpe-image so I can't even start trying the orbiter stuff. I have a thread running on oesf here:

newbielink:http://www.oesf.org/forums/index.php?showtopic=21442&st=0&p=141579&#entry141579 [nonactive]

looks like they broke it moving to 3.5.4.2...

I haven't even tried OPIE yet. Trying to remove the x11 stuff may be beyond my meager abilities. If you can do it let me know.

Rob