Author Topic: Cannot rip movies from vbox MD?  (Read 1215 times)

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Cannot rip movies from vbox MD?
« on: July 30, 2009, 04:54:11 pm »
As mentioned in another thread, I need to re-rip all my DVDs and for convenience I want to do it from my desktop (dual boot XP/Kubuntu 9.04) while working from home.  Since I have a vbox MD on my linux desktop I figured I'd use that for the DVDs LMCE can rip, but I get a message saying it can't rip the movie, possibly due to no DeCSS.  I have uninstalled and re-installed the DeCSS stuff, but still no worky.

Is there some limitation where you cannot get around DeCSS or some other issue with a virtual machine?  If so, is there some work around?  I may try DVD43 in XP and a vbox session although I don't have vbox installed on my XP drive.

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 999
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #1 on: July 30, 2009, 05:21:16 pm »
Hi,

I ran across this problem...

To get the Core/Hybrid to play decrypted and encrypted DVD's.

      Install extra packages.

      /usr/share/doc/libdvdread3/install-css.sh (this installs libdvdcss2)  [may need to install libdvdread3]
      apt-get install w32codecs
      apt-get install kubuntu-restricted-extras

After this I still couldn't get it to work.

As root I did a lspci -vvnn command and looked for my IDE Interface.

      I saw...

      Kernel driver in use: pata_sis
      Kernel modules: pata_sis

      I went into /boot/grub/menu.lst and at the end of the kernel line -after splash- I added all_generic_ide

      Reboot!

     Then everything worked.

      Future note: all_generic_ide boot option no longer working with kernel 2.6.28-4.9 (9.04). It seems that ata_generic.ko is missing!
      Temporary workaround: install linux-image-386, there is ata_generic.ko compiled with it, so it will work.

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #2 on: July 30, 2009, 05:54:50 pm »
I can play DVDs fine (well, most of them) on my core/md, as well as my mds.  It's the virtual MDs (vbox net boot) that cannot play or rip DVDs. 

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 999
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #3 on: July 30, 2009, 06:07:27 pm »
O.K.,

I thought you were running MD software under virtual software like kvm or something and if the ide hardware was pata it would still matter.

Best of luck.

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #4 on: July 30, 2009, 06:55:33 pm »
Well, I gave DVD43 a try.  Supposedly it deals with CSS "on the fly" so the applications see a DVD as unencrypted.  My DVDs are detected, and I get as far as the FBI warnings, but still can't play them in vbox.  I'll see if I can put you (pigdog's) experience to use and look for drive settings in vbox and possibly try adding all_generic_ide to the menu.lst.

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 999
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #5 on: July 30, 2009, 07:13:01 pm »
Hi,

What I experienced on the Core - which was a little confusing - the movie would be picked up - a dialogue box would pop up and show the title.

The ripped movie would start to play for about 2 - 3 seconds and then crap out with the cssdvd message.

The next time I'd try to play it would just go to the cssdvd message.  Only after reboot would the dialogue box appear.

Have you tried a ripped source?

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #6 on: July 30, 2009, 07:25:42 pm »
Yes, movies already ripped to disk play fine.  As far as I can tell, the only thing not working is playing/ripping DVDs from a vbox MD.  A bit of an inconvenience/annoyance but not a major problem.  I'll put a bit more effort into it, but probably not obsess over it.

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 999
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #7 on: July 30, 2009, 07:31:07 pm »
Hi,

If you can play ripped then it's nothing to do with pata.  I couldn't play anything until it was changed in menu.lst.

Good luck.

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #8 on: July 30, 2009, 08:17:14 pm »
I pretty much verified that when I was able to play the DVD from the KDE desktop with mplayer.  Now I'm kinda lost on what to check next.

LegoGT

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
    • Medium Rare Brain
Re: Cannot rip movies from vbox MD?
« Reply #9 on: August 01, 2009, 03:42:02 am »
Hi,

What I experienced on the Core - which was a little confusing - the movie would be picked up - a dialogue box would pop up and show the title.

The ripped movie would start to play for about 2 - 3 seconds and then crap out with the cssdvd message.

The next time I'd try to play it would just go to the cssdvd message.  Only after reboot would the dialogue box appear.

Have you tried a ripped source?

Make sure you set the DVD region. Linux can be picky about that for some DVD drives.
A brain dump of my neverending projects: http://MediumRareBrain.com

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 999
    • View Profile
Re: Cannot rip movies from vbox MD?
« Reply #10 on: August 01, 2009, 05:34:25 am »
Hi LegoGT,

When I was troubleshooting this initially I had tried regionset but the problem on my setup was related to pata_sis as per the second post.

Thanks
« Last Edit: August 01, 2009, 05:36:30 am by pigdog »