Author Topic: Upgrading to ALSA 1.0.20 link - Am I missing something?  (Read 1020 times)

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Upgrading to ALSA 1.0.20 link - Am I missing something?
« on: July 22, 2009, 03:52:21 am »
Hi,

For the upcoming release I was looking for instructions to upgrade to ALSA 1.0.19 and found this for ALSA 1.0.20

http://ubuntuforums.org/showthread.php?p=6589810

Supported kernels: 2.6.24/26/27/28/29 family (including rt-kernel & NON-Ubuntu ZEN-rt-kernel)

Another link is here http://monespaceperso.org/blog-en/2009/02/10/acer-aspire-6920-no-sound-on-ubuntu-810-upgrade-of-alsa/

Hope it saves someone a little searching.

Cheers.
« Last Edit: July 22, 2009, 03:35:38 pm by pigdog »

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4463
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Upgrading to ALSA 1.0.20 link
« Reply #1 on: July 22, 2009, 09:39:01 am »
Hi,

For the upcoming release I was looking for instructions to upgrade to ALSA 1.0.19 and found this for ALSA 1.0.20

http://ubuntuforums.org/showthread.php?p=6589810

Supported kernels: 2.6.24/26/27/28/29 family (including rt-kernel & NON-Ubuntu ZEN-rt-kernel)

Another link is here http://monespaceperso.org/blog-en/2009/02/10/acer-aspire-6920-no-sound-on-ubuntu-810-upgrade-of-alsa/

Hope it saves someone a little searching.

Cheers.

Our updated Avwizard, nVidia 180.60, alsa-1.0.20 and all associated scripts were committed to the svn last night. So the next alpha build should contain them...alternatively checkout the code and build it yourself.

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-7C

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: Upgrading to ALSA 1.0.20 link
« Reply #2 on: July 22, 2009, 02:38:04 pm »
Hi,

Great! That makes things easier.  apt-get dist-upgrade on MD's as well - right?

Thanks.

Cheers.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: Upgrading to ALSA 1.0.20 link
« Reply #3 on: July 22, 2009, 03:34:51 pm »
Hi,

I did an apt-get dist-upgrade and got ...

# pluto-av-wizard_2.0.0.44.09072222170_i386.deb (556,555) - HDMI sound support
# pluto-boot-scripts_2.0.0.44.09072222170_i386.deb (234) - HDMI sound support
# pluto-website-admin_2.0.0.44.09072222170_i386.deb (220) - HDMI sound support

I checked for a new alsa release using command - cat /proc/asound/version and I still had version 1.0.17
I checked for a nvidia driver and still had 180.11

Am I missing something?

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: Upgrading to ALSA 1.0.20 link - Am I missing something?
« Reply #4 on: July 22, 2009, 03:40:11 pm »
Yes.

You have to update nVidia driver and alsa manually.

/niz23

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: Upgrading to ALSA 1.0.20 link - Am I missing something?
« Reply #5 on: July 22, 2009, 03:47:57 pm »
Hi niz23

Oh, I must have misinterpreted this comment.  I thought they were included as updates.

Quote
Our updated Avwizard, nVidia 180.60, alsa-1.0.20 and all associated scripts were committed to the svn last night. So the next alpha build should contain them...alternatively checkout the code and build it yourself.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4463
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Upgrading to ALSA 1.0.20 link - Am I missing something?
« Reply #6 on: July 22, 2009, 03:59:45 pm »
Hi niz23

Oh, I must have misinterpreted this comment.  I thought they were included as updates.

Quote
Our updated Avwizard, nVidia 180.60, alsa-1.0.20 and all associated scripts were committed to the svn last night. So the next alpha build should contain them...alternatively checkout the code and build it yourself.

No... thats my mistake. We have those but did not commit them to svn as the wrapper for installing them is not ready for testing. A manual install of the nVidia & alsa packages is temporarily required ;-)

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-7C

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: Upgrading to ALSA 1.0.20 link - Am I missing something?
« Reply #7 on: July 22, 2009, 04:23:20 pm »
O.K.

No problem - thanks for clearing it up.