Author Topic: Kernel panic - not syncing: attempted to kill init(getting there)  (Read 2694 times)

widescreen

  • Veteran
  • ***
  • Posts: 70
    • View Profile
Maybe someone tell me if i'm missing something I could do to pxe boot a MD with 8.10. It works well if i use it as 8.10 core. Thus far i have
        1)followed the unrecognized nic wiki and tried adding Atl2 to /etc/initramfs-tools-interactor/modules for a Attansic L2 chipset.
        2)/went into the core and went to tftpboot/pxelinux.cfg and edited the default boot script to remove acpi=off.
      
But i get to a point where it says:

Ipconfig: eth0: siocgifindex:
no such device
ipconfig:no devices to configure
/init: .: line 1: can't open /temp/net-eth0.conf
kernel panic - syncing: attempted to kill init!

any input appreciated. thanks guys
« Last Edit: July 14, 2009, 09:28:34 pm by widescreen »

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 983
    • View Profile
Re: Kernel panic - not syncing: attempted to kill init
« Reply #1 on: July 14, 2009, 02:22:47 am »
Hi,

Take a look in your BIOS for acpi settings.  Change them from default.

I was trying to PXE boot an older MD via a ROM-O-MATIC boot disk and it wouldn't work in a later variant of 810.

I went into /tftpboot/pxelinux.cfg directory and edited the default boot script file and removed acpi=off (or I just change it to on).

Since this didn't work for you, then, if you have an newer BIOS version you can probably try to change it there.  If the default is on, try off.

Sometimes things are just to wierd.

Good luck,

Cheers.

P.S. What mobo are you using because someone had this problem http://forum.linuxmce.org/index.php?topic=8125.0 ?

and others with Revo's had to upgrade nvidia drivers to 180.51.
« Last Edit: July 14, 2009, 03:57:39 am by pigdog »

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Kernel panic - not syncing: attempted to kill init
« Reply #2 on: July 14, 2009, 08:53:20 am »
widescreen

from your point 1 it looks like you have only completed half the unrecognised NIC instructions... you have to read the article _very_ carefully and understand exactly what it is asking you to do (as it is very easy to make a mistake with that process!)

First, you need to understand what initramfs and vmlinuz are and how they are used for network booting. Vmlinuz is the first piece of code loaded (via TFTP) on PXE boot, and its entire job is to create a RAM disk, TFTP down the initramfs file, decompress it into the RAM disk, then hand control over to that code to continue. Initramfs contains a small Linux micro kernel and basic hardware drivers necessary to start networking, and mount a remote NFS share locally as the system "disk", then hand control over to that full kernel to start running normally.

The full kernel on 0810 (and probably 0710) will likely have the correct network driver for your NIC, however that is no use if the initramfs micro kernel doesn't have the driver, as it will not be able to start networking and mount the NFS share to get to the full kernel... catch 22! It would seem (I am deducing, I don't know for sure) that the NIC "driver" in vmlinuz is so basic that it will pretty much work on any NIC, so that doesn't need to be updated, and obviously the NIC "driver" used by the PXE firmware is able to drive your NIC because it came with the computer!

So the issue is usually initramfs. But you need to understand that there are 2 different initramfs's involved... the first is the "default" one used for _new_ MDs - ie MDs that have never been seen before my LinuxMCE. The instructions for that are at the top of that article. These are the easy ones to follow. The second is for after LinuxMCE has run the initial discovery on _first_ boot of your MD and assigned a device number, rebooted the MD, etc. The instructions for this one is the second part of that article and can be more difficult to follow what is going on because of the chroot bits...

Note that the first one is here /tftp/default/initrd and the second one is here /usr/pluto/diskless/##/boot/initrd... (which is then symlinked into /tftp/## ie different from the "default" location)

It is highly likely that you have successfully modified the default initramfs, so the first part of setting up an MD has gone through, and you will see it as a device in the device tree of web admin. But haven't successfully modified the second initramfs, which is used for all subsequent reboots.

The error message you are getting means that the driver module for your NIC is not loading and so the eth0 interface name doesn't get set up... ie no networking, and without that, you cannot mount the system "disk" over the network, so the kernel panics, as it cannot continue.

Note that the first uses /etc/initramfs-tools-interactor/modules the second /usr/pluto/diskless/<mediadirector-id>/etc/initramfs-tools/modules

You must edit BOTH /usr/pluto/diskless/<mediadirector-id>/etc/modules AND /usr/pluto/diskless/<mediadirector-id>/etc/initramfs-tools/modules before you chroot into the MD's files. And you must depmod before recreating the initramfs, as this is what reads those config files and tells the initramfs to load that module on start up. It can also be relevant if you modprobed the module into the kernel on the core before even creating the MD image.

One thing is certain though, once you make one stuff up, you can go back and try to fix it up but more often than not you end up in knots! It is usually better to go right back to the beginning and completely delete the MD from the device tree (and allow it to delete all the files - that's why deleting an MD is so slow) and starting again, being concious that the new MD will have a new device number, and that often it will detect it as AMD64 rather than i386, and if your core is i386 (which it should be) the chroot won't work... if that is happening it can be a bit tricky to get around, so I won't detail that here unless you confirm that to be an issue.

good luck

BIOS boot firmware -> PXE boot firmware -> vmlinuz RAM disk bootstrap software -> initramfs Linux micro kernel boot software -> Linux full kernel
« Last Edit: July 14, 2009, 08:56:10 am by colinjones »

widescreen

  • Veteran
  • ***
  • Posts: 70
    • View Profile
Re: Kernel panic - not syncing: attempted to kill init
« Reply #3 on: July 14, 2009, 05:48:10 pm »
pigdog, collin, thanks. I got it to work. Not sure what worked because i did both suggestions but, thanks to you both for helping out. I appreciate it guys.  ;D

widescreen

  • Veteran
  • ***
  • Posts: 70
    • View Profile
Re: Kernel panic - not syncing: attempted to kill init
« Reply #4 on: July 14, 2009, 07:56:58 pm »
as the wiki states:

"This will create a new initial ramdisk for the first boot of new MDs containing the atl1 module (or in your case for whichever module you have added). Now, the first boot of the diskless MD will succeed and a new diskless media director will be created."

following the completion of the first part of the above quoted unrecognized nic wiki, does this lead to the wizard setup or :

running diskliess_setup.sh
running DHCP_config.sh
running diskless_exportsNFS.sh
rebooting
[   377.034413] md: stopping all md devices

because after reboot....even after completing all the steps in the wiki, the md reboots and returns to the original error message i was getting.
 ???
« Last Edit: July 14, 2009, 08:01:59 pm by widescreen »

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 983
    • View Profile
Re: Kernel panic - not syncing: attempted to kill init(getting there)
« Reply #5 on: July 14, 2009, 10:21:29 pm »
Hi,

When you look in webadmin under Media Directors did it created a MD for this guy?

widescreen

  • Veteran
  • ***
  • Posts: 70
    • View Profile
Re: Kernel panic - not syncing: attempted to kill init(getting there)
« Reply #6 on: July 15, 2009, 12:43:58 am »
yes it did,

just won't go beyond this point:

running diskliess_setup.sh
running DHCP_config.sh
running diskless_exportsNFS.sh
rebooting
[   377.034413] md: stopping all md devices

Even after I finish the entire wiki, it reboots it goes back to saying:

Ipconfig: eth0: siocgifindex:
no such device
ipconfig:no devices to configure
/init: .: line 1: can't open /temp/net-eth0.conf
kernel panic - syncing: attempted to kill init!
 ???

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Kernel panic - not syncing: attempted to kill init(getting there)
« Reply #7 on: July 15, 2009, 12:49:41 am »
This definitely means that you successfully modified the "initial" RAM disk, but did not successfully modify the second one that is used for ongoing boots, thereafter. That's the part you should focus on. The initramfs image you created is a compressed container that you can expand and look inside to confirm that 1) the module is in there, and 2) that the config files both name that module, at the very least, look at the modified time/date on the initrd file and confirm that it has been touched at the time you recreated it. Don't forget that if you ever hit the rebuild image button in web admin, this recreates the entire MD image, overwriting any changes you made to the config files or initrd file.