Author Topic: Zotac Ion board  (Read 6241 times)

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Zotac Ion board
« on: July 07, 2009, 08:37:42 pm »
Just wanted to let you guys know that I got my zotac board booted up as a MD yesterday and that I have started a wiki to show the steps necessary.

http://wiki.linuxmce.org/index.php/ZOTAC_ION

I will post anything I come across both here and on the wiki page.
-Krys

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: Zotac Ion board
« Reply #1 on: July 07, 2009, 09:31:18 pm »
krys,

I have a 330 board myself with 1,5GB RAM (512MB allocated to GPU).
For the 330 you need to attach the included fan otherwise it become really hot.

If you have chosen MythTV as pvr in lmce you will automatically get mythtv 0.21 with vdpau if using avenard repository.
Does it work fine for you?
I experience some difficulties. Mythfrontend hang for no apparent reason. Might be because of bad dvb-t reception or some other bug in mythtv_plugin.

The other thing that you also get from avenard repo is mplayer with vdpau support.
So far I have no been able to successfully play any m2ts file using mplayer with vdpau under lmce.
We will probably need to recompile mplayer_plugin against it before it´ll work. (need to more test on this)
Have you tested any m2ts files in 1080P?

/niz23



totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4431
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Zotac Ion board
« Reply #2 on: July 08, 2009, 11:25:24 am »
krys,

I have a 330 board myself with 1,5GB RAM (512MB allocated to GPU).
For the 330 you need to attach the included fan otherwise it become really hot.

If you have chosen MythTV as pvr in lmce you will automatically get mythtv 0.21 with vdpau if using avenard repository.
Does it work fine for you?
I experience some difficulties. Mythfrontend hang for no apparent reason. Might be because of bad dvb-t reception or some other bug in mythtv_plugin.

The other thing that you also get from avenard repo is mplayer with vdpau support.
So far I have no been able to successfully play any m2ts file using mplayer with vdpau under lmce.
We will probably need to recompile mplayer_plugin against it before it´ll work. (need to more test on this)
Have you tested any m2ts files in 1080P?

/niz23

We're using the Avenard repos too. We've not had any hangs in MythFrontend that I can recollect...but we do see some weirdness sometimes whereby the MythBackend just seems to not be communicating. We have not trued the mplayer + vdpau side at all yet. We have tested a lot of HD content from the BBC HD channel on DVB-S and this is working really very well indeed.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: Zotac Ion board
« Reply #3 on: July 08, 2009, 04:31:29 pm »
Here are my first impressions playing with this board.

1. the install was easy enough using the repos
2. UI2 both overlay and alpha-blending  had noticeable tearing even on SD video with 10% cpu usage
3. Tested horrible with Hulu (understandable since flash doesnt use vdpau yet)
4. mt2s files will not play yet with 810 to my knowledge so I could not test anything with mplayer (might try opening from desktop tonight)
5. Optical audio worked automatically (not sure if this was because of the added repo)
6. I started out using the DVI connection, when i switched to HDMi and ran the AV wizard I had to select component to get picture
7. HDMI audio is not yet working, havent looked into it.
8. 720p videos sometimes play well, others are not watchable at all, stuttering even when CPU is @ < 60%
9. I only have 1 1080 video and it was also unwatchable due to stuttering and choppy video
10. SD video is smooth and plays well other than the tearing

Thats all I can think of for now. I really like the way the board is layed out, noiseless and small... I just hope we can get this thing dialed in and working as it should. I am concerned with the tearing, and would like to hear if others are experiencing the same. Maybe we need to get a common video file that we can all compare with to see if we get the same results.
-Krys

*** Also i was wondering is it possible to watch movies in mythTV to take advantage of its use of Vdpau? or does myth only recognize certain file types.
« Last Edit: July 08, 2009, 04:34:43 pm by krys »

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4431
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Zotac Ion board
« Reply #4 on: July 08, 2009, 11:25:52 pm »
Here are my first impressions playing with this board.

1. the install was easy enough using the repos
2. UI2 both overlay and alpha-blending  had noticeable tearing even on SD video with 10% cpu usage
3. Tested horrible with Hulu (understandable since flash doesnt use vdpau yet)
4. mt2s files will not play yet with 810 to my knowledge so I could not test anything with mplayer (might try opening from desktop tonight)
5. Optical audio worked automatically (not sure if this was because of the added repo)
6. I started out using the DVI connection, when i switched to HDMi and ran the AV wizard I had to select component to get picture
7. HDMI audio is not yet working, havent looked into it.
8. 720p videos sometimes play well, others are not watchable at all, stuttering even when CPU is @ < 60%
9. I only have 1 1080 video and it was also unwatchable due to stuttering and choppy video
10. SD video is smooth and plays well other than the tearing

Thats all I can think of for now. I really like the way the board is layed out, noiseless and small... I just hope we can get this thing dialed in and working as it should. I am concerned with the tearing, and would like to hear if others are experiencing the same. Maybe we need to get a common video file that we can all compare with to see if we get the same results.
-Krys

*** Also i was wondering is it possible to watch movies in mythTV to take advantage of its use of Vdpau? or does myth only recognize certain file types.

We have so far focussed on the ability of Mythfrontend + vdpau to efficiently handle 1080i HD TV broadcast by the UK broadcasters - this it does very well in our experience on Ion based ATOM-330 & 270 mptherboards and on more traditional motherbaords fitted with nVidia 9400GT PCI graphics cards. We dont see tearing with is content in UI2 + Overlay mode (we dont use UI2 + Alphablending at all)

We are looking the code/work presented here when considering how to deliver the powerful capabilities of vdpau outside MythFrontend in media directly played back in the Orbiter.

https://launchpad.net/~brandonsnider/+archive/ppa


All the best

Andrew

Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: Zotac Ion board
« Reply #5 on: July 09, 2009, 05:00:44 am »

Andrew,
Any ideas why m2ts files wont play in 810?
-Krys

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: Zotac Ion board
« Reply #6 on: July 09, 2009, 07:57:07 am »
There´s a lot of discussion re tearing on ION based boards with nVidia 180 series driver.
Many people say it is solved in their 185 versions.

Have not tried it yet so I cannot day for sure it is better.
Version 185.19 is available from one of Avenard repos.
Don´t remember the exact url for it. (think it is his "bleeding" repo hat have it)

/niz23

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: Zotac Ion board
« Reply #7 on: July 14, 2009, 08:32:57 am »
krys, are we talking about lmce 0810 only in this post? cause I tried to install with 0710 and i have the unrecognized-nic-kernel-panic-problem

thanks
Roberto

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: Zotac Ion board
« Reply #8 on: July 14, 2009, 04:13:24 pm »
yes this is for 810 only, the NIC problem is well known with 710 and there are wiki pages documenting what you need to do. Search the wiki for "unrecognized nic"
-Krys

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: Zotac Ion board
« Reply #9 on: July 16, 2009, 08:15:43 pm »
I think in this case I will start utilizing 0810 from now on

Thanks for help
Roberto

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4431
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Zotac Ion board
« Reply #10 on: July 16, 2009, 10:53:07 pm »
There´s a lot of discussion re tearing on ION based boards with nVidia 180 series driver.
Many people say it is solved in their 185 versions.

Have not tried it yet so I cannot day for sure it is better.
Version 185.19 is available from one of Avenard repos.
Don´t remember the exact url for it. (think it is his "bleeding" repo hat have it)

/niz23

We're using the 180.60 nVidia driver and have no issue with tearing on any of the Ion motherboards we have tested todate. The Avenard repos is here; http://www.avenard.org/media/Ubuntu_Repository/Ubuntu_Repository.html

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: Zotac Ion board
« Reply #11 on: July 16, 2009, 11:32:04 pm »
Andrew,
You aren't experiencing tearing on videos? or you just dont see it on mythTV?
I currently have not tested mythTV but I do see tearing in all of my videos, wheter SD or HD and across all UI's.
-Krys

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4431
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Zotac Ion board
« Reply #12 on: July 17, 2009, 12:10:32 pm »
Andrew,
You aren't experiencing tearing on videos? or you just dont see it on mythTV?
I currently have not tested mythTV but I do see tearing in all of my videos, wheter SD or HD and across all UI's.
-Krys

To clarify we do not see tearing at all (ie not in the orbiter or in MythTV...or in vdr) on any of our Ion based MD's and we are using the nVidia 180.60 driver. We use UI2 + Overlay by the way.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

rndinokc

  • Veteran
  • ***
  • Posts: 87
    • View Profile
Re: Zotac Ion board
« Reply #13 on: August 08, 2009, 03:20:44 pm »
I hope this is the appropriate place to post this.  I have a Zotac Ion running ver 8.10.  I have installed the 180.60 drivers without any difficulty.  I have not been able to select the HDMI option and the 1080p option on the AV wizzard. Everything seems to work but the video seems to shudder for just a second intermittantly.  Possibly due to increased motion on the screen. The screen does not seem to have any tearing it is like the whole frame just pauses for a few tenths of a second.  Are there other things that need to be done to tweak the Zotac board.  Same problem on different DVDs.  This is not HD content but stored movies from the core.  Same problem also exist when DVD is read off of DVD drive.  Again, I hope this was the correct place to post.

Randy

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4431
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Zotac Ion board
« Reply #14 on: August 08, 2009, 03:39:10 pm »
I hope this is the appropriate place to post this.  I have a Zotac Ion running ver 8.10.  I have installed the 180.60 drivers without any difficulty.  I have not been able to select the HDMI option and the 1080p option on the AV wizzard. Everything seems to work but the video seems to shudder for just a second intermittantly.  Possibly due to increased motion on the screen. The screen does not seem to have any tearing it is like the whole frame just pauses for a few tenths of a second.  Are there other things that need to be done to tweak the Zotac board.  Same problem on different DVDs.  This is not HD content but stored movies from the core.  Same problem also exist when DVD is read off of DVD drive.  Again, I hope this was the correct place to post.

Randy

Hi Randy,

There are many possible explanations for what you are seeing. Do you see the video stutter on DVD's played back from a local drive or only on DVD's stored as rips? It could be a network issue when your accessing content stored on the Core or some attached storage or devices. Do you have another MD to compare against?

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk