Author Topic: Issue with auto umount/slow mount on fat32 USB drive  (Read 954 times)

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Issue with auto umount/slow mount on fat32 USB drive
« on: June 25, 2009, 08:21:13 am »
I recently bought an external USB drive, a Fantom Drive gf1000eu.  After much troubleshooting I discovered it's the source of my MDs problematic periodic pausing or freezing during media playback.  The drive is on the core and gets unmounted then remounted apparently almost constantly.  While mounting it hangs for a minute or so and causes MDs to hang with "CIFS VFS: server not responding" and several related messages while the iowait on the core shoots up to 40%+.  I also found that during this time if I type df on the core, it hangs while getting info for that specific drive.  Finally, I confirmed this by cd'ing into a directory on that drive so it would not auto unmount and that makes the MDs work fine.

When I bought the drive I simply plugged it in and let it do it's thing.  I didn't bother to format it as ext3, I simply left it as fat32, and started filling it up.  At this point I don't have enough space on the server to move everything off that drive.  Before I go through the trouble and creative shuffling and transferring across the network 240G of stuff to get the drive empty and not lose media, will formatting it as ext3 even resolve this issue or is it simply a problem related to the drive?  I do have a WD USB drive that is formatted ext3 and it works flawlessly.

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Issue with auto umount/slow mount on fat32 USB drive
« Reply #1 on: June 25, 2009, 05:35:49 pm »
Yes, i do believe there are problems with FAT32 drives, so you should certainly switch filesystems. However use XFS rather than EXT3, it has better performance for this type of usage. Just it being USB probably also has an impact though, so don't be surprised if changing filesystems doesnt clear all of it up.

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Issue with auto umount/slow mount on fat32 USB drive
« Reply #2 on: June 26, 2009, 04:44:39 am »
Yes, i do believe there are problems with FAT32 drives, so you should certainly switch filesystems. However use XFS rather than EXT3, it has better performance for this type of usage. Just it being USB probably also has an impact though, so don't be surprised if changing filesystems doesnt clear all of it up.
Ok, I'll find a way to save my media and give xfs a shot.  I do have another USB drive that is problem free and the little hack of cd'ing into a directory on that drive has made everything fine.  I also noticed the load average dropped from 2.x to 0.x.  I had been wondering why the load average was so high..  Anyway, I think the right USB drive with the right filesystem will work out, I just hope MY drive with xfs/ext3 will work.

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Issue with auto umount/slow mount on fat32 USB drive
« Reply #3 on: July 07, 2009, 05:46:11 pm »
I figured I should post my findings in case someone searches for this problem in the future.  In short, I moved all the media off my 1TB fat32 USB drive, removed the device from linuxmce, reformatted it ext3, let linuxmce add it as a new drive, then moved my media back.  This has completely resolved the weird pausing/freezing issues I was seeing on my MD.  Live TV (via Myth), media playback, even MD boot time and menu navigation are all far better now and media playback is smooth and reliable again.

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Issue with auto umount/slow mount on fat32 USB drive
« Reply #4 on: July 07, 2009, 05:54:28 pm »
thats good to hear!

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Issue with auto umount/slow mount on fat32 USB drive
« Reply #5 on: July 07, 2009, 06:19:36 pm »
BTW, I stuck with ext3 instead of xfs simply because I'm already using ext3 on my other drives.  I know you suggested xfs for better performance, and it may well be the better option, but I decided to minimize the variables.