Author Topic: Back to Beta 1  (Read 1363 times)

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Back to Beta 1
« on: December 19, 2009, 06:27:40 pm »
I'm sorry but Beta 2 is not for me, is there any way I can reinstall my core with Beta 1???
I've been using Beta 1 for a while without any major issues, but now as soon I updated to Beta 2 and reinstalling at least 4 times, I can not get my DNS-323 to work, beside the power down issue.

my big mistake is I didn't clone my Beta1 hard drive!!!
« Last Edit: December 19, 2009, 06:37:19 pm by ccoudsi »
Cheers |[BEER]
Charlie,

sambuca

  • Guru
  • ****
  • Posts: 448
    • View Profile
Re: Back to Beta 1
« Reply #1 on: December 20, 2009, 02:31:09 pm »
As you almost say yourself, you have to reinstall beta1 on your core.

I would suggest you try to help troubleshooting the issues you are having. As this IS beta software, some problems should be expected.

regards,
sambuca

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: Back to Beta 1
« Reply #2 on: December 20, 2009, 05:43:04 pm »
sambuca,
I don't have any problem helping the team with debugging the problem, especially I have a week off this holidays, except now my 2 year old who uses the system on his own every day, to play video, music and play games, even he turns on/off  the lights, now he can not watch any of his movies or play any games.

My plan is just getting the DNS-323 to work so I can get my son happy, so I can have time to debug the system, now I can see the movies and music, as soon I try to synchronize the pictures the system crashes and can not power down I have to physically shut it down, I have now only one core and DNS-323 connected.

I used the net to install the core from scratch. I have captured the log during installation, no errors were recorded, so I'm not sure this is the installation issue or it is software bugs?? no one mentioned this in the forum, but I was surpised to find out the modifications to "/etc/samba/smb.conf " was not implemented in Beta2 whish I wrote a wiki page for it.
http://wiki.linuxmce.org/index.php/D-Link_DNS-323_How_To_Install_On_LMCE-810
« Last Edit: December 20, 2009, 05:47:48 pm by ccoudsi »
Cheers |[BEER]
Charlie,

sambuca

  • Guru
  • ****
  • Posts: 448
    • View Profile
Re: Back to Beta 1
« Reply #3 on: December 20, 2009, 05:54:52 pm »
I understand your situation with others using the system, its the same for me :-)

I can't say anything about the smb.conf modification, I guess someone else should comment on that. Or if you would like to file a bug/feature request in trac, with information about how and why, that would allow someone to look at it.

A hard crash seems strange, that would indicate a kernel or hardware error (And makes troubleshooting harder, but you could check dmesg or syslog for any clues after rebooting). For starters, I would try to break down what happens during synchronization of the pictures, and try to pin point the source of the error. I.e. first try running the synchronize command from the command line, checking that the path it uses actually exists and is readable, try synchronizing without pictures - or only a few pictures.

regards,
sambuca

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: Back to Beta 1
« Reply #4 on: December 20, 2009, 09:43:21 pm »
Sambuca,
The way I setup the system now, is I have 250GB MainDrive just for the OS, also I blocked LinuxMCE the access to use it to store data, I added another 320GB drive to use as storage for LinuxMCE, and I added my DNS-323 which I told LinuxMCE to store on it only if it asks to do so.
Before, my old setup "Beta1" was main drive and DNS323 where LinuxMCE allowed to store data on them

Looking at "syslog" I found the following errors with segmentation fault, which they repeat:

Code: [Select]
Dec 20 08:22:49 dcerouter kernel: [49087.397204] DCERouter[15273]: segfault at 61006e65 ip b6e5f472 sp bfb3d250 error 4 in libc-2.8.90.so[b6dee000+158000]

Dec 20 08:26:19 dcerouter kernel: [49297.871965] mythbackend[9484]: segfault at ebe2552 ip b27752ef sp b1ea9ce0 error 6 in libmysqlclient_r.so.15.0.0[b2703000+1a1000]

Dec 20 08:27:58 dcerouter automount[6866]: >> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

Dec 20 08:28:43 dcerouter automount[15618]: >> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

Dec 20 08:33:02 dcerouter automount[27679]: >> Failed to write lock '/dev/sdb1': Resource temporarily unavailable
Dec 20 08:33:02 dcerouter automount[27679]: >> Error opening '/dev/sdb1': Resource temporarily unavailable
Dec 20 08:33:02 dcerouter automount[27679]: >> Failed to mount '/dev/sdb1': Resource temporarily unavailable
Dec 20 08:33:02 dcerouter automount[27725]: >> Failed to write lock '/dev/sdb1': Resource temporarily unavailable
Dec 20 08:33:02 dcerouter automount[27725]: >> Error opening '/dev/sdb1': Resource temporarily unavailable
Dec 20 08:33:02 dcerouter automount[27725]: >> Failed to mount '/dev/sdb1': Resource temporarily unavailable

Dec 20 08:36:02 dcerouter automount[32509]: >> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

Dec 20 08:44:10 dcerouter ntfs-3g[13479]: Unmounting /dev/sdb1 (Data)
Dec 20 08:44:16 dcerouter automount[13639]: >> Failed to write lock '/dev/sdb1': Resource temporarily unavailable
Dec 20 08:44:16 dcerouter automount[13639]: >> Error opening '/dev/sdb1': Resource temporarily unavailable
Dec 20 08:44:16 dcerouter automount[13639]: >> Failed to mount '/dev/sdb1': Resource temporarily unavailable

Dec 20 08:44:17 dcerouter automount[13696]: >> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

Dec 20 10:01:14 dcerouter kernel: [ 5657.892426] mythbackend[2115]: segfault at b4e0c3c3 ip b28b02ef sp b1fe4650 error 7 in libmysqlclient_r.so.15.0.0[b283e000+1a1000]

« Last Edit: December 20, 2009, 10:42:53 pm by ccoudsi »
Cheers |[BEER]
Charlie,

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: Back to Beta 1
« Reply #5 on: December 21, 2009, 01:00:38 am »
Thanks Sambuca for giving me hope to go and debug this problem.

I just found the cause of all the problems I had on Beta2, from Hard Crash to can not shut down the system, to can not synchronize my Pictures.

What happened to me is, when I crashed my installation from Beta1 to Beta2, I added new hard drive to my system because I was planning to do a brand new install, the system during configuration asked me if I want to use this drive "/dev/sdb1" I said yes, and I gave LinuxMCE full permission to use and store data on it, apparently LinuxMCE did not format the drive and it was never mounted, and caused chain reaction with all the above problems, please make big note for all users if they need to add new storage drive to the system they need to manually formatted !!!!!!

After several attempts I found the easiest way to format the new drive is to install "GParted " from KDE and run the GUI. The only problem I couldn't format it using XFS file system per Thom recommendations, I had to do EXT3 , maybe someone can help here !!!
 
http://forum.linuxmce.org/index.php?topic=8731.msg59087#msg59087

Now I can say cheers.


Cheers |[BEER]
Charlie,

sambuca

  • Guru
  • ****
  • Posts: 448
    • View Profile
Re: Back to Beta 1
« Reply #6 on: December 21, 2009, 09:13:49 am »
Ok, good thing it worked out for you :-)
A bit strange that an unformated hard drive would cause all these problems, on the other hand, I don't think having lmce automatically format drives would be a good thing either ;-)
sambuca

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: Back to Beta 1
« Reply #7 on: December 21, 2009, 05:43:49 pm »
Sambuca,
The drive I added was NTFS format, it was not a brand new drive, not sure if that caused all the trouble??
What I suggest is at least give the user a warning message during configuration that they need to format the secondary drive first before LinuxMCE can use it. otherwise people will thing it is done and then they will have similar crazy issues.
« Last Edit: December 21, 2009, 06:19:57 pm by ccoudsi »
Cheers |[BEER]
Charlie,