Author Topic: Hauppauge WinTV-HVR-4000  (Read 3835 times)

Schmich

  • Veteran
  • ***
  • Posts: 116
    • View Profile
Hauppauge WinTV-HVR-4000
« on: July 03, 2009, 04:14:53 am »
So I got my first LinuxMCE install going (810 alpha) and managed to get USBUIRT and my Cisco 7971 working. Now I'm stuck...or have been stuck on my DVB-T/S card for the past half a day. I've been getting all sorts of problem including writing v41(one) instead of v4l(L) and not noticing this until an hour later!

Card: Hauppauge WinTV-HVR-4000
What I've done so far is
Updated the firmware:
v1.22.82.0 (http://linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-4000#Firmware_v1.22.82.0) The v1.23.86.1 in rar format fails to extract all but one file so I took this prior version.
Code: [Select]
wget http://www.hauppauge.de/software/mce/88x_2_122_26109_WHQL.zip
unzip -jo 88x_2_122_26109_WHQL.zip Driver88/hcw88bda.sys
sudo dd if=hcw88bda.sys of=/lib/firmware/dvb-fe-cx24116-1.22.82.0.fw skip=75504 bs=1 count=32501
sudo ln -s /lib/firmware/dvb-fe-cx24116-1.22.82.0.fw /lib/firmware/dvb-fe-cx24116.fw
Installed Mercurial:
Code: [Select]
sudo apt-get install mercurialInstalled the Driver:
Code: [Select]
hg clone http://linuxtv.org/hg/v4l-dvb/
cd v4l-dvb
make
make install
reboot
VDR
I need to change my multi-switch so at the moment I'm just testing out DVB-T. So scanning in DVB-T in Switzerland:
Code: [Select]
sudo apt-get update
sudo apt-get install dvb-utils
sudo /etc/init.d/vdr stop
ls /usr/share/doc/dvb-utils/examples/scan/dvb-t
#ch-All_Incomplete for Switzerland
cd /home
sudo scan -o vdr -p -u /usr/share/doc/dvb-utils/examples/scan/dvb-t/ch-All_Incomplete > channels.conf
And this is where I'm stuck. I get this error:
Code: [Select]
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux1'
ERROR: invalid enum value '8MHZ'
initial transponder 562000000 3 5 1 1 1 3 0
ERROR: invalid enum value '8MHZ'
initial transponder 578000000 3 5 1 1 1 1 0
ERROR: invalid enum value '8MHZ'
initial transponder 594000000 3 5 1 1 1 1 0
WARNING: frontend type (QPSK) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QPSK) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QPSK) is not compatible with requested tuning type (OFDM)
ERROR: initial tuning failed
dumping lists (0 services)
Done.
I assume it's trying to use the DVB-S part of the card for the DVB-T? Well whether I'm right or wrong on that, does anyone know how to fix this? I didn't find much when searching (wiki, forum, google etc.) for this problem so I'm completely lost. If there is any information that I need to get please be very specific on what to do as this is also my first time on Linux.
MythTV
I'm not sure whether I'll choose VDR or MythTV in the end. I tried to get it to work on MythTV for a few minutes but when reading the instructions in the wiki there were too many uncertainties on what exactly to do. Right now I just want to see that my card is working and VDR instructions seemed more straight forward for a newbie like me.
« Last Edit: July 03, 2009, 04:18:30 am by Schmich »

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: Hauppauge WinTV-HVR-4000
« Reply #1 on: July 03, 2009, 05:15:55 am »
If you have an entry in /dev/dvb and are happy to use transmitted EPG..

Then for Myth TV do the following...
Run mythtv-setup and go through the steps 1-5
Add new capture card and select DVB and the type. It should show the type of your tuner.
Add Video source that uses over air EPG guide
Add input connection that connects the capture card you created with the video source.
Do a full channel search (make sure your aerial is plugged in)
Exit and select TV from your orbiter - you should see MythTV frontend startup and go straight into the default channel.


The hard bit with MythTV and DVB is getting the drivers installed and running with a firmware that works for your card but if you already have /dev/dvb/... then that is done and the setup for MythTV is very straightforward.
I did this the other day with a KWorld 395U(Actually Afatech 9015) on 810 and worked great and am impressed at the picture quality for a cheap tuner.

HTH
Darren

Schmich

  • Veteran
  • ***
  • Posts: 116
    • View Profile
Re: Hauppauge WinTV-HVR-4000
« Reply #2 on: July 03, 2009, 12:45:58 pm »
Thanks for the reply. The only card types available are these:
Analog V4L capture card
MJPEG capture card (Matrox G200, DC10)
MPEG+2 encoder card (PVR-x50, PVR-500)
FireWire cable box
USB MPEG-4 encoder box (Plextor ConvertX, etc)
DBox2 TCP-IP cable box
HDHomeRun DTV tuner box
Network Recorder
DVB DTV capture card (v3.x)

I assume that I should choose the last one I mentioned. However it seems only to be DVB-S when (atm) I want to test out DVB-T. It says:
Quote
DVB Device Number: 0
Frontend ID: Conexant CX24116/CX24118 Subtype: DVB-S
(then goes on to signal and tuning timeout followed by DisqC and Recording Options)
But I cannot change anything except for the timeouts here. So does this mean I have the same problem here that it only has/sees DVB-S? If so, where does the problem lie? :/

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Hauppauge WinTV-HVR-4000
« Reply #3 on: July 03, 2009, 04:25:34 pm »
Thanks for the reply. The only card types available are these:
Analog V4L capture card
MJPEG capture card (Matrox G200, DC10)
MPEG+2 encoder card (PVR-x50, PVR-500)
FireWire cable box
USB MPEG-4 encoder box (Plextor ConvertX, etc)
DBox2 TCP-IP cable box
HDHomeRun DTV tuner box
Network Recorder
DVB DTV capture card (v3.x)

I assume that I should choose the last one I mentioned.
Yep it is :-)
Quote
However it seems only to be DVB-S when (atm) I want to test out DVB-T. It says:
Quote
DVB Device Number: 0
Frontend ID: Conexant CX24116/CX24118 Subtype: DVB-S
Make sure that the highlight is on 'DVB Device Number:' and use the left/right cursor keys to select an un-assigned DVB-T tuner (if you have already assigned a tuner MythTV will warn you)
Quote
(then goes on to signal and tuning timeout followed by DisqC and Recording Options)
But I cannot change anything except for the timeouts here. So does this mean I have the same problem here that it only has/sees DVB-S? If so, where does the problem lie? :/

DisqC is only used for DVB-S cards. If you dont see any DVB-T tuners when following the above procedure it means that you still do not have the correct modules or possibly the correct firmware loaded for your tuner.

Andrew

Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

Schmich

  • Veteran
  • ***
  • Posts: 116
    • View Profile
Re: Hauppauge WinTV-HVR-4000
« Reply #4 on: July 04, 2009, 04:27:21 pm »
Yeh I meant I couldn't change anything including the DVB type as well. I'm away for a few days now but I'll try re-installing the firmware again when I get back then. Thanks for the help =)

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: Hauppauge WinTV-HVR-4000
« Reply #5 on: July 06, 2009, 05:39:08 am »
Hi Schmich

I have the HVR 3000 and if I am not mistaken this is sort of the same card..
Now if you say you have your dev/dvb/adapter0 folder have a look under it and see is there is like 8 files.. like frontend0 and frontend1

now with mine, Myth is not really working with the Tri -cards.. so what I needed to do is after I saw the frontend0 and 1 and others devices, is do the following..
      1)you need to create another adapter. so do the following in /dev/dvb "sudo mkdir adapter1" then create simbol links.
        " mkdir /dev/dvb/adapter1
          " ln /dev/dvb/adapter0/demux1 /dev/dvb/adapter1/demux0
          " ln /dev/dvb/adapter0/fronted1 /dev/dvb/adapter1/frontend0
          " ln /dev/dvb/adapter0/net1 /dev/dvb/adapter1/net0
          " ln /dev/dvb/adapter0/dvr1 /dev/dvb/adapter1/dvr0
     2)  After this you should be able to see the device in Mythtv 2 DVB devices. select 1 not 0 cause 0 is DVB-S. Test Myth and see if you can get something..
     3) Now to make this perminant we need to create a file in /etc/init.d/ call it what you want.
     4) then copy point 2 in to it and cave it..
     5) Now we need to make it a executable with "chmod +x {FileName}"
     6) Now w need to tell rc to run the script when booting, use this "update-rc.d {filename} defaults"

Now Myth does not pay HD channels, but I saw here that the guys sort of got it working in the UK so you may be in luck
http://forum.linuxmce.org/index.php?topic=8455.0
Hope this helps you
Chris
Ps: I got this working on Mythbuntu 9.04 and on lmce you can have alook http://www.it1stop.com/Home/linux/mythbuntu---linuxmce/mythbuntu-9-04 if it helps..