Author Topic: Newbie -> iMON Pad and VFD  (Read 4187 times)

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Newbie -> iMON Pad and VFD
« on: June 30, 2009, 07:19:19 pm »
Hi all,

i just bought a SilverStone GD01B-MXR with an iMON Pad an built in IR/VFD.

The Pad worked out of the box like a mouse, cursor steering works, left and right clicks are working too. But if i press any other button, the remote does not work any further, so i have to restart my hybrid to get the remote working again.

I read many other topics and searched in google for my problem but i can't get it running like it should.

The VFD doesn't work at all, except the backround light. I also searched a few topics for this, but my display won't display anything  >:(

Can someone PLEASE give me a walkthrought?
I am a totally linux newbie so a step-by-step description would be great.

*staying hopefully*

WhateverFits

  • Guru
  • ****
  • Posts: 228
    • View Profile
    • Sean Walker
Re: Newbie -> iMON Pad and VFD
« Reply #1 on: June 30, 2009, 10:35:30 pm »
Well, if it is acting like a keyboard then maybe xkbevd from xkbutils package will give you more information. If it is using lirc, then lirc.org should help debug it.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5496
  • DOES work for LinuxMCE.
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #2 on: July 01, 2009, 06:39:50 am »
Guys, we need proper device templates for the iMON. Does somebody want to take this on?

-Thom

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #3 on: July 01, 2009, 05:04:37 pm »
Well, if it is acting like a keyboard then maybe xkbevd from xkbutils package will give you more information. If it is using lirc, then lirc.org should help debug it.
its not acting like a keyboard, it acts like a mouse :D

ADD: i think that LIRC doesn't work.
when i type mode2 (in putty) i get this:
Code: [Select]
linuxmce@dcerouter:~$ mode2
mode2: could not get file information for /dev/lirc
mode2: default_init(): No such file or directory

if i type irw to test my remote:
Code: [Select]
linuxmce@dcerouter:~$ irw
connect: No such file or directory
« Last Edit: July 01, 2009, 07:33:11 pm by firefist235 »

gumis

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #4 on: July 01, 2009, 08:13:51 pm »
What version of iMON do you have?

I own 15c2:0038 (IR/LCD) and it's a trouble maker...

TO get this one going I had to manualy build lirc and LIRC_DCE from lmce source.

Have a look on my post: http://forum.linuxmce.org/index.php?topic=6724.msg55615#msg55615
[core/hybrid]
os: LinuxMCE
mobo: Asus P5Q/P45, 8.1 HD Intel Audio, 1GB NIC
proc: Intel-D 3GHz, LGA775
ram: 4GB OCZ
hdd: 1x160GB SATA and 2x500GB SATA
gfx: MSI GF9400GT,VGA/DVI/HDMI,512MB RAM
case: Antec Fusion MAX with iMON RC, LCD and iMON knob

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #5 on: July 01, 2009, 09:56:10 pm »
i own this one too

gumis

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #6 on: July 01, 2009, 11:40:49 pm »
So you'll need to do exactly the same thing...

Re-compile lirc to at least 0.8.4a version. As far as i remember that's when support for iMON pad starts.

When you do that, make sure that lirc creates two lircX instances under /dev. To check that execute this command:

ls -al /dev/ | grep lirc

you should see something like:

...
/dev/lirc0
/dev/lirc1
...

and that's the problem. iMON 0038 creates two instances of /dev/lircX.

Now you'll need to modify LIRC_DCE code and change default command that executes lircd for each remote from:

/usr/local/sbin/lircd --driver=default --device=/dev/lirc0 /etc/lirc/lircd.conf

to something like:
/usr/local/sbin/lircd --driver=default --device=/dev/lirc0 --pidfile=/var/run/lirc0.pid --listen=8765 /etc/lirc/lircd.conf
/usr/local/sbin/lircd --driver=default --device=/dev/lirc1 --pidfile=/var/run/lirc1.pid --output=/dev/lircd --connect=localhost:8765 /etc/lirc/lircd.conf

(read about multiple remote controls supported by lircd)


I hope this will help.
[core/hybrid]
os: LinuxMCE
mobo: Asus P5Q/P45, 8.1 HD Intel Audio, 1GB NIC
proc: Intel-D 3GHz, LGA775
ram: 4GB OCZ
hdd: 1x160GB SATA and 2x500GB SATA
gfx: MSI GF9400GT,VGA/DVI/HDMI,512MB RAM
case: Antec Fusion MAX with iMON RC, LCD and iMON knob

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #7 on: July 02, 2009, 05:31:40 pm »
i just re-compiled LIRC (0.8.6) and when i type
ls -al /dev/ | grep lirc i get this, no lirc0 or lirc1

Code: [Select]
dcerouter_108888:/lirc# ls -al /dev/ | grep lirc
crw-r--r--  1 root   root     61,   0 2009-07-02 17:24 lirc
prw-r--r--  1 root   root           0 2009-07-02 17:24 lircd
prw-r--r--  1 root   root           0 2009-07-02 17:24 lircm

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #8 on: July 07, 2009, 03:32:56 pm »
i didn't get it working.
I have installed LinuxMCE all over so i can start from the beginning.

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #9 on: July 07, 2009, 07:06:53 pm »
i just compiled LIRC and installed it.
but i get this
Code: [Select]
dcerouter_116297:~# modprobe lirc_imon
FATAL: Error inserting lirc_imon (/lib/modules/2.6.22-14-generic/misc/lirc_imon.ko): Unknown symbol in module, or unknown parameter (see dmesg)

dmesg says this:
Code: [Select]
dcerouter_116297:~# dmesg |grep lirc
[   19.224000] lirc_dev: IR Remote Control driver registered, major 61
[   19.404000] lirc_imon: Unknown symbol BIT_MASK
[   19.404000] lirc_imon: Unknown symbol BIT_WORD
[   19.444000] lirc_imon: Unknown symbol BIT_MASK
[   19.444000] lirc_imon: Unknown symbol BIT_WORD
[  217.176000] lirc_imon: Unknown symbol BIT_MASK
[  217.176000] lirc_imon: Unknown symbol BIT_WORD
[  449.236000] lirc_imon: Unknown symbol BIT_MASK
[  449.236000] lirc_imon: Unknown symbol BIT_WORD


firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #10 on: July 09, 2009, 07:50:46 pm »
can someone please help.

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #11 on: July 10, 2009, 08:35:40 pm »
i give up.
i just searched in google to solve my problem, but nothing helped

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #12 on: July 25, 2009, 10:33:16 pm »
am i really the only one with this problem?

aponcz

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #13 on: July 29, 2009, 04:06:53 pm »
firefist235 -

I too am having some issues with my IR/VFD (15c2:0038).  I have recompiled LIRC multiple times and when I download it from CVS I was getting the same errors as you were.  However, when I downloaded version 1.5 and modprobe lirc_imon was working fine however only /dev/lirc0 was listed and not /dev/lirc1.  After doing some reading, I hope it is related to my LIRC config file.

Any updates on your end?

firefist235

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
Re: Newbie -> iMON Pad and VFD
« Reply #14 on: July 29, 2009, 05:47:59 pm »
sorry no