Author Topic: Asterisk 0810 alpha 2.20 solved  (Read 1830 times)

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Asterisk 0810 alpha 2.20 solved
« on: May 21, 2009, 11:10:21 am »
After

chmod 777 extensions_additional.conf
meetme_additional.conf
sip_additional.conf
sip_registrations.conf
iax_additional.conf
iax_registrations.conf
zapata_additional.conf
queues_additional.conf

asterisk works with sipgate.


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5479
  • DOES work for LinuxMCE.
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #1 on: May 21, 2009, 11:16:03 am »
Can you guys please look at our perl scripts in /usr/pluto/bin to try and make this work out of the box? Thanks.

-Thom

felpouse

  • Veteran
  • ***
  • Posts: 99
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #2 on: June 15, 2009, 01:45:20 pm »
Hi all,

inste of doing this to change to permissin I've checked that those files had the not right owner.

Then I've only make this :

chown asterisk:asterisk extensions_additional.conf extensions_pluto_dial.conf iax_additional.conf iax_registrations.conf meetme_additional.conf provider_list.txt queues_additional.conf sccp.conf sccp.conf.template sip_additional.conf sip_registrations.conf zapata_additional.conf

The problem was that this files had root.root as owner and not the asterisk user and group, like FreePBX web interface would like to use.

Next when I make every changes in configuration and then apply config, don't ever receive the error message and all works great.

Regards

Luke

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #3 on: June 15, 2009, 01:49:47 pm »
what kind of error message did you have initially?

Murcel

felpouse

  • Veteran
  • ***
  • Posts: 99
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #4 on: June 15, 2009, 01:54:51 pm »
Hi Murcel,

see this forum messages :

http://forum.linuxmce.org/index.php?topic=8355.0
http://forum.linuxmce.org/index.php?PHPSESSID=7c0a86df1d22e8c00a602395ee3ad225&topic=8196.0

This are the common errors that happens when you try to apply for the first time you connect to freepbx and need to apply changes.

I receive this, post adding my cisco 7970 in a correct way for use it both with linuxmce and asterisk.

Bye

Luke

dlewis

  • Guru
  • ****
  • Posts: 401
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #5 on: June 15, 2009, 02:18:32 pm »
As Thom said, please please look at our perl scripts in /usr/pluto/bin to try and make this work out of the box and resubmit the new file to trac.

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #6 on: June 15, 2009, 02:24:56 pm »
i am currently setting up the enviroment and will fix this issue.

murcel

felpouse

  • Veteran
  • ***
  • Posts: 99
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #7 on: June 15, 2009, 02:34:46 pm »
Murcel,
I had found this script in /usr/pluto/bin     sync_pluto2amp.pl

In the file there are these fixing processes:

#fix permissions on each run
`chmod g+w /etc/asterisk/*`;

# fix some permisions
`chown asterisk.asterisk /usr/share/asterisk/agi-bin/*`;

I'm not a developer but I think that could be this the script that need some arrangement, I hope . It's necessary to add the chown also for the /etc/asterisk/* .

Please tell me if it's the possible correct way to fix it.

Regards

Luke

gadget

  • Veteran
  • ***
  • Posts: 136
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #8 on: June 15, 2009, 03:36:18 pm »
I had a brief look for the scripts but got lost and couldnĀ“t find where to fix.
Instead of doing a chmod 777 this would be more secure.

cd /etc/asterisk
chown asterisk:asterisk * 
chmod o+r *

gadget

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: Asterisk 0810 alpha 2.20 solved
« Reply #9 on: June 15, 2009, 04:20:59 pm »
everything in /etc/asterisk is already owned by asterisk from what I saw. if the apache user (www-data) is in the "asterisk" group, then yeah just giving write privs to "group" should work. I couldnt see where www-data was in the asterisk group, but maybe it is already.
I just got my build environment sorted out again this morning so I will take a look at this script and get a patch ready.