Author Topic: 0810 Install #2  (Read 1755 times)

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
0810 Install #2
« on: May 31, 2009, 07:06:09 pm »
After having some troubles with the asterisk, where i thought, i have something missconfigured, i started over, and made a clean 810 install. Here are the steps and the point where i am stucked:

The hardware setup is quite easy: internet through router, which is connected to the core (single NIC):

set router to dhcp

install 8.10
installed all updates through kde
installed language pack through kde
installed nvidia latest driver 98
reboot
open terminal from within kde

sudo su
aptitude update
aptitude dist-upgrade

wget -c http://deb.linuxmce.org/ubuntu/new-installer-alpha-latest.tar.gz
tar xvf new-installer-alpha-latest.tar.gz
cd new-installer
./pre-install-from-repo.sh
./mce-install.sh
./post-install.sh
reboot

AVWizard came up
Setup Wizard came up

while setup wizard downloaded files, changed to kde
open dcerouter/admin in webbrowser
changed to advanced/network/network settings
ticked enable dhcp server, inputed 192.168.80.2 - 192.168.80.100
ticked provide ip adresses fopr anonymous, inputed 192.168.80.101 - 192.168.80.253
Ticked use static ip adress under External network card eth0
inputed 192.168.1.4
255.255.255.0
gateway 192.168.1.1
nameserver 192.168.1.1
updated
closed browser
changed to setup wizard again, waited for reboot

after lmce came up, opened admin web on different windows pc

first task was to setup Asterisk
followed  http://wiki.linuxmce.org/index.php/Sipgate.co.uk

After setting up the phone lines and the phone through advanced/devices/phone lines
i ticked the orange bar and it throew an error. Something to do with permissions. from previous installations i knew that i had to chmod the following files:

linuxmce@dcerouter:~$ sudo su
[sudo] password for linuxmce:
dcerouter_114164:/home/linuxmce# cd /etc/asterisk
dcerouter_114164:/etc/asterisk# chmod 0777 sip_additional.conf
dcerouter_114164:/etc/asterisk# chmod 0777 extensions_additional.conf
dcerouter_114164:/etc/asterisk# chmod 0777 meetme_additional.conf
dcerouter_114164:/etc/asterisk# chmod 0777 sip_registrations.conf
dcerouter_114164:/etc/asterisk# chmod 0777 iax_additional.conf
dcerouter_114164:/etc/asterisk# chmod 0777 iax_registrations.conf
dcerouter_114164:/etc/asterisk# chmod 0777 zapata_additional.conf
dcerouter_114164:/etc/asterisk# chmod 0777 queues_additional.conf

After that the settings where saved and a reload was done WITHOUT any errors. (the only errors whrere the known ones, but even they exist, the asterisk normally works fine - could not reload FOB Server and Mysql Password)
if i looked under /wizard/devices/phone lines, it says sip account registered.

after the next reboot i went back to asterisk advanced configuration

the status was


retrieve_conf failed, config not applied
Reload failed because retrieve_conf encountered an error: 1

Asterisk Manager Connection Failure
Failed to connect to the Asterisk manager through port: 5038

Could not reload FOP server
Could not reload the FOP operator panel server using the bounce_op.sh script. Configuration changes may not be reflected in the panel display.

symlink from modules failed
retrieve_conf failed to sym link the /etc/asterisk/sip.conf file from modules

Failed to copy from module agi-bin
Retrieve conf failed to copy file(s) from a module's agi-bin dir: copy(/usr/share/asterisk/agi-bin/list-item-remove.php): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/dialparties.agi): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/recordingcheck): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/checksound.agi): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/directory): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/fixlocalprefix): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/enumlookup.agi): failed to open stream: Permission denied

Default SQL Password Used
You are using the default SQL password that is widely known, you should set a secure password

No email address for online update checks
You are automatically checking for online updates nightly but you have no email address setup to send the results. This can be set on the General Tab. They will continue to show up here.

So does anybody know how to solve it?!
BTW, it already run one time, on a different install.....But now i haven't installed or mixed up anything, just do it step by step.


Thanks
« Last Edit: May 31, 2009, 08:18:21 pm by murcel »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: 0810 Install #2
« Reply #1 on: May 31, 2009, 07:55:54 pm »
Be sure to install 8.10 instead of 8.04.

-Thom

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: 0810 Install #2
« Reply #2 on: May 31, 2009, 08:18:55 pm »
sorry Thom,

i meant it was 8.10, just a typo.
thanks for taking care

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: 0810 Install #2.22
« Reply #3 on: June 02, 2009, 08:41:33 pm »
hm,

now i setup up the lmce alpha 2.22 from ground incl. 810 kubuntu.
i promise i really didn't touch anything before.
avwizard was ok,
house setup, i just added rooms and user.
after that went to the dceadmin interface, looked into /advanced/configuration/phone lines and saw the same error message than above.
can anybody please point me into the right direction on how to solve this asterisk case?!

i saw that someone in the past had the same trouible, but noone was believing him, if i read the lines correctly

http://forum.linuxmce.org/index.php?topic=5534.0

gumis

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: 0810 Install #2
« Reply #4 on: June 28, 2009, 04:01:24 pm »
Hi marcel.

I had similar problems after upgrading from 710 to 810. I'll try to explain what I did to get rid some of them.

Quote
Asterisk Manager Connection Failure
Failed to connect to the Asterisk manager through port: 5038

- check your /etc/asterisk/manager.conf file and make sure that the following options are set correctly:

enabled = yes
port = 5038
bindaddr = 0.0.0.0

you might need to restart asterisk if you made any changes: /etc/init.d/asterisk restart
- check your /etc/amportal.conf and make sure that:
AMPWEBADDRESS=
- now try re-loading FreePBX

Quote
Could not reload FOP server
Could not reload the FOP operator panel server using the bounce_op.sh script. Configuration changes may not be reflected in the panel display.
I believe that FOP is not included in standard LinuxMCE installation (it wasn't in mine anyway). Normally it should be located in /var/www/htdoc/panel. At the moment I'm trying to add this option manually to my lmce 810 to get rid of yellow warning "OP Panel" button in FreePBX GUI and this error message.

Quote
symlink from modules failed
retrieve_conf failed to sym link the /etc/asterisk/sip.conf file from modules
Do the following:

mv /etc/asterisk/sip.conf /etc/asterisk/sip.conf.old
mv /etc/asterisk/iax.conf /etc/asterisk/iax.conf.old
mv /etc/asterisk/extensions.conf /etc/asterisk/extensions.conf.old
mv /var/lib/asterisk/bin/fax-process.pl /var/lib/asterisk/bin/fax-process.pl.old

/var/lib/asterisk/bin/retrieve_conf


Quote
Failed to copy from module agi-bin
Retrieve conf failed to copy file(s) from a module's agi-bin dir: copy(/usr/share/asterisk/agi-bin/list-item-remove.php): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/dialparties.agi): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/recordingcheck): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/checksound.agi): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/directory): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/fixlocalprefix): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/enumlookup.agi): failed to open stream: Permission denied

This one is tricky. There is two ways to solve this problem. You can either change apache to run as asterisk in in /etc/apache2/envvars or what I did:
- add www-data to asterisk group:
adduser www-data asterisk
- change folder permissions:
chown www-data.asterisk -R /usr/share/asterisk
- and add two additional lines at the end of /etc/amportal.conf file:
AMPASTERISKUSER=www-data
AMPASTERISKGROUP=asterisk


Quote
Default SQL Password Used
You are using the default SQL password that is widely known, you should set a secure password

This is just a warning message. I think it's just a matter of changing user name and password in /etc/amportal.conf and in mysql database (using phpMyAdmin for example). I'll post an update when I do that on mine.

Quote
No email address for online update checks
You are automatically checking for online updates nightly but you have no email address setup to send the results. This can be set on the General Tab. They will continue to show up here.
Go to "General Settings" on FreePBX GUI and:
either disable Check for Updates option or insert your e-mail address.

I hope this will help.
[core/hybrid]
os: LinuxMCE
mobo: Asus P5Q/P45, 8.1 HD Intel Audio, 1GB NIC
proc: Intel-D 3GHz, LGA775
ram: 4GB OCZ
hdd: 1x160GB SATA and 2x500GB SATA
gfx: MSI GF9400GT,VGA/DVI/HDMI,512MB RAM
case: Antec Fusion MAX with iMON RC, LCD and iMON knob