Author Topic: simple php problem  (Read 1180 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
simple php problem
« on: July 11, 2006, 11:20:11 pm »
Hi,

I'm using great mythweb plugin (web interface to mythtv pvr functionality).

I keep getting this errors on recordings page...

Quote
Error at /usr/share/mythtv/mythweb/includes/mythbackend.php, line 318:
is_file(): Stat failed for /home/mythtv/shows/192.168.0.1/1018_20060619182500.mpg.png (errno=13 - Permission denied)


--------------------------------------------------------------------------------
Details:

    datetime:  2006-07-11 22:19:43 (CEST)
    errornum:  2
  error type:  Warning
error string:  is_file(): Stat failed for /home/mythtv/shows/192.168.0.1/1018_20060619182500.mpg.png (errno=13 - Permission denied)
    filename:  /usr/share/mythtv/mythweb/includes/mythbackend.php
  error line:  318



It must be some simple trick to fix that....

Any help ?

Thanks in advance,

regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
simple php problem
« Reply #1 on: July 12, 2006, 12:54:55 pm »
yeah i was getting that. i just run chmod 777 on the files from a ssh terminal. Its not a fix, but i only used mythtv to record Doctor Who:)

Maybe the mythtv user needs to be in the same group as www-data.

i'll have a look at my machine in abit and see if i can work it out.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
simple php problem
« Reply #2 on: July 20, 2006, 04:49:58 pm »
OMG...please don't chmod 777!  That is a severe security risk since it allows anyone to do whatever they wish to that file.  Better option is to find the user that this should run under and do a chmod to add only that user with execute permissions.  The user may be "mythtv" or "user_1" or similar...  Try those options first.  IMHO, 777 should never be an option.

Kindest Regards,
Sevak

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
simple php problem
« Reply #3 on: July 20, 2006, 06:10:24 pm »
:) yeah i know, but its really hot over here in the UK at the moment and my brain isn't working.

The real fix is to make sure that mythtv and www_data are in the same group and just mod the group permissions.


but i can't check anymore as i've broke my mythweb by using another source to get extra plugins and now everything is using diffrent myth versions and mythweb is complaining.