Author Topic: MD wont play back from core or from DVD player in the MD  (Read 1437 times)

speedyone

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
MD wont play back from core or from DVD player in the MD
« on: May 19, 2009, 05:49:43 am »
I've installed linux MCE from DVD 0710 onto a core machine and have the MD in a machine with an Iwill KK266 motherboard and a Nvidia GEForce 8400GS PCI graphic card. In the UI1 mode, videos played just fine. Then I got to playing around trying to get UI2 to work by updating the Nvidia drivers. Now I'm at the point where the MD boots up in UI1 and when I try to play either a video from the DVD drive in my MD or a video from the core, the video never starts and the MD goes back to the main screen window after a few seconds.

Does anyone know if this can be fixed or do I need to start over?

Thanks,

Speedyone

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: MD wont play back from core or from DVD player in the MD
« Reply #1 on: May 19, 2009, 06:03:01 am »
The optical drive functionality is provided by the Disk Drive DCE device on the MD that the disk is in. You should probably start by using web admin -> devices tree to find those devices and note their device #

Then from a terminal,

tail -f /var/log/pluto/<#>_Disk_Drive.log

Replace the # with the appropriate device number you noted.... watch that log when you are choosing to play a DVD and see if it mentions anything that might help you determine what is wrong. Also, potentially the Orbiter (of the MD you are trying to play the DVD to), and the house-wide MediaPlugin logs might be useful.

speedyone

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: MD wont play back from core or from DVD player in the MD
« Reply #2 on: May 19, 2009, 02:58:41 pm »
The optical drive functionality is provided by the Disk Drive DCE device on the MD that the disk is in. You should probably start by using web admin -> devices tree to find those devices and note their device #

Then from a terminal,

tail -f /var/log/pluto/<#>_Disk_Drive.log

Replace the # with the appropriate device number you noted.... watch that log when you are choosing to play a DVD and see if it mentions anything that might help you determine what is wrong. Also, potentially the Orbiter (of the MD you are trying to play the DVD to), and the house-wide MediaPlugin logs might be useful.


I'll give your suggestions a try...what about the MD also not being able to play back a streamed video from the core?

Thanks much!

speedyone

jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: MD wont play back from core or from DVD player in the MD
« Reply #3 on: May 19, 2009, 03:05:38 pm »
is it something simple like your libdvdcss2 isn't installed?


pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: MD wont play back from core or from DVD player in the MD
« Reply #4 on: May 19, 2009, 05:11:35 pm »
... and if libdvdcss2 wasn't (on the core and MD) don't forget the other packages. (w32codecs or w64codecs (on 710 64 bit) and the other I can'y remember of the top of my head but the wizard asks if you want all three.  They have to be selected and are checked when loaded.

Cheers.

jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: MD wont play back from core or from DVD player in the MD
« Reply #5 on: May 19, 2009, 10:07:39 pm »
... and if libdvdcss2 wasn't (on the core and MD) don't forget the other packages. (w32codecs or w64codecs (on 710 64 bit) and the other I can'y remember of the top of my head but the wizard asks if you want all three.  They have to be selected and are checked when loaded.

Cheers.

810 doesn't yet- at least on mine.  Unlike 710, you cannot select those from the list during the setup and have them installed, you have to to it manually.  There is another post about logging into a MD as the root- I wonder if he/she was trying to install the software directly on the MD rather than go through the core.  I ran into this myself and eventually just went the /usr/pluto/diskless/moon ## way to get done on the MDs what I needed done from the core.

BTW- even if libdvdcss2 is installed on the core, it must be installed on the MD that you want to watch an encrypted DVD on.  That is to say, that if you installed libdvdcss2 on the core, but not a MD, and put a DVD in the MD's DVD player you will get a similar response to what you (speedyone) experienced- the screen would blip black for a moment and then kick back to the main screen.  Usually (maybe every time) a message is displayed in the upper left hand corner stating that the dvd is unreadable or something isn't installed.  FWIW.
« Last Edit: May 19, 2009, 10:11:20 pm by jimmejames »

speedyone

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: MD wont play back from core or from DVD player in the MD
« Reply #6 on: May 20, 2009, 06:11:00 am »
I'm back in business......I ended up deleting the MD from the web admin page and then re-booting my MD. It loaded everything it needed and works fine.

Thanks to all for your suggestions  :)

Peace

Speedyone

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: MD wont play back from core or from DVD player in the MD
« Reply #7 on: May 20, 2009, 08:57:15 am »
speedyone,

if libdvdcss is installed on the core, each subsequent MD creation will contain the libdvdcss as well.

jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: MD wont play back from core or from DVD player in the MD
« Reply #8 on: May 20, 2009, 03:16:37 pm »
speedyone,

if libdvdcss is installed on the core, each subsequent MD creation will contain the libdvdcss as well.

Is this new in 810?  710 was/is not like this- I don't have to tell you, but you have to install it on each MD.  Will 810 copy over the addons you install on the core over to newly created MDs or is this an alpha thing that will be changed later?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: MD wont play back from core or from DVD player in the MD
« Reply #9 on: May 20, 2009, 03:51:50 pm »
if libdvdcss is installed on the core, each subsequent MD creation will contain the libdvdcss as well.
Will 810 copy over the addons you install on the core over to newly created MDs

This is only true for the libdvdcss2