Author Topic: mame install error when running 'make'  (Read 1060 times)

fistfight

  • Newbie
  • *
  • Posts: 9
    • View Profile
mame install error when running 'make'
« on: May 10, 2009, 08:57:22 pm »
I get past checkingout the svn but when I run make I get a buch of errors about files not existing. This is a fresh install of the DVD install. I understand that meme isnt supported on 7.10 but I was just curious if something was done to the files  to break it until 8.10 is release?

This is what I get when I run make...

Code: [Select]
Checked out revision 21983.
linuxmce@dcerouter:~$ cd trunk/
linuxmce@dcerouter:~/trunk$ ./configure
linuxmce@dcerouter:~/trunk$ make
I need to run sudo...
[sudo] password for linuxmce:
"src/Ubuntu_Helpers/"/RunFunction.sh /home/linuxmce/trunk SUDO_Install_Build_Nee                                                                  ded_Packages_SUDO
/usr/pluto/bin/Config_Ops.sh: line 207: ulimit: open files: cannot modify limit:                                                                   Operation not permitted
OK
Retrieving updated package lists
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/main/binary-i386/Pa                                                                  ckages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/restricted/binary-i                                                                  386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/multiverse/binary-i                                                                  386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/universe/binary-i38                                                                  6/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/main/binar                                                                  y-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://linuxmce.com/ubuntu/./Packages.gz  404 Not Found
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/restricted                                                                  /binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/multiverse                                                                  /binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/universe/b                                                                  inary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/main/binary                                                                  -i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/restricted/                                                                  binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/multiverse/                                                                  binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/universe/bi                                                                  nary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
E: Some index files failed to download, they have been ignored, or old ones used                                                                   instead.
Installing general development packages
.E: Package asterisk-dev has no installation candidate
Error installing asterisk-dev
.E: Package autoconf has no installation candidate
Error installing autoconf
.E: Couldn't find package automake
Error installing automake
.E: Couldn't find package automake1.10
Error installing automake1.10
.E: Couldn't find package autotools-dev
Error installing autotools-dev
.E: Couldn't find package build-essential
Error installing build-essential
.E: Couldn't find package cdw
Error installing cdw
.E: Package debhelper has no installation candidate
Error installing debhelper
..E: Package dh-make has no installation candidate
Error installing dh-make
..E: Package fakeroot has no installation candidate
Error installing fakeroot
..E: Broken packages
Error installing g++
...E: Couldn't find package libavcodec-dev
Error installing libavcodec-dev
.E: Couldn't find package libavformat-dev
Error installing libavformat-dev
..E: Package libcaca-dev has no installation candidate
Error installing libcaca-dev
..E: Couldn't find package libcdio-dev
Error installing libcdio-dev
..E: Couldn't find package libconfuse-dev
Error installing libconfuse-dev
..E: Couldn't find package libdancer-xml0-dev
Error installing libdancer-xml0-dev
...E: Package libdirectfb-dev has no installation candidate
Error installing libdirectfb-dev
..E: Package libesd0-dev has no installation candidate
Error installing libesd0-dev
.E: Couldn't find package libfuse-dev
Error installing libfuse-dev
.E: Couldn't find package libglade2-dev
Error installing libglade2-dev
.E: Couldn't find package libgnomevfs2-dev
Error installing libgnomevfs2-dev
.E: Broken packages
Error installing libgtk2.0-dev
.....E: Broken packages
Error installing liblinphone1-dev
..E: Couldn't find package libmad0-dev
Error installing libmad0-dev
.E: Couldn't find package libmediastreamer0-dev
Error installing libmediastreamer0-dev
.E: Couldn't find package libmodplug-dev
Error installing libmodplug-dev
.E: Couldn't find package libmpcdec-dev
Error installing libmpcdec-dev
.E: Couldn't find package libpostproc-dev
Error installing libpostproc-dev
...E: Broken packages
Error installing libqt3-mt-dev
........E: Couldn't find package libtcltk-ruby
Error installing libtcltk-ruby
.E: Couldn't find package libtheora-dev
Error installing libtheora-dev
.E: Couldn't find package libupnp-dev
Error installing libupnp-dev
..E: Couldn't find package libvte-dev
Error installing libvte-dev
..E: Couldn't find package libxcb-shape0-dev
Error installing libxcb-shape0-dev
.E: Couldn't find package libxcb-shm0-dev
Error installing libxcb-shm0-dev
.E: Couldn't find package libxcb-xv0-dev
Error installing libxcb-xv0-dev
.E: Couldn't find package libxine-dev
Error installing libxine-dev
....E: Package mkisofs has no installation candidate
Error installing mkisofs
.E: Couldn't find package module-assistant
Error installing module-assistant
...E: Couldn't find package nasm
Error installing nasm
.E: Couldn't find package qt3-apps-dev
Error installing qt3-apps-dev
.E: Couldn't find package qt3-assistant
Error installing qt3-assistant
.E: Couldn't find package qt3-designer
Error installing qt3-designer
..E: Couldn't find package qt3-dev-tools-compat
Error installing qt3-dev-tools-compat
.E: Couldn't find package qt3-dev-tools-embedded
Error installing qt3-dev-tools-embedded
.E: Couldn't find package qt3-linguist
Error installing qt3-linguist
.E: Couldn't find package qt3-qtconfig
Error installing qt3-qtconfig
.E: Couldn't find package quilt
Error installing quilt
..E: Couldn't find package sgmltools-lite
Error installing sgmltools-lite
.E: Couldn't find package squashfs-tools
Error installing squashfs-tools
...E: Couldn't find package tcl8.4-dev
Error installing tcl8.4-dev
.E: Couldn't find package transfig
Error installing transfig
.....E: Couldn't find package x11proto-xf86vidmode-dev
Error installing x11proto-xf86vidmode-dev
.E: Couldn't find package xorg-dev
Error installing xorg-dev
.E: Couldn't find package libdvb-dev
Error installing libdvb-dev
.E: Couldn't find package libavc1394-dev
Error installing libavc1394-dev
.E: Package liblame-dev has no installation candidate
Error installing liblame-dev
.E: Couldn't find package libiec61883-dev
Error installing libiec61883-dev
..E: Couldn't find package libimlib2-dev
Error installing libimlib2-dev
.E: Couldn't find package texi2html
Error installing texi2html
.E: Couldn't find package ccache
Error installing ccache
.E: Couldn't find package libtag1-dev
Error installing libtag1-dev

Installing mysql stuff
Installing libxine development packages
.E: Package libcaca-dev has no installation candidate
Error installing libcaca-dev
..E: Couldn't find package libtheora-dev
Error installing libtheora-dev
.E: Couldn't find package libflac-dev
Error installing libflac-dev=1.1.2-5ubuntu2
.E: Couldn't find package libmodplug-dev
Error installing libmodplug-dev
.E: Couldn't find package libgnomevfs2-dev
Error installing libgnomevfs2-dev
..E: Couldn't find package libmad0-dev
Error installing libmad0-dev
.E: Package libxvmc-dev has no installation candidate
Error installing libxvmc-dev
.E: Package automake1.9 has no installation candidate
Error installing automake1.9
.E: Package autoconf has no installation candidate
Error installing autoconf
.E: Package libtool has no installation candidate
Error installing libtool
.E: Couldn't find package libcdio-dev
Error installing libcdio-dev
.E: Couldn't find package sgmltools-lite
Error installing sgmltools-lite
.E: Couldn't find package dpatch
Error installing dpatch
.E: Couldn't find package transfig
Error installing transfig
.E: Couldn't find package libavformat-dev
Error installing libavformat-dev
.E: Couldn't find package libpostproc-dev
Error installing libpostproc-dev
.E: Couldn't find package libavcodec-dev
Error installing libavcodec-dev
..
Installing Linux headers for installed Linux release, needed for pluto-asterisk
Installing lirc-source for installed Linux release
E: Package linux-source-2.6.22 has no installation candidate
E: Package lirc-modules-source has no installation candidate
ivtv-source (TODO still needed? -- dtk)
E: Couldn't find package ivtv-source
Installing KDE development libraries 710
E: Couldn't find package kdelibs4-dev
Removing libdvdnav-dev to make room for libxine version
make start_build_db
make[1]: Entering directory `/home/linuxmce/trunk'
/usr/pluto/bin/Config_Ops.sh: line 207: ulimit: open files: cannot modify limit:                                                                   Operation not permitted
Backing up Database
/var/lib /home/linuxmce/trunk


Have the needed files been removed?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5502
  • DOES work for LinuxMCE.
    • View Profile
Re: mame install error when running 'make'
« Reply #1 on: May 11, 2009, 12:12:54 am »
yikes! do not use trunk!

The MAME player/plugin are not supported anymore for 0710, and trunk will be completely shelved, and replaced with the LinuxMCE-0810 branch.

If you want MAME, use the Game Player in 0810. (that would imply installing 0810)

-Thom