Author Topic: 8.10 Hybrid Core  (Read 3509 times)

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 8.10 Hybrid Core
« Reply #30 on: May 11, 2009, 01:24:24 pm »
Pigdog,

did you update your MD as well?

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 999
    • View Profile
Re: 8.10 Hybrid Core
« Reply #31 on: May 11, 2009, 01:45:04 pm »
Hi posde,

After applying 2.19 I reboot the core, tried the MD.

Since it didn't work I ssh'd into moon31 - was root, did update and dist-upgrade and nothing to apply.

Thanks.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 8.10 Hybrid Core
« Reply #32 on: May 11, 2009, 01:51:53 pm »
[..]ssh'd into moon31 - was root, did update and dist-upgrade and nothing to apply.

This is strange. Please post your sources.conf of your MD, and the output of
Code: [Select]
dpkg -l|grep pluto-booton both, the md and the core.

PS: You don't need to ssh into your moon. On the core, you can do
Code: [Select]
chroot /usr/pluto/diskless/<id of media-director>
apt-get update
apt-get upgrade

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 999
    • View Profile
Re: 8.10 Hybrid Core
« Reply #33 on: May 11, 2009, 02:52:58 pm »
Before you replied I had gone back to put the broadcast option back into dhcp3 and I booted the Core & MD system.  I have rebuilt the system from scratch so many times I had missed it the last rebuild. When executing dpkg I saw a difference between the two.

On Core

dcerouter_112566:~# dpkg -l|grep pluto-boot
ii  pluto-boot-scripts                         2.0.0.44.09051121983                        <insert up to 60 chars description>
dcerouter_112566:~#

On MD

root@dcerouter:/# dpkg -l|grep pluto-boot
ii  pluto-boot-scripts                         2.0.0.44.09050721973                        <insert up to 60 chars description>
root@dcerouter:/#

So using chroot I did an apt-get update

Fetched 6756B in 1s (4706B/s)                                                                                                                 
W: GPG error: http://packages.medibuntu.org intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783                                                                                                               
W: Failed to fetch file:/usr/pluto/deb-cache/./Packages.gz  File not found                                                                     
E: Some index files failed to download, they have been ignored, or old ones used instead.

On my earlier attempt using ssh I did not get the public key error.

Just to verify using ssh

Reading package lists... Done
W: GPG error: http://packages.medibuntu.org intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
W: You may want to run apt-get update to correct these problems


This morning prior to adding the broadcast option upon doing apt-get dist-upgrade I had received

Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Now I received...

The following packages will be upgraded:
  pluto-boot-scripts
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I upgraded pluto-boot scripts and reboot the MD.

Recheck the installed package.

dcerouter_112566:~# chroot /usr/pluto/diskless/31
root@dcerouter:/# dpkg -l|grep pluto-boot
ii  pluto-boot-scripts                         2.0.0.44.09051121983                        <insert up to 60 chars description>
root@dcerouter:/#

Matched.  Went to MD and ran KDE desktop.  Took a while but it is UP!  Yeah!

However, when the MD initially boots it reports that it gets the broadcast address from the Core.

It looks like something is not clicking between the Core and MD yet.

Now maybe I can get the kernel panic on the other MD sorted out.

Thank you very much posde for pointing me in the right direction.  I really appreciated your help.
« Last Edit: May 11, 2009, 02:57:29 pm by pigdog »

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 8.10 Hybrid Core
« Reply #34 on: May 11, 2009, 03:14:27 pm »
Matched.  Went to MD and ran KDE desktop.  Took a while but it is UP!  Yeah!

Yes, it does take a while on the first start of the KDE Desktop after a MD start.
Quote
However, when the MD initially boots it reports that it gets the broadcast address from the Core.

If you have added it to the dhcpd.conf file manually, that is expected, and correct.

castlec

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: 8.10 Hybrid Core
« Reply #35 on: May 11, 2009, 06:32:41 pm »
So I've done a fresh install based on 2009/05/11 updates.  After orbiter gen, a note comes up saying that the orbiter is unable to register with the router.  From the time I was able to spend in front of it, the router never did respond to the orbiter.  The router process is up.  Does anyone have any suggestions on things I should look at before opening a bug report?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 8.10 Hybrid Core
« Reply #36 on: May 11, 2009, 08:11:00 pm »
Please check that you have mce-diskless-utils 2.0.0.44.09051121984. If not, apt-get update && apt-get upgrade and try again!

pigdog

  • wants to work for LinuxMCE
  • **
  • Posts: 999
    • View Profile
Re: 8.10 Hybrid Core
« Reply #37 on: May 11, 2009, 08:16:24 pm »
Hi posde,

This is what I meant.

The following would happen whether or not /etc/dhcp3/dhcpd.conf had the option broadcast-address programmed.

When you boot the MD up, after you receive ...

eth0: link up

... you get ...

IP-Config: eth0: complete (from 192.168.80.1)
address:192.168.80.2   broadcast:192.168.80.255   netmask:255.255.255.0
gateway:192.168.80.1   dns0:192.168.80.1   dns1: 0.0.0.0
rootserver: 192.168.80.1   rootpath:
filename:  /tftpboot/prelinux.0

That's what I meant by "However, when the MD initially boots it reports that it gets the broadcast address from the Core."

It was only after putting the broadcast-address on the Core I was able to get the 2.19 update.

I needed the 2.19 update to get KDE desktop running because right now with or without the broadcast-address programmed  in dhcpd.conf - KDE runs on the MD.

I'm just wanting to fully understand what happened because originally I thought the problem was KDE broadcast-address related.

But, the problem was I couldn't get the latest update.

I had the 2.18 pluto-boot-scripts (2.0.0.44.09050721973) because of my rebuild.

So, just to be sure, in order to update my MD(s) I need dhcpd.conf programmed with the broadcast address?


Thanks again for your help.