Author Topic: Should the Cisco 7970 pnp scripts automatically register the device in FreePBX?  (Read 3135 times)

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Problem solved:

So that no other 7970 users will have to endure what I had to in order to get this working, here is the simple solution that our friend from Orange County either refused to divulge or simply did not know the answer to:

Linuxmce automatically sets up the Cisco 7970 but apparently there are bugs that prevent it from completing this setup occasionally. In my case,everything worked except that you could not call the phone from an internal extension. What you need to do to get this to work:

1) In the web admin got to Wizard\Devices\phones and then scroll down to where the Cisco 7970 is listed in the description column. The bolded number to the left is the pluto device number that has been assigned by the setup script copy that as well as the info in the phone type and phone number boxes.

2) Go to Advanced\Configuration\Phones setup in the column. Under the FreePBX logo you will see "Extensions" click on that. On the right side of that page will be the list of extensions. If you do not see an extension with with the phone number you copied in step 1, you will need to add it.

3) In the drop-down box next to the word "Device" choose, Other (custom) Device, and hit submit. This will take you to a screen that will allow you to fill in various fields.  For the
Display Name put whatever you want --I put Cisco 7970
Outbound CID put something like "pl_142" <210> where 142=the pluto id number from step 1 and 210=the phone number from step 1. The formatting with " and <> needs to be included.
Under Device Options next to Dial put SCCP/210 where SCCP=phone type from step 1 and 210=phone number (this is the secret sauce to getting asterisk to recognize that it is a sccp extension it is dialing.
Under voice mail and directory you will need to select "enable" from the drop down box as there is an apparent bug--at least in my version of FreePBX which is too much trouble to fix.

All the other fields can be left blank or default.

Now hit submit. It will register you SCCP extension and you will see it on the right side of the page.

Click on it. Go back and disable the Voicemail in FreePBX so that you use the linuxmce voicemail instead.
Hit submit again--this time it will accept it without balking that you do not have voicemail.

Now at the top of the page you will see an orange box on a blue background "apply configuration changes" click on that and apply the changes in the next screen.

Go to another extension and call your SCCP Cisco 7970 phone. It should be working now.

Please note, this is the quick and dirty fix using SCCP based on my particular problem. From everything I have read, SCCP is fraught with problems and SIP is the way to go with asterisk--but requires that you either buy a license for the firmware or order the phone with SIP. Perhaps the next release of linuxmce will support SIP configurations of this phone as well.

Happy dialing

ivanp

  • Veteran
  • ***
  • Posts: 94
    • View Profile
Please make a wiki page for Your problem and how You resolved it. That way people dont have to search the forums to find an answer.

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile

dlewis

  • Guru
  • ****
  • Posts: 401
    • View Profile
Please make a wiki page for Your problem and how You resolved it. That way people dont have to search the forums to find an answer.

Don't make a seperate wiki site... There is a 7970 wiki site found here: http://wiki.linuxmce.org/index.php/Cisco_7970 . Add it to that wiki site.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2958
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
How about not wikiing the stuff, but looking at the configure script for the Cisco 7970 phone and fixing it?

I have installed a few Cisco phones into my LinuxMCE install, and the only thing I ever had to do, was extending the mac range. Nothing else.

So, if you come across a problem with our current configure script, why don't you fix the configure script, so other people do NOT have to manually go around and edit stuff.

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
I second possy. Please try to reproduce and debug the issue. 20-step long workarounds do not help, if there is a bug in the setup script it shall be easilly fixed.

br, Hari
rock your home - http://www.agocontrol.com home automation

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Gentlemen,

While you figure out what is wrong with the script, would you mind if I posted this to the Wiki to save some other unfortunate soul the frustration of having the expensive and highly lauded device they have purchased for use with linuxmce not working? I mean, I am thrilled that it works for some or most, but it did not work here and took quite a bit of time to figure it out--and it did not have to do with changing the mac range. Unless I hear otherwise I will go ahead, but please let me know if a fix is nearing completion.

Many thanks for all your help.

Best regards.

bugui

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Hello,
I have a 7970 running at home, and I setup it using the document on the wiki, and without any problems. It was PNP for me.
I think that your issue is not a common one, maybe you didn't complete the procedure and you unplug and re-plug the phone again.
Did you turn off the phone before doing a reload router?.

Sorry by my english

Regards
Hernan