Author Topic: Club3D GeForce 9400 GT & Sound Blaster X-Fi Titanium PCI-E  (Read 1160 times)

ramonh

  • Newbie
  • *
  • Posts: 13
    • View Profile
Club3D GeForce 9400 GT & Sound Blaster X-Fi Titanium PCI-E
« on: April 25, 2009, 04:04:32 pm »
Hi guys

I'm new to LinuxMCE, please don't blame me, if I'm too silly  ::)

After some problems installing LinuxMCE 0710 i386 with the 3 CDs because I wanted to have custom partition on an 32 GB SSD, where I want the system to be installed, I have installes the DVD 0710 i386 and it worked well.
But I have poor graphic  :(

I downloaded the NVidia Linux Display Driver - x86 and installed it from tty3. I was told that the driver doesn't include a version for the installed kernel and will check the website. Nothing was found.
Therefore the driver was compiled.
After that it asked me if I want to configure the X configuration file. I chose yes.
I was told that the installation was successful.

But unfortunately the system doesn't boot any more. There are two screen that alternate all the time:

Code: [Select]
* Re-exporting directories for NFS kernel daemon...   [ OK ]
and

Code: [Select]
Starting up ...
[   0.528000] PCI: Cannot allocate resource region 3 of device 0000:00:00.0
Loading, please wait...

Ubuntu 7.10 dcerouter tty1

dcerouter login:                            [ OK ]

* Starting Samba daemons                    [ OK ]

* Reloading /etc/samba/smb.conf...          [ OK ]

* Starting Samba daemons                    [ OK ]

* Restarting UPnP Media Server fuppesd      [ OK ]


I have no clue, what I can do, to make the graphics card work :(
Any help is highly appreciated!

Maybe I should try 0810?



Edit: My system looks like this

Silverstone SST-GD01S-MXR Grandia Desktop
Silverstone SST-ST30NF-GM Fanless-Series - 300 Watt
MSI K9A2 CF-F, AMD 790X, Socket AM2+, CF
AMD Athlon 64 X2 5050e BOX, Socket AM2, Dual Core, 65nm
Silverstone SST-NT01-E Fanless Heatpipe Cooler
Corsair TWIN2X2048-6400C4, 4x1GB, DDR2-800, CL4
Club3D 9400GT Passive, PCI-E x16, 512MB, HDMI (nVidia GeForce Chipset)
Hauppauge WinTV-HVR-1300, analog TV und DVB-T Hybrid Tuner
« Last Edit: May 01, 2009, 11:35:52 pm by ramonh »

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Club3D GeForce 9400 GT driver problem
« Reply #1 on: April 26, 2009, 01:48:16 am »
The bit I think you got wrong was telling it to reconfig your x config file.... it will screw it up, you should say no.

Probably start by rebooting, and when you get the kubuntu loader screen, hold down the shift key to get back into the AV Wizard. This should overwrite your xorg.conf file with the standard one.... that will be a good starting point. Then we just need to get your xorg.conf into working order! Let me know what this does.... Don't forget the keyboard shortcuts inside the AV Wizard that let you choose the output port and resolution (keys 1 - 0). If it doesn't work post your /var/log/Xorg.0.log file here..

ramonh

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Club3D GeForce 9400 GT driver problem
« Reply #2 on: April 26, 2009, 04:06:40 pm »
Thanks alot for your answer!

I have booted and pressed shift to enter the AV Wizard. But a blue screen with a grey AVWizard window says that it "Failed to setup X".
I tried to copy the backup xorg.conf to get a working version back. This was not successful too.

Then I installed LMCE and the driver again. This time without updating xorg.conf. The result was the same sreen that tells me that it "Failed to setup X".

My xorg.conf looks like this:
Code: [Select]
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NVIDIA Default Card"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "XvmcUsesTextures" "true"
Option "renderAccel" "true"
Option "NoDDCValue"
Option "UseEDID" "false"
Option "ExactModeTimingsDVI" "true"
Option "NoLogo" "true"
Option "NoBandWidthTest" "true"
Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
Option "DynamicTwinView" "false"
Option "UseEvents" "true"
Option "AllowGLXWithComposite" "true"
Option "AddARGBGLXVisuals" "true"
Option "ConnectedMonitor" "DFP"
EndSection

Section "Monitor"
Identifier "DVI TV"
Option "DPMS"
Modeline "1280x720" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
HorizSync 20-500
VertRefresh 59-61
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NVIDIA Default Card"
Monitor "DVI TV"
DefaultDepth 24
SubSection "Display"
Modes "1280x720"
Virtual 1280 720
EndSubSection
Option "XvmcUsesTextures" "true"
Option "renderAccel" "true"
Option "NoDDCValue"
Option "UseEDID" "false"
Option "ExactModeTimingsDVI" "true"
Option "NoLogo" "true"
Option "NoBandWidthTest" "true"
Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
Option "DynamicTwinView" "false"
Option "UseEvents" "true"
Option "AllowGLXWithComposite" "true"
Option "AddARGBGLXVisuals" "true"
Option "TVStandard" "720p"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
EndSection
Section "Extensions"
Option "Composite" "true"
Option "RENDER" "true"
EndSection

ramonh

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Club3D GeForce 9400 GT driver problem
« Reply #3 on: April 26, 2009, 07:19:11 pm »
I have found a post (http://forum.linuxmce.org/index.php?topic=5503.0) where gatesgil had a solution:
Code: [Select]
sudo dpkg-reconfigure -phigh xserver-xorg
After that I was able to enter the AVWizard and choose the solution.
But only solutions like 800x600 and 1024x768 worked. Since my TV is widescreen I wanted to choose 720p or 1080p. But there I see alot of thin stripes. :-\
After choosing 1024x768 and waiting until everything was configured, I get a screen with the message:
"Orbiter failed to setup the transparency. Please check if the transparency manager is running."
Then I tried OpenGL standard instead of high end, this brought the message "Orbiter failed to initialize OpenGL".

Because I had to go, I couldn't try the option without OpenGL.

My xorg.conf looks now like this:
Code: [Select]
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NVIDIA Default Card"
Driver "vesa"
BusID "PCI:1:0:0"
Option "XvmcUsesTextures" "true"
Option "renderAccel" "true"
Option "NoDDCValue"
Option "UseEDID" "false"
Option "ExactModeTimingsDVI" "true"
Option "NoLogo" "true"
Option "NoBandWidthTest" "true"
Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
Option "DynamicTwinView" "false"
Option "UseEvents" "true"
Option "AllowGLXWithComposite" "true"
Option "AddARGBGLXVisuals" "true"
Option "ConnectedMonitor" "DFP"
EndSection

Section "Monitor"
Identifier "DVI TV"
Option "DPMS"
Modeline "1024x768" 60.80 1024 1056 1128 1272 768 768 770 796
HorizSync 20-500
VertRefresh 59-61
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NVIDIA Default Card"
Monitor "DVI TV"
DefaultDepth 24
SubSection "Display"
Modes "1024x768"
Virtual 1024 768
EndSubSection
Option "XvmcUsesTextures" "true"
Option "renderAccel" "true"
Option "NoDDCValue"
Option "UseEDID" "false"
Option "ExactModeTimingsDVI" "true"
Option "NoLogo" "true"
Option "NoBandWidthTest" "true"
Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
Option "DynamicTwinView" "false"
Option "UseEvents" "true"
Option "AllowGLXWithComposite" "true"
Option "AddARGBGLXVisuals" "true"
Option "TVStandard" "1024x768"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
EndSection
Section "Extensions"
Option "Composite" "false"
Option "RENDER" "true"
EndSection


How can I make 720p and high-end OpenGL working?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Club3D GeForce 9400 GT driver problem
« Reply #4 on: April 26, 2009, 11:50:05 pm »
First up, you are now using the vesa driver in the latest config... that's no good. Also, dump the idea of UI2 Blended for now.... you are unlikely to want that anyway due to the screen tearing issues, use UI2 masking (the mid range option).

Before you go back into AV Wizard to change that, you need to edit your xorg.conf file and change vesa in the device section to nvidia. While you are in there, change BOTH instances (in the device section and the screen section) of UseEDID false to UseEDID true... then boot to the wizard and change the UI level...

This will log more info to the /var/log/Xorg.0.log file in case it fails to use that driver again. Then we can look and see at which point it is failing.

If it does work, there is a possibility that you may end up with tiny fonts... don't worry about that yet, its easily fixed....

ramonh

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Club3D GeForce 9400 GT driver problem
« Reply #5 on: April 27, 2009, 07:28:40 pm »
Thank you again for your help ;D

Unfortunately I won't be able to check that before next Thursday...

I will post the latest news ;)

ramonh

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Club3D GeForce 9400 GT & Sound Blaster X-Fi Titanium PCI-E
« Reply #6 on: May 02, 2009, 12:26:38 am »
I was able to install and setup the driver properly  :D
But to be honest I have no clue how ??? :P

I have bought a Sound Blaster X-Fi Titanium PCI-E card to have optical SPDIF. I decided to install LinuxMCE again to get the drivers. But I couldn't even install LinuxMCE (not even as far as before...)
After removing the card and several attempts it worked (don't ask me how :o)

The graphic card worked properly after installing the drivers and not updating the xorg.conf
Suprisingly the driver was already set to nvidia (I have chosen to make a clean install when I was asked)
I set both useEDID to true and restarted the AV Wizard. Now almost everything worked. But my TV wasn't able to display 720p but 1280x800 with alpha blending.
Maybe it has to do with these settings?

But the sound card doesn't work. Do I have to set the correct bus address?

I have another problem: I installed a HDD with music and videos but I can't access the content. When I want to access it from KDE it tells me "hal-storage-foxed-mount refused uid 1000"
« Last Edit: May 02, 2009, 12:32:05 am by ramonh »

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Club3D GeForce 9400 GT & Sound Blaster X-Fi Titanium PCI-E
« Reply #7 on: May 02, 2009, 04:03:06 am »
last time I looked, SB X-Fi had no support whatsoever for Linux of any kind and the company made it clear they had no intentions of supporting it.... please try looking for support before buying hardware! Don't bother with the Alpha blended UI just go for the UI2 Masking

ramonh

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Club3D GeForce 9400 GT & Sound Blaster X-Fi Titanium PCI-E
« Reply #8 on: May 02, 2009, 11:34:33 am »
Thank you for the reply.

I saw that other sound blaster cards are supported but couldn't find them on my local store.