Author Topic: EIB/KNX configuration  (Read 1195 times)

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3535
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: EIB/KNX configuration
« Reply #30 on: December 30, 2016, 04:14:40 pm »
I put it under the core, after all, that's where the eibd runs as well. But I do not think it really matters.

So, you now have the eibd running? That's good. Please paste
Code: [Select]
ps ax|grep eib -i
from the core, so I can have a look.

girlaldo

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Re: EIB/KNX configuration
« Reply #31 on: January 04, 2017, 11:52:53 am »
Happy new year all,
I'm back again with my problems.
I do not know if after trying to configure my EIB/KNX interface of the new vm or after an autoremove, I got millions of log messages like those that I finally posted.
So I went back to the earlier lmce vbox vm that gave me the message segmentation fault when installing lmce-eib-eibd and without trying to add the 2195 profile I checked if eibd was running and I got this:

aldo@dcerouter:~$ ps ax | grep eib -i                                                                         
 5646 pts/25   Sl+    0:00 /usr/pluto/bin/EIB -d 36 -r localhost -l /var/log/pluto/36_EIB.log
 6091 pts/0    S+     0:00 grep --color=auto eib -i
19021 ?        Ss     0:00 /usr/bin/SCREEN -d -m -S KNX_via_eibd36 /usr/pluto/bin/Spawn_Device.sh 36 localhost EIB
19024 pts/25   Ss+    0:00 /bin/bash /usr/pluto/bin/Spawn_Device.sh 36 localhost EIB

looking at it my questions are:
is the eibd running ok?
If yes, how can I check it by the web admin interface?
And how can I test it switching one light on/of
And how can I configure lmce so that I can access my EIB/KNX from both lmce and ETS4 at the same time?
Thank you so much


posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3535
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: EIB/KNX configuration
« Reply #32 on: January 04, 2017, 02:43:12 pm »
eibd is not running.

run it manually with the known commandline. if it works manually, run it from rc.local. Don't forget the route, and make sure that the VM environment has correctly setup networking.

girlaldo

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Re: EIB/KNX configuration
« Reply #33 on: January 04, 2017, 05:51:20 pm »
here is what happens

aldo@dcerouter:~$ sudo /usr/bin/eibd --no-tunnel-client-queuing -D -T -R -S -i -u --eibaddr=0.0.1 --daemon=/var/log/eibd.log ipt:192.168.80.137
aldo@dcerouter:~$ ps -ax | grep eib -i
16822 ?        Ss     0:00 /usr/bin/SCREEN -d -m -S KNX_via_eibd36 /usr/pluto/bin/Spawn_Device.sh 36 localhost EIB
16830 pts/25   Ss+    0:00 /bin/bash /usr/pluto/bin/Spawn_Device.sh 36 localhost EIB
30050 pts/4    S+     0:00 grep --color=auto eib -i
aldo@dcerouter:~$ cat /var/log/syslog | grep eibd]
Jan  4 17:37:03 dcerouter kernel: [ 1295.081957] eibd[29901]: segfault at bf1c2ffc ip b770eac3 sp bf1c3000 error 6 in libpthsem.so.20.0.28[b770c000+11000]

I try to reinstall the entire vm again

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3535
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: EIB/KNX configuration
« Reply #34 on: January 04, 2017, 06:04:55 pm »
You did setup the route, didn't you? Are you able to try an install on a real machine?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3535
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: EIB/KNX configuration
« Reply #35 on: January 04, 2017, 06:33:05 pm »
One more thing, try the original version from Austria:
Code: [Select]
deb http://www.auto.tuwien.ac.at/~mkoegler/debian/ eib main

and
Code: [Select]
dcerouter_112602:~# cat /etc/apt/preferences
Package: *
Pin: origin "www.auto.tuwien.ac.at"
Pin-Priority: 1000