Archive > Orbiter - Developers

Orbiter on debian unstable

(1/3) > >>

archived:
Hi,

  Has anyone built the orbiter on debian unstable?  I'm having problems with the final linking.  I'm using an svn checkout from the 10th and I've tried both g++-3.3.6 and g++-4.0.3 with the same results.  Upon linking of the orbiter I get a mess of these errors:

`.L8111' referenced in section `.rodata' of Linux/OSDScreenHandler.o: defined in discarded section `.gnu.linkonce.t._ZN3DCE17ScreenHandlerBase25ReceivedGotoScreenMessageEiPNS_7MessageE' of Linux/OSDScreenHandler.o


other than that the compile is uneventfull.  Even less so with g++4 as it gave out even fewer warning messages.  I am just looking to see if anyone has tried this or has an idea of how to start trouble shooting it.  I know pluto is built on debian stable and my pluto core is the only machine I run stable on,  with all others in my house running unstable (no windows here).  I'd like to run an orbiter on my laptop.  I've tried the web orbiter and it works ok, but the refresh rate of the site get anoying after a while.

Thanks for any help,
Jason

archived:
I've compiled the Orbiter on Etch a week or two ago, but I don't remember what the result on linking was. I'll update my system to current Etch and let you know on the outcome. As for Sid, I don't know any one that could help me test building the Orbiter there, so I can't give you any insights. Sorry.

archived:
It seems to be a linker error, something like "undefined reference". You might want to recompile libDCECommon (do a make in src/DCE) and libPlutoUtils( do a make in src/PlutoUtils). When try to link Orbiter again.

Best regards,
Chris M.

archived:
I've since updated my system to the latest versions of everything and installed g++-3.4.  I've also updated my pluto source from svn and am still getting the same errors.  Each time I try something different, I do a make clean on all the dependent libraries and rebuild.  As a side not, Is it common for the code in svn to not compile due to missing/unfinished functions? (I'm ok with this as that's my coding style :)  I'm just curious)  I'll keep looking to get an idea of what kind of things cause these linking errors and post as I try things.  If you guys come up with any ideas or solutions please pass them along.  Once I get a stand alone orbiter working on sid, I'll try to get it working on openzaurus/opie.

Jason

archived:
jspeckman,
I am most interested in your progress on getting Orbiter running on a zaurus. I am not currently running OZ/opie but I would be more than happy to help test etc. if you can get it compiled. I have been unsuccessful in compiling using the default sharp rom/pocketworkstation on a zaurus C3100. I've tried a cross-compile environment using DSL as well as trying to compile directly on the z in pocketworkstation. (my post is just below this one: newbielink:http://plutohome.com/support/phpbb2/viewtopic.php?t=788 [nonactive])

Let me know if I could help in any way.

DoTheDog

Navigation

[0] Message Index

[#] Next page

Sitemap 
Go to full version