Author Topic: No sound when using a usb sound system  (Read 1063 times)

tkwfo

  • Newbie
  • *
  • Posts: 6
    • View Profile
No sound when using a usb sound system
« on: April 14, 2009, 01:50:23 pm »
Hi List,

I have an issue with a USB sound system that i try to use with LMCE. It works very vell in the Kubuntu desktop with Amarok and the xcine player but in the orbiter there is no sound. In the desktop players I have selected ALSA as the sound system so I am sure that it works.

When I first installed the system i used the internal analog onboard sound, but it was very noisy, so i decided to try the USB solution. I have disabled the onboard sound in the bios, but that did not solve the problem.

When I run the wizard at startup do not hear any sound.

Tim

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: No sound when using a usb sound system
« Reply #1 on: April 14, 2009, 04:34:46 pm »
look in /etc/pluto/xine.conf as well as /etc/alsa.conf and look at the asym_analog device. There may be a problem here with the devices chosen to deal with your sound card.

I am thinking on how to best add support USB sound card devices, especially when combined with USB conference microphones, it's not as simple as supporting things on the desktop, we have to guarantee working configurations underneath and guarantee that sound devices always go to the right place, so things are more rigid.

-Thom

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: No sound when using a usb sound system
« Reply #2 on: April 14, 2009, 04:45:46 pm »
I got my USB soundcard working the way Thom described it to you, there is also a change that you will need to make in webadmin. I have to go through this process all over again since my core crashed and I will make a wiki this time.
-Krys

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: No sound when using a usb sound system
« Reply #3 on: April 14, 2009, 04:52:51 pm »
What we really need is some work in sound card configuration, in the web admin and various scripts, and the xine player etc, to properly support USB sound cards.

Basically, we can create a new device category called USB Sound Cards, and use FindRelatedDevice in libDCE to look for one, if present, set things to use it.

The issue will be to make sure that USB microphones are not detected as sound cards, and as such, those _LITERALLY_ have to be handled on a case by case basis, or to make a Generic USB Microphone that can be selected when the PNP screen appears.

-Thom

tkwfo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: No sound when using a usb sound system
« Reply #4 on: April 15, 2009, 01:10:16 am »
Thanks for your suggestions but i am not sure how to change the asound.conf

At the moment the asym part is
pcm.asym_analog {
   type asym
   playback.pcm "plughw:0"
   capture.pcm "plughw:0"
}
pcm.!default asym_analog

When i do a  cat /proc/asound/cards i get
0 [CMI8738        ]: CMI8738-MC6 - C-Media CMI8738
                      C-Media CMI8738 (model 55) at 0xc800, irq 18
1 [default        ]: USB-Audio - Microsoft Digital Sound System
                      Microsoft Microsoft Digital Sound System  at usb-0000:00:1d.0-2, full speed
2 [Bt878          ]: Bt87x - Brooktree Bt878
                      Brooktree Bt878 at 0xe0001000, irq 21
3 [Bt878_1        ]: Bt87x - Brooktree Bt878

I have tried to change to

pcm.asym_analog {
   type asym
   playback.pcm "plughw:1"
   capture.pcm "plughw:1"
}

and restarted the orbiter but that did not help.

Any suggestions?

Tim

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: No sound when using a usb sound system
« Reply #5 on: April 15, 2009, 08:11:12 pm »
try playing the test sound from the KDE desktop. I think its system setting> sound system or something like that.

tkwfo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: No sound when using a usb sound system
« Reply #6 on: April 16, 2009, 11:09:20 pm »
Hi again

After some reading about alsa i have come a little futher

in the asound.conf i have modified asym_analog to

pcm.asym_analog {
      type hw
      card 1
      device 0
}

in "system settings/sound system" i have selected alsa on the hardware tab. (and applied changes)
after that i have tried the test button on the "general" tab and the sound is now coming from my usb speakers ;D

But still now usb sound in the orbiter, only the noisy sound from the onboard sound card  >:(

I have tried with the default settings in xine.conf

then i have tried
audio.device.alsa_front_device:default
audio.alsa_front_device:default

and

audio.device.alsa_front_device:plughw 1
audio.alsa_front_device:plughw 1

and all i get is the onboard sound card

I am a little lost.

Tim

tkwfo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: No sound when using a usb sound system [solved]
« Reply #7 on: April 18, 2009, 02:05:22 am »
Hi list,

I finally managed to make my usb sound system work with LMCE. I discovered a Wiki article http://wiki.linuxmce.org/index.php/Changing_Xine_Player_Audio_Settings where it describes the settings for XINE.

It turns out that a setting in WebAdmin should be changed.
In "advanced/configuration/devices" you should select "the core/hybrid" and change "Audio Settings" to M. This means that LinuxMCE does not change the xine.conf file.

The current behaviour in LMCE is that when Stereo is selected as audio output then LMCE modifies the xine.conf parameter
audio.alsa_front_device' with the value plughw:0.

I would suggest that this should be changed so the Stereo selection does not change the xine.conf in that way the audio is played thru the default sound card in asound.conf.

Thanks for your help

Tim




tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: No sound when using a usb sound system
« Reply #8 on: April 18, 2009, 03:08:29 am »
Unfortunately, your case is an edge case.

We will have to add a new sound card type, and add logic in Xine_Player and the other DCE players to compensate for this.

-Thom

tkwfo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: No sound when using a usb sound system
« Reply #9 on: April 19, 2009, 01:02:07 am »
Why is this an edge case?

According to the information in http://wiki.linuxmce.org/index.php/Changing_Xine_Player_Audio_Settings the values for S/PDIF are linked to a the "asym_spdif" section in asound.inf but Stereo is hard coded to the value plughw:0.

If Stereo is linked to asym_analog and it is defined as follow

pcm.asym_analog {
   type asym
   playback.pcm "plughw:0"
   capture.pcm "plughw:0"
}

The result is the same.

You mention in an earlier post that the selection of sound card should be changed. I would like to suggest that a list of devices are shown to select from. If you make it possible to play a test sound for each device the user will quickly be able to select the right device. 

Tim