Author Topic: Choppy Video on 9400GT  (Read 1108 times)

pixelpipeline

  • Newbie
  • *
  • Posts: 7
    • View Profile
Choppy Video on 9400GT
« on: April 14, 2009, 07:32:10 am »
All,

after my old 8200 (256 MB) which without issues died the death of heat (bad housing fan) I upgraded to a 9400GT with 1 GB.

After the install the screensaver images move and fade really choppy (looks like a streaming over a very low bandwidth).

I reinstalled the system and updated the driver ... no change ...  :(

I'm quite new to linux ... so please bare with me if this is a simple thing and i just didn't get it or I missed crucial information.

THANKS !

-pp- 
Life in order of importance:

- food
- shelter
- a pair of very loud speakers

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Choppy Video on 9400GT
« Reply #1 on: April 14, 2009, 07:56:04 am »
Well if you installed the latest nVidia drivers, following the wiki article - Display Drivers, then you should have the right driver... it still sounds as though it isn't using it though (the OpenGL acceleration), check that the driver is selected in the Device section of /etc/X11/xorg.conf

Device    "nvidia"

Not "nv" or "vesa". Also make sure there is only one Device section, and that section's PCI Bus ID is the same as that listed when you run lspci for that new chipset.

Failing that, post your xorg.conf and /var/log/pluto/Xorg.0.log files here... but make sure you quote them using the # icon when editing your post so that it doesn't flood the thread.

pixelpipeline

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy Video on 9400GT
« Reply #2 on: April 16, 2009, 04:41:00 am »
Hello Colinjones,

Thanks for the fast reply.


I changed the xorg.cnf setting ... now MCE des not start up at all anymore ... it stops at

"dcerouter login:"

and (strangely) the screen flashes to just a cursor in the top left corner ...

Is there any way to fix that besides a new install ?

-pp-
Life in order of importance:

- food
- shelter
- a pair of very loud speakers

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Choppy Video on 9400GT
« Reply #3 on: April 16, 2009, 04:58:45 am »
pixelpipeline

This just means that X is trying to start up (which is why it flashes, it is trying again and again), but for some reason it isn't able to.

It will tell you why in the /var/log/Xorg.0.log file...

BUT.... you didn't actually say what setting you changed....

pixelpipeline

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy Video on 9400GT
« Reply #4 on: April 16, 2009, 06:20:29 am »
Hello Colinjones,


I changed the device from "nv" to "nvidia" ... sorry that I forgot that ...

at the end of the logfile it says:

(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have usable configuration.

Fatal server error:
no screens found



... hopefully you can decipher that  ....


THANKS !!!

-pp-

Life in order of importance:

- food
- shelter
- a pair of very loud speakers

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Choppy Video on 9400GT
« Reply #5 on: April 16, 2009, 06:31:48 am »
The change you made told it to load the proprietary/restricted nVidia driver instead of the open source driver. Which is correct. The error just indicates that it cannot load that driver. You should note that it will default to nvidia on install, so it is likely it changed to nv at some point because it cannot load the proprietary driver.

Are you SURE that you followed the instructions at http://wiki.linuxmce.org/index.php/Display_Drivers#NVidia_Chipsets exactly, and substituted in the latest version in the URL??? Did it go through the wizard and tell you it couldn't find the kernel interfaces so was compiling a new one? Did it say it had successfully installed the drivers? And at the end, when it asks you if you want it to auto configure X, did you say no? (because that can screw up the config file for LMCE)

The driver must successfully install. And the xorg.conf file must be configured appropriately. If you are not sure the file is right, then you should trigger the AV Wizard again (reboot, then hold down shift whilst the Kubuntu progress bar goes across), select your settings again and exit. This will refresh the xorg.conf with a basic LMCE one. Which you can then tweak, but you should find it is already set to "nvidia" if the drivers installed correctly.

pixelpipeline

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy Video on 9400GT
« Reply #6 on: April 16, 2009, 06:49:43 am »
O.k. ...

I guess I f@#$% up the xorg.conf ...

I did NOT say NO when the installer wanted to auto configure X ... I guess a classical case of RTFM ...

When I now hold the shift key during the startup the AVWizard comes up but tells me "Failed to setup X" (with a red "ok") ...

Is there any way to manually fix the configuration or should I just get ready to do a new install ?
Life in order of importance:

- food
- shelter
- a pair of very loud speakers

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Choppy Video on 9400GT
« Reply #7 on: April 16, 2009, 06:54:40 am »
You are SOO keen to reinstall aren't you? :)

You will find a copy of a vanilla xorg file in the same directory called xorg.conf.pluto.avwizardr, you can use that to regenerate it by deleting the current one, and copying that one in its place.

pixelpipeline

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy Video on 9400GT
« Reply #8 on: April 16, 2009, 07:12:14 am »
First of all I want to say that I really appreciate the yelp and support you are giving here !

I hope one day I will be able to give something back to the community here !

I'm not really keen on a reinstall - but for a linux newbe like me that seems the (only) solution for so many problems ... it took me 13 installs to finally get my SUSE on my home PC to run ... now int runs fine (I still don't know exactly why - but it works ...)

I'm kind of proud that i found the file ... but how do I replace on with the other  ??? (Sorry if this is a really stupid question ...  :-[ )


-pp-

Life in order of importance:

- food
- shelter
- a pair of very loud speakers

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Choppy Video on 9400GT
« Reply #9 on: April 16, 2009, 09:12:57 am »
First of all I want to say that I really appreciate the yelp and support you are giving here !

I hope one day I will be able to give something back to the community here !

I'm not really keen on a reinstall - but for a linux newbe like me that seems the (only) solution for so many problems ... it took me 13 installs to finally get my SUSE on my home PC to run ... now int runs fine (I still don't know exactly why - but it works ...)

I'm kind of proud that i found the file ... but how do I replace on with the other  ??? (Sorry if this is a really stupid question ...  :-[ )


-pp-



OK, assuming you are at a terminal prompt....

cd /etc/X11   (will get you into the folder)

sudo mv xorg.conf xorg.conf.old  (will raise your permissions to superuser after typing the password "linuxmce", then move/rename the existing file)

sudo cp xorg.conf.pluto.avwizardr xorg.conf  (will raise your permissions again, but you will not have to type the password again. Then makes a copy of the template config and gives it the same name as the "live" one)

Now reboot, and hold the shift key down again.

pixelpipeline

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy Video on 9400GT
« Reply #10 on: April 17, 2009, 05:43:59 am »
 :)

THANK YOU VERY MUCH !!!!

It worked perfectly ...
Life in order of importance:

- food
- shelter
- a pair of very loud speakers