Author Topic: configure linksys router toa switch  (Read 7515 times)

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: configure linksys router toa switch
« Reply #15 on: August 02, 2010, 09:42:42 am »

Techstyle, thanks for the quick response.
To answer your questions:

Quote
1.  Can anything connected to the WRT54G access the internet or Web admin?
2.  Can the core access the internet?
3.  If you connect a PC on the internal network to Eth1 directly, can you access the internet now?

1. I connected PC1 directly to the WRT54G. PC1 cannot access the internet. It also cannot connect to the Web admin
2. The core can access the internet
3. I connected PC1 directly to the external interface. It cannot access the internet

So I'm guessing that the problem is with eth1.

I setup eth1 according to the instructions in:
http://wiki.linuxmce.org/index.php/Single_to_Double_NIC
and in:
http://linuxmce.wordpress.com/2007/10/03/hack-5-howto-modify-network-configuration/

When I do ifconfig on the core, I'm getting the following:

Code: [Select]
avner@dcerouter:~$ sudo ifconfig
[sudo] password for avner:
eth0 Link encap:Ethernet HWaddr 00:13:d4:29:17:e7
inet addr:10.0.1.12 Bcast:10.0.1.255 Mask:255.255.255.0
inet6 addr: fe80::213:d4ff:fe29:17e7/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:88890 errors:0 dropped:0 overruns:0 frame:0
TX packets:98965 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:102072129 (102.0 MB) TX bytes:10176103 (10.1 MB)
Interrupt:17

eth1 Link encap:Ethernet HWaddr 00:80:c6:ee:11:73
inet addr:192.168.80.1 Bcast:192.168.80.255 Mask:255.255.255.0
inet6 addr: fe80::280:c6ff:feee:1173/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:46 errors:0 dropped:0 overruns:0 frame:0
TX packets:29689 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:17070 (17.0 KB) TX bytes:1257465 (1.2 MB)
Interrupt:21 Base address:0xb800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:47088 errors:0 dropped:0 overruns:0 frame:0
TX packets:47088 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11076519 (11.0 MB) TX bytes:11076519 (11.0 MB)

Avner
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: configure linksys router toa switch
« Reply #16 on: August 02, 2010, 05:48:36 pm »
To need to do the Single to double NIC thing you must have installed as a single NIC then added a second?

If that is the case I would re-install with two NIC's in. 

Maybe somebody else could confirm that the single to double NIC wiki page is still valid in 0810?

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: configure linksys router toa switch
« Reply #17 on: August 05, 2010, 03:09:24 am »
Ok, I reinstalled linuxMCE with 2 cards and I still get the same problem.
I configure the WRT54G by connecting it to the external router (Time capsule / Air  port)

After I change the IP address of WRT54G to 192.168.80.130 (step 3) I can not access the WRT54G anymore.
When the WRT54G is still connected to the external router, I can connect to it from PC1 at 198.168.80.130, but only if I wire the WRT54G to PC1
(In wireless connection, I can connect to the WRT54G network but cannot access the router)

However, when I connect the WRT54G to eth1 on PC2 (the Core) I cannot access or ping the WRT54G.

I tried restarting eth1:
Code: [Select]
sudo ifdown eth1
sudo ifup eth1

eth1 shows up in ifconfig:
Code: [Select]
...
eth1 Link encap:Ethernet HWaddr 00:80:c6:ee:11:73
inet addr:192.168.80.1 Bcast:192.168.80.255 Mask:255.255.255.0
inet6 addr: fe80::280:c6ff:feee:1173/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3850 errors:0 dropped:0 overruns:0 frame:0
TX packets:9232 errors:115957 dropped:0 overruns:0 carrier:115957
collisions:0 txqueuelen:1000
RX bytes:245158 (245.1 KB) TX bytes:414561 (414.5 KB)
Interrupt:21 Base address:0xb800
...

Code: [Select]
ping 198.168.80.130hangs

Code: [Select]
ip neigh showresults in:
Code: [Select]
...
192.168.80.130 dev eth1 FAILED
...

Any help would be greatly appreciated
Avner
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: configure linksys router toa switch
« Reply #18 on: August 05, 2010, 03:51:06 am »
Update:

When I take out the WRT54G and wire PC1 directly to eth1, I can access the WebAdmin page and also ping 192.168.80.1 from PC1
From the core side I can see PC1 and ping it (at 192.168.80.140)
So the problem is with the connection to the WRT54G. I tested the WRT54G and it is fully functional outside linuxMCE system.

Another observation is that eth1 returns with no data avilable (in both cases, when the WRT54G and when PC1 is connected to eth1)
Code: [Select]
ethtool eth1
Setting for eth1:
No data avialable

ethtool -i eth1
driver: tulip
version 1.1.15
firmware-version:
bus-info: 0000:01:0a:0
Avner
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850

Avner

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: configure linksys router toa switch
« Reply #19 on: August 05, 2010, 04:19:56 am »
Finally, I was able to make the WRT54G connected to eth1 in the Core  :)
I over sited the instruction in step 5 to connect the WRT54G to the core through the LAN port not the WAN port.
After connecting the WRT54G to one of the 4 LAN ports, I can now access the WRT54G management web page (at 192.168.80.130) and ping it.
I can also ping PC1 that is connected to another LAN port on the WRT54G

Thanks Techstyle for helping me with this problem

P.S.
Now my PC1 (Windows machine) cannot connect to the Internet when it is connected both to the external network via wireless and to
the internal network (via wired connection to the WRT54G, which is wired to eth1 in the Core)  ???

ipconfig shows:
Code: [Select]
C:\Windows\system32>ipconfig

Windows IP Configuration


Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : Moshkovitz
   Link-local IPv6 Address . . . . . : fe80::c48:de15:4b6:a34c%11
   IPv4 Address. . . . . . . . . . . : 10.0.1.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.0.1.1

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::bd61:d2fb:230e:4c1e%10
   IPv4 Address. . . . . . . . . . . : 192.168.80.140
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.80.131
                                       192.168.80.1

If I disconnect the wire connection, it can access the Internet fine.
Asus P5GD2-X, Intel i915P/G, Pentium 4 3.2 GHz, 2.5GB, nvidia Geforce 8800, Hauppauge WinTV-HVR-1850