Archive > Orbiter - Developers

Orbiter on Zaurus?

(1/4) > >>

archived:
Hi all,
First time posting. Just a little background. I am going to be building a house in the next couple of months and was looking to PlutoHome as a great home automation option. One question I do have is, can the Orbiter be run on a Zaurus. I have a Zaurus C3100 and am going to be in Japan again this month and I was thinking that if I can get it to compile for ARM, I would get a couple of Zaurus C1000's to use as Orbiters in the new house. Here is the Issue.

I have tried cross-compiling (using Damn Small Linux and the gcc-2.95 tool chain) as well as tried compiling it in Debian PocketWorkstation on the zaurus itself and seem to be running into problems. I am sure they are dependency related but I can't figure it out and was hoping that I could get some help.

Here is what I have tried:

Tried to compile SerializeClass on DSL using the command: make host=arm-linux
This is what I got:

--- Code: newbielink:javascript:void(0); [nonactive] ---bash-2.05b# make host=arm-linux
g++ -c -I./ -I../../ -I../ -I../DCE/ -I../../DCE -I../VIPShared/ -I../../VIPShared -I/usr/include/mysql -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_DEVEL_DEFINES -DUSE_LZO_DATAGRID -Wall -g -ggdb3 -D_GNU_SOURCE SerializeClass.cpp -o SerializeClass.o
In file included from ../SerializeClass/ShapesColors.h:5,
                 from SerializeClass.cpp:30:
../SerializeClass/SerializeClass.h: In method `void SerializeClass::Read_string(string &)':
../SerializeClass/SerializeClass.h:591: no matching function for call to `basic_string<char,string_char_traits<char>,__default_alloc_template<true,0> >::clear ()'
SerializeClass.cpp: In method `bool SerializeClass::SerializeRead(basic_string<char,string_char_traits<char>,__default_alloc_template<true,0> >, void * = 0)':
SerializeClass.cpp:405: warning: `void *' is not a pointer-to-object type
make: *** [SerializeClass.o] Error 1

--- End code ---


I tried this one first because it seemed to have the fewest dependencies. I also tried PlutoUtils but ended up with this:


--- Code: newbielink:javascript:void(0); [nonactive] ---Computing dependencies for ProcessUtils.cpp done
Computing dependencies for Other.cpp done
Computing dependencies for MultiThreadIncludes.cpp done
Computing dependencies for FileUtils.cppFileUtils.cpp:39: warning: No include path in which to find http_fetcher.h
 done
Computing dependencies for CommonIncludes.cpp done
g++ -c -I./ -I../../ -I../ -I../DCE/ -I../../DCE -I../VIPShared/ -I../../VIPShared -I/usr/include/mysql -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSE_LZO_DATAGRID -D_DEVEL_DEFINES -Wall -g -ggdb3 -D_GNU_SOURCE CommonIncludes.cpp -o CommonIncludes.o
CommonIncludes.cpp: In function `bool AskYNQuestion(basic_string<char,string_char_traits<char>,__default_alloc_template<true,0> >, bool, int = 0)':
CommonIncludes.cpp:49: warning: comparison is always true due to limited range of data type
g++ -c -I./ -I../../ -I../ -I../DCE/ -I../../DCE -I../VIPShared/ -I../../VIPShared -I/usr/include/mysql -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSE_LZO_DATAGRID -D_DEVEL_DEFINES -Wall -g -ggdb3 -D_GNU_SOURCE FileUtils.cpp -o FileUtils.o
FileUtils.cpp:39: http_fetcher.h: No such file or directory
make: *** [FileUtils.o] Error 1


--- End code ---


I have installed libhttpfetcher-dev and there is a http_fetcher.h file in /usr/includes/ so I am not sure what the problem is.

Any and all help on this is appreciated. I would love to be able to pick up a couple of zaurii when I am in Japan to use as Orbiters ;)

archived:
I just re-read the post and there is some more information that I should include. The Zaurus runs on the 2.4.20 Embedix kernel using gcc-2.95. I realize it is a little old but that is what it runs on.

Also, is there a specific order I need to compile this stuff in? I have everything required for PlutoUtils (I think) except for cdrecorder. I guess I can always apt-get that and try again.

Let me know if there is any other information I can give you to help me figure this out.

Thanks,
Rob

archived:
Hi Rob,

You will need to compile SerializeClass, PlutoUtils and DCE first and then Orbiter. Indeed, gcc-2.95 is a little to old, we are using 3.3.5 right now.

Anyway, instead of that "str.clear();" you can try doing a str = "";
We will try to compile orbiter for Zaurus too, but I don't think this will be too soon.

For that http_fetcher.h, you can comment out the functions which uses it. Orbiter doesn't really need them.

Best regards,
Chris M.

archived:
Chris.m
Thanks for the help on that. I got SerializeClass (the str ="" worked) and DCE compiled (I had to download pluto_main from svn). Now I just need some help with PlutoUtils. I got past the http_fetcher problem but now I have a problem with locale in StringUtils.cpp. I'll post the stack trace here. It is complaining that it cannot find the path to locale. It is in /usr/bin which is in the PATH variable. I tried adding -I/usr/bin to the MakeFile but then it complained about an "unterminated character constant". When I type locale in a terminal window they all say en_US.  Help?

Rob

Here is the error for PlutoUtils make

--- Code: newbielink:javascript:void(0); [nonactive] ---
g++ -c -I./ -I../../ -I../ -I../DCE/ -I../../DCE -I../VIPShared/ -I../../VIPShared -I/usr/include/mysql -I/usr/bin -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DUSE_LZO_DATAGRID -D_DEVEL_DEFINES -Wall -g -ggdb3 -D_GNU_SOURCE StringUtils.cpp -o StringUtils.o
In file included from StringUtils.cpp:37:
/usr/bin/locale:2: unterminated character constant
/usr/bin/locale:107: unterminated character constant
/usr/bin/locale:149: unterminated character constant
/usr/bin/locale:150: unterminated string or character constant
/usr/bin/locale:4: possible real start of unterminated constant
make: *** [StringUtils.o] Error 1

--- End code ---


Here is the result of locale+


--- Code: newbielink:javascript:void(0); [nonactive] ---root@zaurus:~/PlutoHome/PlutoUtils# locale
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE="en_US"
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=en_US


--- End code ---

archived:
Hi Rob,

I guess you can comment that include too (#include <locale>) and eventually comment any function that might use it or provide a dummy implementation or those functions.

Chris M.

Navigation

[0] Message Index

[#] Next page

Sitemap 
Go to full version