Author Topic: 0810 alpha 2 no /usr/pluto/diskless  (Read 8330 times)

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #15 on: April 16, 2009, 09:30:35 pm »
I deleted and rebooted the MD, it PXE boots to the point where it tries to run the Diskless_Setup.sh then it fails as expected.

Here's what the output from the webinterface shows after I've rebuilt the image:

Code: [Select]
sudo -u root /usr/pluto/bin/Diskless_Setup.sh

7381 Thu Apr 16 20:25:20 BST 2009 TryLock 'Diskless_Setup' (Diskless_Setup)
7381 Thu Apr 16 20:25:20 BST 2009 Lock 'Diskless_Setup' (Diskless_Setup)
7381 Thu Apr 16 20:25:20 BST 2009 Lock 'Diskless_Setup' (Diskless_Setup) success
7381 Thu Apr 16 20:25:20 BST 2009 TryLock 'Diskless_Setup' (Diskless_Setup) success
Getting list of Media Directors
7381 Thu Apr 16 20:25:25 BST 2009 Unlock 'Diskless_Setup' (Diskless_Setup)
7381 Thu Apr 16 20:25:25 BST 2009 Unlock 'Diskless_Setup' (Diskless_Setup) success


sudo -u root /usr/pluto/bin/DHCP_config.sh

8003 Thu Apr 16 20:25:26 BST 2009 WaitLock 'PlutoDHCP' (PlutoDHCP_config)
8003 Thu Apr 16 20:25:29 BST 2009 WaitLock 'PlutoDHCP' (PlutoDHCP_config) success
 * Stopping DHCP server dhcpd3
   ...done.
 * Starting DHCP server dhcpd3
   ...done.
8003 Thu Apr 16 20:25:33 BST 2009 Unlock 'PlutoDHCP' (PlutoDHCP_config)
8003 Thu Apr 16 20:25:33 BST 2009 Unlock 'PlutoDHCP' (PlutoDHCP_config) success


sudo -u root /usr/pluto/bin/Diskless_ExportsNFS.sh

 * Re-exporting directories for NFS kernel daemon...
   ...done.

It executed this incredibly quickly and does not provide any dir-structure under /usr/pluto/diskless

I'm also struggling to find anything in the logs of relevance.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1005
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #16 on: April 16, 2009, 09:39:34 pm »
Hi,

Just to verify...

This is after you added the architecture type as i386 in wedadmin and rebuilt via the webadmin rebuild button that's associated with the MD?

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #17 on: April 16, 2009, 09:47:06 pm »
pigdog,

That's correct and I've tried it with a different MD device as well (never been seen by this system before) and get the same result.

Something I have noticed is that /usr/pluto/bin/Diskless_Setup.sh calls /usr/pluto/bin/Diskless_CreateFS.sh which relies on being able to unpack /usr/pluto/install/PlutoMD-$Moon_Architecture.tar.bz2 however the only file in /usr/pluto/install that is similar to this is PlutoMD_Debootstraped.tar.bz2.

Could this be the issue?  If it is, where can I get the i386 tar.bz2 file?

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #18 on: April 16, 2009, 09:52:20 pm »
OK, I gave it a go and hard-coded the deboostrapped.tar.bz2 into the Diskless_CreateFS.sh and then re-ran the "rebuild image".

I get a much more productive output from the web interface, I'll post the results of the next PXE attempt.

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #19 on: April 16, 2009, 09:55:12 pm »
OK, PXE was more promising, no announce to router by vmlinuz did not exist.

Have deleted both MDs and will retry creation.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1005
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #20 on: April 16, 2009, 09:57:17 pm »
Hi,

Did you have PlutoMD-i386.tar.bz2 in the directory?

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #21 on: April 16, 2009, 10:01:49 pm »
pigdog,

nope, it doesn't exist.

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #22 on: April 16, 2009, 10:06:09 pm »
Diskless setup now runs for a new MD, however it does not create the vmlinux image under /tftpboot/

Further investigation reveals that the kernel has not been installed into the /usr/pluto/diskless/#MD/boot dir.

Chrooting to this dir and trying to install a kernel shows that aptitude is not installed, apt-get is and it looks lik I need to install the kernel and kernel headers.

I'm guessing this is also done by the Diskless_CreateFS.sh script and whilst I've been looking through that script I've noticed that Diskless_CreateTBZ.sh has been commented out.

I'm going to look at this further and see if I can fix it.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1005
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #23 on: April 16, 2009, 10:10:32 pm »
Here's what in my directory.

dcerouter_111337:/usr/pluto/install# ls
alsa.configured     compile.sh                     Download_Direct.sh        Initial_Config.sh              PlutoMD-i386.tar.bz2
AptSources.sh       config_update.sh               Download_SVN.sh           Initial_DHCP_Config.sh         PlutoMD-i386.tar.bz2.version
BonusCdAutoInst.sh  config_update.sh.19606         Initial_Config_Core.sh    Initial_Network_Config.sh      post-debootstrap.sh
BonusCdMenu.sh      ConfirmDependencies_Debian.sh  Initial_Config_Finish.sh  pkgsel                         preseed.cfg
Common.sh           Download_CVS.sh                Initial_Config_MD.sh      PlutoMD_Debootstraped.tar.bz2  PreseedStage2.sh

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #24 on: April 16, 2009, 10:13:27 pm »
I've uncommented the lines in Diskless_CreateFS.sh and executed it for MD #64 (the newest addition to my system) it is now setting up a complete linux system including downloading packages via APT so I think I may be on to a winner.  

I'll keep you all updated.

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #25 on: April 16, 2009, 10:45:54 pm »
That script failed:

Code: [Select]
#### Installing pluto-xine-player
Reading package lists... Done
Building dependency tree       
Reading state information... Done
pluto-xine-player is already the newest version.
pluto-xine-player set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
#### Package pluto-xine-player installed ok!
#### Installing pluto-mythtv-player
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  pluto-mythtv-player: PreDepends: libft-perl but it is not going to be installed
E: Broken packages
#### Package pluto-mythtv-player failed (/tmp/tmp.jtxpw15057)

but it does look promising...

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #26 on: April 16, 2009, 11:13:38 pm »
FAIL on the attempt to fix this by hand, have updated /etc/apt/sources.list as documented in the wiki and am re-running the CreateTBZ.sh script.

May well go to bed before it completes so will post an update tomorrow.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1005
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #27 on: April 17, 2009, 01:25:40 am »
Hi,

Myth failing...

sudo apt-get install pluto-mythtv-player

see if that passes... unless you've done that.

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #28 on: April 17, 2009, 08:42:13 am »
The sources.list change allowed the CreateTBZ.sh script to run without issue and I now have the i386.tar.bz2 file in the correct area.

I've just started a new MD PXE booting and so far the "Diskless_Setup.sh" has not failed (been going for a while now!)

If this works, I'll document what I've done and see if I can get it posted to the WIKI and fixed for the next version.

PF.

ProfFalken

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
Re: 0810 alpha 2 no /usr/pluto/diskless
« Reply #29 on: April 17, 2009, 08:45:48 am »
Pleased to confirm that the diskless file-system has now been created and I'm awaiting the MD to reboot.