Author Topic: /tftpboot/pxeboot.cfg/01-<md-mac-address> corrupted  (Read 837 times)

alx9r

  • Guru
  • ****
  • Posts: 187
    • View Profile
/tftpboot/pxeboot.cfg/01-<md-mac-address> corrupted
« on: April 08, 2009, 03:36:32 am »
This ground has been plowed in other threads but it's difficult to find from the symptoms so I'm re-iterating it here in the hopes that it will help someone.

Symptom:
A media director that was successfully pxebooting now fails to boot at this line:
Code: [Select]
Trying to Load PXELinux.cfg/01-<md-mac-address>

Cause (in my case at least):
The file /tftpboot/pxeboot.cfg/01-<md-mac-address> was corrupted as follows:

good file:
Code: [Select]
DEFAULT Pluto
LABEL Pluto
KERNEL 94/vmlinuz
APPEND initrd=94/initrd.img ramdisk=10240 rw root=/dev/nfs boot=nfs nfsroot=192.168.80.1:/usr/pluto/diskless/94

bad file:
Code: [Select]
DEFAULT Pluto
LABEL Pluto
LOCALBOOT 0 #ERNEL 94/vmlinuz
APPEND initrd=94/initrd.img ramdisk=10240 rw root=/dev/nfs boot=nfs nfsroot=192.168.80.1:/usr/pluto/diskless/94

Temporary Fix
Just edit the 'LOCALBOOT...' line to read KERNEL <moon#>/vmlinuz.  MD should now pxeboot again.


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: /tftpboot/pxeboot.cfg/01-<md-mac-address> corrupted
« Reply #1 on: April 08, 2009, 04:29:45 am »
alx9r - I have seen this issue with exactly that "corruption" in the file....

FYI - for some strange reason, this is the way that LMCE implements the Boot from HDD option when rebooting an MD. If for some reason you chose in the web admin or the UI, either deliberately or accidentally (easy to do) to boot from HDD, it writes that # character in there that causes the PXE boot to fail and thus drop through to HDD boot... if you have a bootable HDD and it is still in the BIOS boot sequence.

Seems a strange way of doing it, but I think it is important to note that generally, just editing that config file isn't enough as it will regenerate that file with the # character (not sure when this is triggered, but I suspect on every reboot, it certainly appeared to be doing this for me), and the simple way around this is to reboot the MD from the web admin, but first specifically choose Net boot in that web page before hitting reboot. This then removes that # and it will boot normally.

alx9r

  • Guru
  • ****
  • Posts: 187
    • View Profile
Re: /tftpboot/pxeboot.cfg/01-<md-mac-address> corrupted
« Reply #2 on: April 08, 2009, 05:28:25 am »
Thanks for confirming that you saw this too colinjones.

alx9r - I have seen this issue with exactly that "corruption" in the file....
I saw another thread where you mentioned this -- but not until I diagnosed the problem myself. :)

Quote
FYI - for some strange reason, this is the way that LinuxMCE implements the Boot from HDD option when rebooting an MD. If for some reason you chose in the web admin or the UI, either deliberately or accidentally (easy to do) to boot from HDD, it writes that # character in there that causes the PXE boot to fail and thus drop through to HDD boot... if you have a bootable HDD and it is still in the BIOS boot sequence.
I don't see quite the same thing:
   * In webadmin, "Diskless Boot" remains checked for that media director.
   * Once the LOCALBOOT line is fixed, pxeboot works for multiple reboots.

Alex

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: /tftpboot/pxeboot.cfg/01-<md-mac-address> corrupted
« Reply #3 on: April 08, 2009, 06:14:01 am »
Nevertheless, it is related in some way... try choosing the boot from HDD option (I actually did this by accident in the UI by clicking too quickly and hit the boot from disk button, but I guess you can achieve the same thing from the web admin. I'm pretty much certain you will find that # in the config file once you have done that....