Author Topic: How can I compile vdr-plugin-xineliboutput so that it works with 0710 ?  (Read 1311 times)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Hi,

now I have found out how to compile VDR :) and next thing is now the vdr plugin xineliboutput.

I have tried compiling it like described below, but that did not work. It used libxine 1.1.7 instead of 1.1.10.

So how can I compile it using the pluto libxine version 1.1.10 ?


I have now gotten the pluto libxine version 1.1.10 from svn like this :
 svn checkout http://svn.linuxmce.org/svn/branches/LinuxMCE-0710/ubuntu/xine-lib-1.1.10.1

and compiled it with dpkg-buildpackage. Then I get the package:
 libxine-pluto-dev_1.1.10.1-2-pluto4_i386.deb

The sources are placed in /opt/libxine/include/xine/ - how can I get vdr-plugin-xineliboutput to use them when building ?

----------

Here is current state
When staring "TV" I with the version I have got now I get the following error in Spawn_VDR.VDR_XXXX.log

Code: [Select]
# cat Spawn_VDR.VDR_31968.log
[31968] [vdr-fe]    sxfe_display_open: DPMS unavailable
plutovdr 1.0.1  (build with xine-lib 1.1.7, using xine-lib 1.1.10)

Automatic reconnection enabled
Fullscreen mode
VDR Server: xvdr://127.0.0.1:37890

params.c:OpenConfFile() - Unable to open configuration file "/root/.smb/smb.conf.append":
        No such file or directory
added interface ip=192.168.217.135 bcast=192.168.217.255 nmask=255.255.255.0
added interface ip=192.168.80.1 bcast=192.168.80.255 nmask=255.255.255.0
Using netbios name DCEROUTER.
Using workgroup LINUXMCE.
[31968] [vdr-fe]    fe_xine_open: xine_open("xvdr://127.0.0.1:37890#nocache;demux:mpeg_block") failed
Error opening xvdr://127.0.0.1:37890


Press Esc to exit

I can then start plutovdr on the command line like this and then it works :

plutovdr --fullscreen xvdr://127.0.0.1:37890

Normally with the standard version plutovdr it is the other way around. LinuxMCE can start it, but I can't ...


---------

Here is how I compiled it.

# make backups

 mkdir -p /install/VDR/init.d
 mkdir -p /install/VDR/default
 mkdir -p /install/VDR/conf
 cp -v /etc/vdr/*.conf /install/VDR/conf
 cp /etc/init.d/vdr /install/VDR/init.d
 cp /etc/default/vdr /install/VDR/default


Add this to /etc/apt/sources.list (if not already there) :
deb-src http://archive.ubuntu.com/ubuntu/ intrepid main universe restricted multiverse

 apt-get update

 mkdir -p /usr/src/hdtv4
 cd /usr/src/hdtv4
 apt-get source vdr

 cd vdr-1.6.0

now change the name of the package by changing the verion number in paranthesis in first linie of debian/changelog from :

vdr (1.6.0-5ubuntu2) intrepid; urgency=low

to :

vdr (1.6.0-6-LMCE0710-11) intrepid; urgency=low


now compile :
 dpkg-buildpackage

now you have the new packages in the parent directory :)

 cd ..
 dpkg -i vdr_1.6.0-6-LMCE0710-11_i386.deb

restore the saved configuration
(Later we can insert this into the debian package before compiling)

 /etc/init.d/vdr stop

 cp /install/VDR/default/vdr /etc/default/
 ln -s /home/public/data/VDRTV/video.00 /home/public/data/VDRTV/video
 cp -v /install/VDR/conf/*.conf /var/lib/vdr/

 /etc/init.d/vdr start


Compile plugins

 cd /usr/src/hdtv4
 dpkg -i vdr-dev_1.6.0-6-LMCE0710-11_all.deb

Xineliboutput
 apt-get source vdr-plugin-xineliboutput
 cd vdr-plugin-xineliboutput-1.0.1/
 apt-get install cdbs libxv-dev libxext-dev sharutils libdbus-glib-1-dev install libxine-dev

 dpkg-buildpackage

This will probably bring an error message like this :
 dpkg-checkbuilddeps: Unmet build dependencies: libxine-dev (>= 1.1.12)

If that is the only failed dependency, then build with -d to ignore :
 dpkg-buildpackage -d

 cd ..
 dpkg -i libxine1-xvdr_1.0.1-5_i386.deb libxineliboutput-sxfe_1.0.1-5_i386.deb xineliboutput-sxfe_1.0.1-5_i386.deb vdr-plugin-xineliboutput_1.0.1-5_i386.deb
 /etc/init.d/vdr restart

In this package there is no plutovdr - in the linuxmce original package this was renamed - fix :

 ln -s /usr/bin/vdr-sxfe /usr/bin/plutovdr

----
all the packages I got after compiling the pluto libxine source :

libxine1-pluto_1.1.10.1-2-pluto4_i386.deb
libxine1-pluto-all-plugins_1.1.10.1-2-pluto4_all.deb
libxine1-pluto-bin_1.1.10.1-2-pluto4_i386.deb
libxine1-pluto-console_1.1.10.1-2-pluto4_i386.deb
libxine1-pluto-doc_1.1.10.1-2-pluto4_all.deb
libxine1-pluto-ffmpeg_1.1.10.1-2-pluto4_i386.deb
libxine1-pluto-gnome_1.1.10.1-2-pluto4_i386.deb
libxine1-pluto-misc-plugins_1.1.10.1-2-pluto4_i386.deb
libxine1-pluto-plugins_1.1.10.1-2-pluto4_all.deb
libxine1-pluto-x_1.1.10.1-2-pluto4_i386.deb
libxine-pluto-dev_1.1.10.1-2-pluto4_i386.deb

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
HI,

replying myself ;)

I will add my findings to the wiki as soon as I am sure it is done the right way.


I now found a way, but is there maybe a better one ?


This is how I did :

Now we have to build libxine-pluto-dev from the subversion repository
 apt-get install subversion

Get pluto linxine sources
 svn checkout http://svn.linuxmce.org/svn/branches/LinuxMCE-0710/ubuntu/xine-lib-1.1.10.1
 cd xine-lib-1.1.10.1

install missing packages and build libxine-pluto-dev
 apt-get install libavcodec-dev libavformat-dev libpostproc-dev libxcb-xv0-dev libxcb-shm0-dev libxcb-shape0-dev libxinerama-dev libxvmc-dev libxt-dev libasound2-dev libaa1-dev libcaca-dev libmodplug-dev libmagick9-dev  libpng12-dev libogg-dev libvorbis-dev libtheora-dev libesd0-dev libgnomevfs2-dev liblircclient-dev libdirectfb-dev libgtk2.0-dev libflac-dev libpulse-dev libwavpack-dev libsmbclient-dev libspeex-dev libmng-dev libmad0-dev libmpcdec-dev libcdio-dev transfig sgmltools-lite
 dpkg-buildpackage

 cd ..
 dpkg -i libxine-pluto-dev_1.1.10.1-2-pluto4_i386.deb

Now create the links so that it can be used to compile vdr-plugin-xineliboutput
Maybe there is a better way than doing this ??

 ln -s /opt/libxine/bin/xine-config /usr/bin/xine-config
 ln -s /opt/libxine/include/xine.h /usr/include/xine.h
 ln -s /opt/libxine/include/xine /usr/include/xine


And from here like I did before, but without installing linxine-dev

Greetings
Viking

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Hi again,

unfortunately that was not working 100% :(

I have got a picture, but the remote is not working ...

Any ideas ?

Greetings
Viking

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
HI,

Bump.

anyone knowing what to do to compile vdr-plugin-xineliboutput with sources in

/opt/libxine/include/xine

Greetings
Viking