Author Topic: [SOLVED] SPDIF sound everywhere except from orbiter.  (Read 2484 times)

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
[SOLVED] SPDIF sound everywhere except from orbiter.
« on: April 03, 2009, 02:12:00 pm »
[SOLVED]
hen I went through the A/V Wizard, I select SPDIF Coax and Y for both Dolby Digital and DTS. The fix was to then go into the admin site, change the sound card to "Audigy", Uncheck the "Use AC3/DTS pass-through" and reboot the media director. Everything sounds good now and since figuring out how to get scrolling to work with my Wiimote and sensor bar, I can retire my aging Xbox based Xbox Media Center! Thanks!

Don't bother reading anything past this...

Yes, I have searched, read and tried several things to resolve this.

I have a netbooting md, with an Audigy card, connected to a Dolby Digital and DTS capable Sony receiver via S/PDIF Coaxial. When I run the AVWizard, I get sound for DD, but not for DTS. I've read that DTS is not possible on Linux with Audigy. When I try to play a movie, there's a crackle, and then no sound. I've started KDE, heard the start up music, unmute Optical Raw in alsamixer, no joy. I tried unmuting the other Optical setting, again with no sound in movies. What are the steps to set up an audigy 1 (not platinum) card for full LinuxMCE functionality?

Thank you!
« Last Edit: May 01, 2009, 04:23:06 pm by piusvelte »

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #1 on: April 04, 2009, 07:20:43 pm »
I can play music, but still no sound on DVDs. I've read about and tried using the stereo setting instead of s/pdif coax in the webadmin, restarting the router, but to no effect. It was noted in that workaround that the pass through should be left checked, though when I change to stereo, the checkbox is unchecked and then disabled, so that I can't leave it checked. Any ideas on getting audio in DVDs? This is the last piece before I can retire my xbox with XBMC. Thank you!

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #2 on: April 08, 2009, 02:29:15 pm »
I've followed a wiki on mythtv, specific to audigy and digital out, and so far it's not been successful:
set the speaker_arrangement to Pass Through in ~/.xine/config
mute Optical raw in alsamixer
unmute Analog/Digital out in alsamixer

KDE has sound fine, and I can play music through the orbiter. It just seems to be DVDs in Xine.

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #3 on: April 09, 2009, 02:07:58 pm »
Update: I get center speaker only, when testing mplayer, and only left and right speakers when I run speaker-test.

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #4 on: April 09, 2009, 06:54:06 pm »
I was in the same boat as you where I could hear the sound in AV wizard but not when watching a movie. I went into ALSA mixer and turned every single option to on and put them all at 100% after that it worked.

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #5 on: April 09, 2009, 07:12:55 pm »
Thank you! I'll try that when I get home!

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #6 on: April 10, 2009, 01:24:15 pm »
OK, I set all levels umuted and full volume in alsamixer and still no audio playing DVDs. Any other thoughts? The wiki lists the audigy as full functioning, so I'm confident that this can work, but it's not easy to get there it seems. Thank you!

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #7 on: April 14, 2009, 02:44:26 pm »
Mplayer plays dvd's fine through all speakers. My alsa settings are optical raw unmuted, analog/digital output unmuted. Xine is still not playing audio...
« Last Edit: April 17, 2009, 03:03:09 pm by piusvelte »

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #8 on: April 15, 2009, 01:06:40 pm »
I'm working with .xine/config now, and still no sound:

tried:
audio.device.alsa_passthrough_device:default
audio.device.alsa_passthrough_device:hw:Audigy,0
audio.device.alsa_passthrough_device:hw:0,0
audio.device.alsa_passthrough_device:plughw:0,0

setting the audio driver to alsa or oss.

Do you have to start the MD each time you make a change. I had been for a while, but with these past attempts I've ssh'd in, made a change and tried playing a movie without restarting.

Could someone using an Audigy card and s/pdif please post their full config file?

My mornings now consist of eating breakfast over my keyboard while trying different config settings. It's been over a week and getting a little old. I'd love to start using LMCE. Again, mplayer plays fine, it's just xine that isn't producing sound. Thank you!

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #9 on: April 16, 2009, 01:39:40 pm »
MPlayer and playing music work fine. Maybe it's helpful to post my /etc/asound.conf file. Does anyone see anything here that may be a clue. I've tried setting the passthrough device in ~/.xine/config to default, ALSA:default, ALSA:spdif, and ALSA:asym_spdif. It doesn't seem like changes to ~/.xine/config are having any effect. I even tried renaming to file and playing a dvd and the outcome is the same: video:good, audio:none.
Code: [Select]
pcm_slave.convert48k {
pcm "spdif"
rate 48000
}

pcm.spdif_playback {
type plug
slave convert48k
}

pcm.asym_spdif {
type asym
playback.pcm "spdif_playback"
capture.pcm "plughw:0"
}

pcm.asym_analog {
type asym
playback.pcm "plug:dmix"
capture.pcm "plughw:0"
}
pcm.!default asym_spdif

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #10 on: April 17, 2009, 03:02:23 pm »
What settings should I have in MythTV Frontend setup? I've read that I should have the device set to ALSA:spdif, Pass Through set to Default. I've tried that and also with the device set to ALSA:default. Thank you!

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #11 on: April 19, 2009, 09:15:41 pm »
I've switched to an audigy 2 card and still xine fails to produce sound. I started out with a clean netboot md, as instructed, and got sound in the a/v wizard. I've implemented the .asoundrc file found on a ubuntu forum post for using audigy 2 over digital coax. I've made the mythtv front end changes, device ALSA:spdif, and passthrough default described in using an audigy card with xine in a google book. Still no sound. I've tried optical raw muted and umuted, though unmuted appears to be generally recommended. Could someone using an audigy card please post their audio setting in MythTV Front End, their ~/.xine/config and /etc/asound.conf files? Thank you!

canukguy1974

  • Regular Poster
  • **
  • Posts: 42
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #12 on: April 20, 2009, 05:12:23 am »
 I am having sound issues as well. I get it play in the AV Wizard and when I rebooted its all gone again, I have done a reinstall 3 x today but, I have been keeping the /home directory (700 gigs worth of media) I don't want to transfer back to drive ( I have a backup ) I know that it is my home folder just trying one more time before I do a clean install. Anyways good luck, and good job updating your thread if we all did as good a job we would have great support archives.

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: Audigy 1, Wizard+KDE=Sound; Movies no sound, searched
« Reply #13 on: April 20, 2009, 01:08:36 pm »
Thank you! From the lack of responses, it seems that I'm pioneering, so these are my notes as well as anyone else's. However, I'm concerned that I may have missed some details initially as I only recently started documented my steps. From reading through the ubuntu forums, and others, it seems that the audigy can be made to work with xine over spdif coax, so perhaps this is an issue with LMCE that just manifests itself this way. I've started over with a fresh MD build with Audigy 2. Onboard audio is disabled in the bios. The A/V Wizard and Setup Wizard Video both had sound. Mplayer has sound. As before, only Xine produces no sound. This makes me doubt that anything I've tried had any effect. Does anyone have a recommended order for testing?

In alsamixer, both IEC958 Raw and Analog/Digital Out are unmuted. It seems that generally, IEC958 should be muted, but I'm not making any changes anywhere yet.

In .xine/config, audio.output.speaker_arrangement is commented out (default). It's been recommended to set this to "Pass Through".

This is the asound.conf:
Code: [Select]
pcm_slave.convert48k {
pcm "spdif"
rate 48000
}

pcm.spdif_playback {
type plug
slave convert48k
}

pcm.asym_spdif {
type asym
playback.pcm "spdif_playback"
capture.pcm "plughw:0"
}

pcm.asym_analog {
type asym
playback.pcm "plug:dmix"
capture.pcm "plughw:0"
}
pcm.!default asym_spdif
There are 2 ~/.asoundrc files recommended to use with alsa and audigy. I'll try both, though alsa says that .asoundrc is no longer required.

I haven't looked in MythTV Front end to see what the default settings are, but it's been recommended to use the device "ALSA:spdif" and the Passthrough "default".

piusvelte

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: SPDIF sound everywhere except from orbiter.
« Reply #14 on: April 30, 2009, 02:50:22 pm »
OK, here's what I've found so far:

By default, a netbooted Media Director 7.10, will play audio over Audigy SPDIF in the A/V Wizard, KDE Desktop, and Mplayer.

In the orbiter, there's no sound when playing a movie, but music is fine.

In KDE Desktop, I changed Myth Frontend audio device to ALSA:spdif from ALSA:default. Then I went into Kaffeine and change the audio driver from auto to alsa and the speaker layout to Pass Through. Playing a movie in Kaffeine on the desktop has audio. Upon returning to the orbiter, there's still no audio in movies.

How are movies played in the orbiter, that is different from Kaffeine on the desktop? They both use the Xine engine, from what I can tell. I'm going to set Myth frontend back to ALSA:default and try Kaffeine and then the orbiter again to see if Kaffeine still works. Thanks!