Author Topic: New diskless MD does not install properly. Why?  (Read 1930 times)

Domodude

  • Guest
New diskless MD does not install properly. Why?
« on: March 24, 2009, 08:00:09 pm »
Hi,
I used the wizard to generate a new diskless MD, which results in a media director entry in the web interface. The IP is set to 192.168.80.18.
The PC I am using has two internal NICs, which gives lots of trouble. I can only turn both off at the same time (Very Lame Bios), so I did that and added an external PCI NIC. This NIC has been used before with this core.

Everything looks fine until the infinite loop of
Code: [Select]
...
IP-Config: eth1 complete (from 192.168.80.1)
 address:    192.168.80.248   broadcast: 192.168.80.255   netmask: 255.255.255.0
 gateway:    192.168.80.1     dns0 : 192.168.80.1         dns1: 0.0.0.0
 rootserver: 192/168.80.1     rootpath:
 filename: /tftpboot/pxelinux.0
IP-Config: eth1 complete (from 192.168.80.1)
 address:    192.168.80.248   broadcast: 192.168.80.255   netmask: 255.255.255.0
 gateway:    192.168.80.1     dns0 : 192.168.80.1         dns1: 0.0.0.0
 rootserver: 192/168.80.1     rootpath:
 filename: /tftpboot/pxelinux.0
IP-Config: eth1 complete (from 192.168.80.1)
 address:    192.168.80.248   broadcast: 192.168.80.255   netmask: 255.255.255.0
 gateway:    192.168.80.1     dns0 : 192.168.80.1         dns1: 0.0.0.0
 rootserver: 192/168.80.1     rootpath:
 filename: /tftpboot/pxelinux.0
...

It gets an IP 192.168.80.248 (!!). Probably a remnant of the NIC's previous use, but how do I get rid of that?
I am pretty sure that the core does not recognize it as an MD, because it has prepared IP 192.168.80.18.

Ideas, anyone?

Cheers,
Mark

EDIT: and why is eth1 anyway? The other two are turned off in the BIOS!
« Last Edit: March 24, 2009, 09:16:00 pm by Domodude »

boris

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: New diskless MD does not install properly. Why?
« Reply #1 on: March 24, 2009, 08:25:48 pm »
add MAC address of your new NIC in configuration for your MD in admin web interface. The same place where you set IP address for MD.
« Last Edit: March 25, 2009, 08:16:00 am by boris »

Domodude

  • Guest
Re: New diskless MD does not install properly. Why?
« Reply #2 on: March 24, 2009, 09:04:48 pm »
That worked, as far as changing the IP. It still loops, however  ???

EDIT:

All that was needed was a minor edit in /usr/pluto/diskless/219/etc/network/interfaces. That file contained the default eth0 setting, once I changed it to eth1, the MD continued booting  8)
« Last Edit: March 24, 2009, 09:12:26 pm by Domodude »

Domodude

  • Guest
Re: New diskless MD does not install properly. Why?
« Reply #3 on: March 24, 2009, 09:20:33 pm »
That worked, as far as changing the IP. It still loops, however  ???

EDIT:

All that was needed was a minor edit in /usr/pluto/diskless/219/etc/network/interfaces. That file contained the default eth0 setting, once I changed it to eth1, the MD continued booting  8)

This must be the suckiest BIOS ever. It loads the initrd image, then tells me that there IS an eth0 (with different MAC address)!!
I'll keep battling, but if anyone has a great idea how to get past this step, do tell :)
« Last Edit: March 24, 2009, 09:34:43 pm by Domodude »

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4361
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: New diskless MD does not install properly. Why?
« Reply #4 on: March 24, 2009, 09:32:07 pm »
Hi,
I used the wizard to generate a new diskless MD, which results in a media director entry in the web interface. The IP is set to 192.168.80.18.
The PC I am using has two internal NICs, which gives lots of trouble. I can only turn both off at the same time (Very Lame Bios), so I did that and added an external PCI NIC. This NIC has been used before with this core.

Everything looks fine until the infinite loop of
Code: [Select]
...
IP-Config: eth1 complete (from 192.168.80.1)
 address:    192.168.80.248   broadcast: 192.168.80.255   netmask: 255.255.255.0
 gateway:    192.168.80.1     dns0 : 192.168.80.1         dns1: 0.0.0.0
 rootserver: 192/168.80.1     rootpath:
 filename: /tftpboot/pxelinux.0
IP-Config: eth1 complete (from 192.168.80.1)
 address:    192.168.80.248   broadcast: 192.168.80.255   netmask: 255.255.255.0
 gateway:    192.168.80.1     dns0 : 192.168.80.1         dns1: 0.0.0.0
 rootserver: 192/168.80.1     rootpath:
 filename: /tftpboot/pxelinux.0
IP-Config: eth1 complete (from 192.168.80.1)
 address:    192.168.80.248   broadcast: 192.168.80.255   netmask: 255.255.255.0
 gateway:    192.168.80.1     dns0 : 192.168.80.1         dns1: 0.0.0.0
 rootserver: 192/168.80.1     rootpath:
 filename: /tftpboot/pxelinux.0
...

It gets an IP 192.168.80.248 (!!). Probably a remnant of the NIC's previous use, but how do I get rid of that?
I am pretty sure that the core does not recognize it as an MD, because it has prepared IP 192.168.80.18.

Ideas, anyone?

Cheers,
Mark

EDIT: and why is eth1 anyway? The other two are turned off in the BIOS!

You need to remove the NIC from the 'Unknown Devices' list in Web Admin -> Advanced -> Configuration -> Unknown Devices

Just unlock the IP/MAC Address for the NIC then (also delete any previously added MD's that used this NIC) boot the machine again... this time it should announce itself properly.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

Domodude

  • Guest
Re: New diskless MD does not install properly. Why?
« Reply #5 on: March 24, 2009, 09:57:32 pm »
Hi Andrew.

You need to remove the NIC from the 'Unknown Devices' list in Web Admin -> Advanced -> Configuration -> Unknown Devices
That particular NIC wasn't in there, I think. Nevertheless, I deleted anything that even looked like it is or was an MD...


Just unlock the IP/MAC Address for the NIC then (also delete any previously added MD's that used this NIC) boot the machine again... this time it should announce itself properly.
I don't understand what you mean by that. Did you mean remove the MAC address and IP address of the already generated MD?
The NIC was used in a non-MD PC, in case that matters...

The additional problem now seems to be the suddenly appearing eth0! I turned it off in the bios. Also checked if the MD would PXE boot from any of the two disabled cards, but that would not work. Very strange. Can I tell the booting MD to _not_ probe for any more NICs?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4361
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: New diskless MD does not install properly. Why?
« Reply #6 on: March 24, 2009, 11:10:55 pm »
Hi Andrew.

Just unlock the IP/MAC Address for the NIC then (also delete any previously added MD's that used this NIC) boot the machine again... this time it should announce itself properly.
I don't understand what you mean by that. Did you mean remove the MAC address and IP address of the already generated MD?
The NIC was used in a non-MD PC, in case that matters...

Yes what I meant was remove any previously added MD's that used this NIC... and if it was used in a PC that was detected previously by your Core and you added its storage as a Windows Share then you should delete the Windows Storage Device for it from the 'Device Tree' in Web Admin... while your Core still has a record of this NIC's MAC Address in the DB then it will not add it as an MD.
Quote

The additional problem now seems to be the suddenly appearing eth0! I turned it off in the bios. Also checked if the MD would PXE boot from any of the two disabled cards, but that would not work. Very strange. Can I tell the booting MD to _not_ probe for any more NICs?


Hmmm... there probably is a way to force the onboard NIC's to not be probed for... but I dont know it off hand.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

boris

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: New diskless MD does not install properly. Why?
« Reply #7 on: March 24, 2009, 11:43:32 pm »
after you do all configs and run "setup bootless md" from MD set up web page, can you show what your /etc/dhcp3/dhcpd.conf looks like?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: New diskless MD does not install properly. Why?
« Reply #8 on: March 25, 2009, 12:08:11 am »
boris - please do not use the "setup diskless md" button. This is legacy. The correct way to set up an MD is just to turn it on with PXE enabled in the BIOS. The core does everything else.

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: New diskless MD does not install properly. Why?
« Reply #9 on: March 25, 2009, 01:50:51 am »
Quote
I used the wizard to generate a new diskless MD, which results in a media director entry in the web interface. The IP is set to 192.168.80.18.


As Andrew says that is legacy.


Any pxe booted pc that has a supported nic will simply set itself up as a MD.
All that should be required is a quick reload of router when prompted to do so.


Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: New diskless MD does not install properly. Why?
« Reply #10 on: March 25, 2009, 01:54:50 am »
As Andrew says that is legacy.


Thanks fredrick ;)

boris

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: New diskless MD does not install properly. Why?
« Reply #11 on: March 25, 2009, 08:11:37 am »
boris - please do not use the "setup diskless md" button. This is legacy. The correct way to set up an MD is just to turn it on with PXE enabled in the BIOS. The core does everything else.

Fair enough Andrew :), just kidding Colin. It looks that if you use MD wizard to add your device then "setup diskless md" is useless because it seems that "add device" already does all the work.

But as Colin and Tim said, PEX booted MD will configure it self. So delete your MD from MD wizard web page, then reload or reboot your core and boot your MD from PEX and it should just work.
If you once again see that your MD gets address 192.168.80.248 before you see "Announce MD to Core.." (or something like that) message that is normal. You will get IP in range of pluto devices after "Announce MD to Core.." message.

Domodude, you said "That worked, as far as changing the IP." what did you change that IP to?


Domodude

  • Guest
Re: New diskless MD does not install properly. Why?
« Reply #12 on: March 25, 2009, 03:56:41 pm »
Hi Boris,
I did not change the IP (that was already assigned as 80.18 by the core), but I entered the NIC in the web admin. As I wrote above, that got me one step ahead.

The modification of /etc/network/interfaces was another step.

But now the MD makes its eth0 available after the initrd.img is loaded, and that obviously confuses the heck out of the whole booting procedure. It first boots with eth1, and then there is all of a sudden an additional eth0!

Making eth0 a hotpluggable interface does not help. The screen output while booting shows the message about the newly found interface, with new MAC address, and then everythings hangs again. What is needed, I think, is a way to tell the MD to ignore eth0 and eth2. That probably requires a new initrd.img...  :(

Best regards
Mark

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: New diskless MD does not install properly. Why?
« Reply #13 on: March 25, 2009, 05:36:07 pm »
Do you have an additional nic in your MD ? if so  disable it in bios.

Or do you have one of those strange nics that give you different mac addresses?



Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

boris

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: New diskless MD does not install properly. Why?
« Reply #14 on: March 25, 2009, 06:25:30 pm »
Hi Boris,
I did not change the IP (that was already assigned as 80.18 by the core), but I entered the NIC in the web admin. As I wrote above, that got me one step ahead.

The modification of /etc/network/interfaces was another step.

But now the MD makes its eth0 available after the initrd.img is loaded, and that obviously confuses the heck out of the whole booting procedure. It first boots with eth1, and then there is all of a sudden an additional eth0!

Making eth0 a hotpluggable interface does not help. The screen output while booting shows the message about the newly found interface, with new MAC address, and then everythings hangs again. What is needed, I think, is a way to tell the MD to ignore eth0 and eth2. That probably requires a new initrd.img...  :(

Best regards
Mark

Mark,
I, was hopping you did not change IP.

Can you post your /usr/pluto/diskless/[MD#]/etc/network/interfaces?

I still say try this - disable NICs in your bios (that is really bad that you can not disable just one NIC at the time), delete your MD with IP 80.18 from webpage, reboot core, and PXE boot from your PIC NIC card.