Author Topic: play HD video on slow hardware via VDPAU...  (Read 15162 times)

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #15 on: April 25, 2009, 06:58:48 pm »
Hi guys I have been introduced to LINUXMCE by a friend, and I have been trying it out for the past month.

One of my interest in being able to play HD on low end PC's, example sempron, celeron, nvidia-atom (when released),etc.

To my question.

When I try apt-get build-dep mplaper I am getting add url to sources.list. I am not sure what URL I should add for this.

On a side note, I am interested in providing assistance in creating device templates, as I am attempting one for the HVR-1600 which I got working with a kernel upgrade and through configuration with mythv, no success with the template yet.

Nice project guys - real nice -

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: play HD video on slow hardware via VDPAU...
« Reply #16 on: April 25, 2009, 07:03:20 pm »
When I try apt-get build-dep mplaper I am getting add url to sources.list. I am not sure what URL I should add for this.

add deb-src entries for each of your regular deb entries in the sources.list.

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #17 on: May 05, 2009, 02:20:19 am »
I have been really busy, tried it and am getting the following:

root@moon31:~/vdpau/mplayer-vdpau-3532130# apt-get build-dep mplayer
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Could not open file /var/lib/apt/lists/_usr_pluto_deb-cache_._Sources - open (2 No such file or directory)

My source.list

Quote
deb file:/usr/pluto/deb-cache/ ./
deb http://archive.ubuntu.com/ubuntu/ gutsy  main restricted multiverse universe
deb http://archive.ubuntu.com/ubuntu/ gutsy-security  main restricted multiverse universe
deb http://archive.ubuntu.com/ubuntu/ gutsy-updates  main restricted multiverse universe
deb http://linuxmce.com/ubuntu/ ./
deb http://deb.linuxmce.com/ubuntu/ 20dev_ubuntu  main
deb http://deb.linuxmce.com/ubuntu/ replacements_ubuntu  main
#Sources
#deb-src file:/usr/pluto/deb-cache/ ./
deb-src http://archive.ubuntu.com/ubuntu/ gutsy  main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ gutsy-security  main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ gutsy-updates  main restricted multiverse universe
#deb-src http://linuxmce.com/ubuntu/ ./
deb-src http://deb.linuxmce.com/ubuntu/ 20dev_ubuntu  main
deb-src http://deb.linuxmce.com/ubuntu/ replacements_ubuntu  main



posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: play HD video on slow hardware via VDPAU...
« Reply #18 on: May 05, 2009, 08:41:09 am »
Did you run
Code: [Select]
apt-get updateafter changing your sources.list?

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #19 on: May 06, 2009, 01:36:46 am »
I did the apt-get update as suggested.

Am getting the following errors and still not successful with apt-get build-depo  mplayer.

I do know if this will make a difference, this is on an MD.

Quote
Err http://archive.ubuntu.com gutsy/main Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://linuxmce.com ./ Packages
  404 Not Found
Err http://archive.ubuntu.com gutsy/restricted Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/multiverse Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/universe Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/main Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/restricted Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/multiverse Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/universe Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/main Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/restricted Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/multiverse Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/universe Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/main Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/restricted Sources
  404 Not Found [IP: 91.189.88.140 80]
Ign http://deb.linuxmce.com 20dev_ubuntu Release
Err http://archive.ubuntu.com gutsy-security/multiverse Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/universe Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/main Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/restricted Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/multiverse Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/universe Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/main Sources
  404 Not Found [IP: 91.189.88.140 80]
Ign http://deb.linuxmce.com replacements_ubuntu Release
Err http://archive.ubuntu.com gutsy-updates/restricted Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/multiverse Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/universe Sources
  404 Not Found [IP: 91.189.88.140 80]
Ign http://deb.linuxmce.com 20dev_ubuntu/main Packages
Ign http://deb.linuxmce.com 20dev_ubuntu/main Sources
Ign http://deb.linuxmce.com replacements_ubuntu/main Packages
Ign http://deb.linuxmce.com replacements_ubuntu/main Sources
Hit http://deb.linuxmce.com 20dev_ubuntu/main Packages
Err http://deb.linuxmce.com 20dev_ubuntu/main Sources
  404 Not Found
Hit http://deb.linuxmce.com replacements_ubuntu/main Packages
Err http://deb.linuxmce.com replacements_ubuntu/main Sources
  404 Not Found
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/main/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/restricted/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/multiverse/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/universe/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/main/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/restricted/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/multiverse/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/universe/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://linuxmce.com/ubuntu/./Packages.gz  404 Not Found
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/main/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/restricted/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/multiverse/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/universe/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://deb.linuxmce.com/ubuntu/dists/20dev_ubuntu/main/source/Sources.gz  404 Not Found
Failed to fetch http://deb.linuxmce.com/ubuntu/dists/replacements_ubuntu/main/source/Sources.gz  404 Not Found
Reading package lists... Done
E: Some index files failed to download, they have been ignored, or old ones used instead.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #20 on: May 06, 2009, 02:08:50 am »
Gutsy is retired, so the apt sources are no longer valid. You need to change the URL to the new location. Can't remember which it is, but it wasn't archives.... it was something like old...., you can do a search on apt sources in the forum as someone posted it in the last week.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4508
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: play HD video on slow hardware via VDPAU...
« Reply #21 on: May 06, 2009, 02:17:09 am »
I did the apt-get update as suggested.

Am getting the following errors and still not successful with apt-get build-depo  mplayer.

I do know if this will make a difference, this is on an MD.

Quote
Err http://archive.ubuntu.com gutsy/main Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://linuxmce.com ./ Packages
  404 Not Found
Err http://archive.ubuntu.com gutsy/restricted Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/multiverse Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/universe Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/main Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/restricted Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/multiverse Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy/universe Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/main Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/restricted Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/multiverse Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/universe Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/main Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/restricted Sources
  404 Not Found [IP: 91.189.88.140 80]
Ign http://deb.linuxmce.com 20dev_ubuntu Release
Err http://archive.ubuntu.com gutsy-security/multiverse Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-security/universe Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/main Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/restricted Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/multiverse Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/universe Packages
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/main Sources
  404 Not Found [IP: 91.189.88.140 80]
Ign http://deb.linuxmce.com replacements_ubuntu Release
Err http://archive.ubuntu.com gutsy-updates/restricted Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/multiverse Sources
  404 Not Found [IP: 91.189.88.140 80]
Err http://archive.ubuntu.com gutsy-updates/universe Sources
  404 Not Found [IP: 91.189.88.140 80]
Ign http://deb.linuxmce.com 20dev_ubuntu/main Packages
Ign http://deb.linuxmce.com 20dev_ubuntu/main Sources
Ign http://deb.linuxmce.com replacements_ubuntu/main Packages
Ign http://deb.linuxmce.com replacements_ubuntu/main Sources
Hit http://deb.linuxmce.com 20dev_ubuntu/main Packages
Err http://deb.linuxmce.com 20dev_ubuntu/main Sources
  404 Not Found
Hit http://deb.linuxmce.com replacements_ubuntu/main Packages
Err http://deb.linuxmce.com replacements_ubuntu/main Sources
  404 Not Found
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/main/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/restricted/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/multiverse/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy/universe/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/main/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/restricted/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/multiverse/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-security/universe/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://linuxmce.com/ubuntu/./Packages.gz  404 Not Found
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/main/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/restricted/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/multiverse/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/gutsy-updates/universe/source/Sources.gz  404 Not Found [IP: 91.189.88.140 80]
Failed to fetch http://deb.linuxmce.com/ubuntu/dists/20dev_ubuntu/main/source/Sources.gz  404 Not Found
Failed to fetch http://deb.linuxmce.com/ubuntu/dists/replacements_ubuntu/main/source/Sources.gz  404 Not Found
Reading package lists... Done
E: Some index files failed to download, they have been ignored, or old ones used instead.


Hi,

Replace archive.ubuntu.com with old-releases.ubuntu.com in your /etc/apt/sources.list

Then do apt-get update <return>

And all should be fine.

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #22 on: May 06, 2009, 05:12:17 pm »
The apt-get update worked, with some errors shown in the quote below, which I am assuming is expected
Quote
Failed to fetch file:/usr/pluto/deb-cache/./Sources.gz  File not found
Failed to fetch http://linuxmce.com/ubuntu/./Packages.gz  404 Not Found
Failed to fetch http://deb.linuxmce.com/ubuntu/dists/20dev_ubuntu/main/source/Sources.gz  404 Not Found
Failed to fetch http://linuxmce.com/ubuntu/./Sources.gz  404 Not Found
Failed to fetch http://deb.linuxmce.com/ubuntu/dists/replacements_ubuntu/main/source/Sources.gz  404 Not Found


The following still failed
Quote
root@moon31:~/vdpau/mplayer-vdpau-3532130# apt-get build-dep mplayer
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Could not open file /var/lib/apt/lists/_usr_pluto_deb-cache_._Sources - open (2 No such file or directory)

Should it be looking for /var/lib/apt/lists/_usr_pluto_deb-cache_._Sources

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #23 on: May 07, 2009, 10:55:14 am »
Hi,

looks like trouble with one ouf your "deb-src file:*" (or "deb file:*") entries in sources.list

Greetings
Viking

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #24 on: May 08, 2009, 01:47:17 am »
Had to comment the following.

Quote
#deb-src http://linuxmce.com/ubuntu/ ./
#deb-src http://deb.linuxmce.com/ubuntu/ 20dev_ubuntu  main
#deb-src http://deb.linuxmce.com/ubuntu/ replacements_ubuntu  main
.
 Only thing,tried to play transformers, the m2ts file, initially the cpu usage was high, but drop to around 65% after introduction, the audio sucks, really comes in glitches video little slow, cpu usage still 65%.

I feel its the speed of the network from the core, this MD is a 100MB nic, on an ECS board. Had it lying around, bought it previously for a firewall solution, which is needed no more.

This board will not boot from the network, using the upgrade kernel 2.6.29, at set of nfs timeout errors - this could be I did crap, but another machine boots with the new kernel, can't use that, its my wife own.

Thanks guys. I am glad to see that this works as for CPU usage; great benefit for the project, makes the nvidia-ion platform possible.




klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #25 on: May 08, 2009, 03:27:00 am »
Just and update

Tried it again, the cpu usage this time was 89 to 92 %, same problem as before.

Played the trailers, first with xine with 94% cpu usage, renamed the file to .m2ts, played with mplayer, and it played smooth, no problem, but cpu usage was 65% quiet and action was 93%.

mplayer -vo help produces:

Quote
CPU: AMD Sempron(tm) Processor LE-1150 (Family: 15, Model: 127, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
Available video output drivers:
        vdpau   VDPAU with X11
        xv      X11/Xv
        x11     X11 ( XImage/Shm )
        xover   General X11 driver for overlay capable video output drivers
        gl      X11 (OpenGL)
        gl2     X11 (OpenGL) - multiple textures version
        dga     DGA ( Direct Graphic Access V2.0 )
        sdl     SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
        ggi     General Graphics Interface (GGI) output
        fbdev   Framebuffer Device
        fbdev2  Framebuffer Device
        aa      AAlib
        caca    libcaca
        dxr3    DXR3/H+ video out
        v4l2    V4L2 MPEG Video Decoder Output
        xvidix  X11 (VIDIX)
        cvidix  console VIDIX
        null    Null video output
        mpegpes MPEG-PES to DVB card
        yuv4mpeg        yuv4mpeg output for mjpegtools
        png     PNG file
        jpeg    JPEG file
        gif89a  animated GIF output
        tga     Targa output
        pnm     PPM/PGM/PGMYUV file
        md5sum  md5sum of each frame


Still hope, a multicore and gigabyte may seem perfect

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #26 on: May 08, 2009, 06:04:48 am »
If the decode is being handed off to VDPAU then I wouldn't have thought your CPU would have been anything like as high as that. I suspect that it isn't working - either the VDPAU is not being used for the decode, or you don't have a compatible nVidia chipset (needs to be 8xxx, 9xxx series or an integrated PV chip)

Itsik

  • Guru
  • ****
  • Posts: 190
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #27 on: May 08, 2009, 08:06:22 am »
The numbers indicate VDPAU is not working as I get the same numbers with a regular 0710 with 180.44 Nvidia drivers.

Itsik

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4508
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: play HD video on slow hardware via VDPAU...
« Reply #28 on: May 08, 2009, 10:01:52 am »
If the decode is being handed off to VDPAU then I wouldn't have thought your CPU would have been anything like as high as that. I suspect that it isn't working - either the VDPAU is not being used for the decode, or you don't have a compatible nVidia chipset (needs to be 8xxx, 9xxx series or an integrated PV chip)

Agreed Colin...people on the vdpau irc channel are getting completely different results to this...I would suggest that either vdpau is no working or that the card your using is not compatible with it. What card is being used in the test itsik?

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: play HD video on slow hardware via VDPAU...
« Reply #29 on: May 08, 2009, 11:39:31 am »
I am using a evga 9400, from all indication, this card is supported.

nvidia driver 180.51.

Are there any other changes required for linuxmce, or it plays mplayer in /usr/local/bin

Just in case.

I will retry the process, I tar the MD files before doing this, so will I restore and retry, just in case I missed something.