Author Topic: Video media freezes for 20 seconds then continues  (Read 991 times)

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Video media freezes for 20 seconds then continues
« on: February 26, 2008, 12:40:51 pm »
Just rebuilt my core - all my media played fine previously. Whilst playing my video media, randomly it may happen only once in 30 mins, or 2-3 times in 10 mins, seems quite random - but backing up and playing the same stretch it doesn't do it. And in previous builds with all the same media it has never done it before.

Doesn't matter what I press on the remote, there is no response, menus don't react at all. If I press several buttons, when it does start playing again, it replays all the buttons I pressed it very quick succession and then continues normally. If I just leave it without pressing anything it starts playing again on its own after about 20 seconds....


Anybody seen this before?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Video media freezes for 20 seconds then continues
« Reply #1 on: February 26, 2008, 06:31:32 pm »
You could try running "top" in a terminal (preferably logged in remotely so you can always see it).  When the system freezes up you can check to see if there is a single process hogging the resources.
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Video media freezes for 20 seconds then continues
« Reply #2 on: February 27, 2008, 12:56:30 pm »
All/Zaerc do you remember that I was having issues similar to yours over SMBFS vs CIFS some time ago. You had provided a patch that meant in the end I just had to config smbfs instead of cifs in the admin site and it fixed it (took a long time to get to that point) - but before that my windows shares just wouldn't stay online as far as the core was concerned even though they were actually online.

Happened with every install completely repeatably - the share was discovered and media added, then immediately failed and never came back.

dmesg reports smb_add_request timed out and smb_proc_readx_data errors - the only references I can google date back to 2005 and an earlier kernel, but clearly talk about freezes with smbfs shares as well, and that cifs was a workaround!

Perversely - I tried switching to cifs again.... now the share seems to be online!!! How frustrating and inexplicable! But those messages have gone away, and so far (after 15mins) a media file has not yet hung on me....

This seemed to be effecting DVDs as well, presumably because it is a complete hang, but have also had DVD bomb out with CSS lib issues fully 20 mins into the show!

Problem is, as happy as I would be to be back with the default cifs, I am effectively stuck between a rock and a hard place, reliability-wise. Using cifs and I risk the device-offline issue coming back randomly at any point, staying with smbfs, suddenly I have periodic freezes of the system.

Advice???

(btw, this seems unrelated to the sound in VDR/KDE issue that I am also having and the subject of another thread)

finsdown

  • Veteran
  • ***
  • Posts: 54
    • View Profile
Re: Video media freezes for 20 seconds then continues
« Reply #3 on: February 27, 2008, 04:48:32 pm »
I'm just a newbie with this s/w but have you checked to see if MythTV is doing some background jobs - like transcoding or commerical flagging? 

Cheers,

Fins


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Video media freezes for 20 seconds then continues
« Reply #4 on: February 27, 2008, 09:50:50 pm »
As I mentioned, finsdown, switching back to cifs stopped this issue - it is network related in some way, and apparently to an old kernel bug for some reason...

BTW I don't use Myth I use VDR...

cirion

  • Guru
  • ****
  • Posts: 353
    • View Profile
Re: Video media freezes for 20 seconds then continues
« Reply #5 on: February 27, 2008, 10:37:47 pm »
Colinjones I'm having the exact same problem after my reinstall...
Once in a while picture freezes for a few secs audio continues and my remote does nothing. If i rewind that same sequence works fine...
It's very random when it happens...

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Video media freezes for 20 seconds then continues
« Reply #6 on: February 27, 2008, 10:51:46 pm »
Exactly! I don't understand it at all. This is my 12th build and it has never done it before, but suddenly it does this randomly - it definitely looks like the whole system freezes. Switching back to cifs seems to have resolved it. Are you using smbfs to get around the device mount issue?

Just noticed, you said audio is fine... that's not the case for me as I think the whole system is freezing, so perhaps they are different after all...

1stDuc

  • First post!
  • Posts: 1
    • View Profile
Re: Video media freezes for 20 seconds then continues (SOLVED FOR ME)
« Reply #7 on: November 08, 2008, 10:05:32 pm »
Just wanted to put my experience out there for anybody having this same problem. I just switched to LMCE from a standard myth install because I wanted a little more robustness. My MD did this from the start, looking around at all of the possible solutions I noticed that the home directory was mounted with cifs. I edited fstab to mount it through nfs instead and the only time it pauses now is if I am recording 4 HD streams (2 Tuners on the core and 2 tuners on the MD) commercial flagging one starem and watching a previous recording. When I did get it to lock-up I had top running on another computer with the core useage running 8 plus and the MD at 4 plus (both AMD64 with 4 GB of ram).

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Video media freezes for 20 seconds then continues
« Reply #8 on: November 08, 2008, 10:14:16 pm »
Just fyi, LMCE controls the mounting mechanism, how, when, where, etc and expects you never to create mounts or symlinks manually. It sounds like you may have resolved one problem but you will probably end up with all sorts of other problems because you are manually mounting things.

Btw, the freezing thing doesn't happen for me when using cifs, that was specific to smbfs (both of which are configured through the web admin)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Video media freezes for 20 seconds then continues
« Reply #9 on: March 14, 2009, 12:30:43 am »
Hi,

I have noticed this on my old VDR recordings that are using small files of 50MB size (because I used hardlink-cutter). Sometimes when VDR is replaying the next file the replay stops and then continues after 1-2 seconds.

I assume I can (almost) get rid of the problem if I concatenate the files so that I have got bigger files but if you are looking for a way to test it. Just set VDR to record 100MB sizes (in the VDR setup/recording) and then replay the recording.

Greetings
Viking