Author Topic: ATI Radeon HD3200 and LinuxMCE 0710/0810  (Read 2302 times)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
ATI Radeon HD3200 and LinuxMCE 0710/0810
« on: March 09, 2009, 03:01:02 pm »
Hi,

A few friends of mine have problems with ATI Radeon HD3200. Unfortunately they live far from me. That's why I cannot come to some of them and dig that problem. Maybe somebody can share his successful experience with that card if so - used driver, xorg.conf etc.

TIA
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

alx2k

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: ATI Radeon HD3200 and LinuxMCE 0710/0810
« Reply #1 on: March 09, 2009, 04:13:55 pm »
I'm using a laptop that has an HD3200 inside and Ubuntu 8.10

I have used catalyst versions 8.11, 8.12, 9.1 and 9.2.

From those, 9.1 was by far the best of them. Now I have the version 9.2 running and I'm considering to downgrade it.

I'm not at home right now I could post my xorg.conf when I get there, but I just did "/usr/bin/aticonfig --initial"

My problems with 9.2 are:
* random X restarts
* when starting new videos, sometimes the player shows a black image on the playing area, audio sounds.
* when switching to fullscreen, 50% of the times, X restarts.

It was running smooth with 9.1.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: ATI Radeon HD3200 and LinuxMCE 0710/0810
« Reply #2 on: March 09, 2009, 09:59:55 pm »
Thanks for your reply, alx2k. Have you try 0810?
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

alx2k

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: ATI Radeon HD3200 and LinuxMCE 0710/0810
« Reply #3 on: March 10, 2009, 12:31:40 am »
I'm sorry, I haven't tried 0810 on the laptop.

I tried to install it on an old PC I have around, and use the laptop with HD3200 as MD, but I was unable to run it smoothly, so I finally decided to wait for a beta release.

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: ATI Radeon HD3200 and LinuxMCE 0710/0810
« Reply #4 on: March 30, 2009, 08:03:58 pm »
Hi, I'm very interested in this HD3200 myself.
I have it onbooard the Gigabyte GA-MA78GPM-DS2H mainboard.
At the moment I'm running 0710 from DVD install on it.
Have also added a TP-Link TG-3468 http://alternate.be/html/productDetails.html?artno=LGPK03 PCIx NIC for 15 €. Works out of the box, and the small form PCIx slot never gets used (until now) this way I don't waste a slot for a second NIC.

I downloaded following drivers:
Code: [Select]
-rw-r--r--  1 linuxmce linuxmce 50467637 2007-10-23 18:11 ati-driver-installer-8.42.3-x86.x86_64.run
-rw-r--r--  1 linuxmce linuxmce 53459141 2008-04-16 16:24 ati-driver-installer-8-4-x86.x86_64.run
-rwxr--r--  1 linuxmce linuxmce 83286827 2009-02-20 17:49 ati-driver-installer-9.2-x86.x86_64.run


First I installed the 9.2 driver - during install it shows a different number than 9.2...
Worked beautifully allright - but when Flickr screensaver comes up, I have no control over any of the orbiters' buttons...

I'd like to try the default LinuxMCE ati version, but it doesn't seem to get loaded.
Perhaps I'm misconfiguring somwhere.
I did an unistall from the 9.2 driver according to ATI manual.
Next tried to install according to http://wiki.linuxmce.org/index.php/Display_Drivers Ati chipsets.
But it seems vesa drivers get loaded..
At least each time I check the xorg.conf has been modified back to vesa...

locate fglrx gives me:
Code: [Select]
linuxmce@dcerouter:/var/log$ locate fglrx
/mnt/recovery/lib/linux-restricted-modules/2.6.22-14-generic/fglrx
/mnt/recovery/lib/linux-restricted-modules/2.6.22-14-generic/fglrx/firegl_public.o
/mnt/recovery/lib/linux-restricted-modules/2.6.22-14-generic/fglrx/libfglrx_ip.a.GCC4
/mnt/recovery/lib/linux-restricted-modules/2.6.22-14-generic/fglrx/fglrx.mod.o
/mnt/recovery/usr/share/app-install/desktop/fglrx-driver.desktop
/mnt/recovery/usr/share/linux-restricted-modules/2.6.22-14-generic/modules.alias.override/fglrx
/lib/linux-restricted-modules/2.6.22-14-generic/fglrx
/lib/linux-restricted-modules/2.6.22-14-generic/fglrx/libfglrx_ip.a.GCC4
/lib/linux-restricted-modules/2.6.22-14-generic/fglrx/fglrx.mod.o
/lib/linux-restricted-modules/2.6.22-14-generic/fglrx/firegl_public.o
/home/linuxmce/.kde/share/apps/RecentDocuments/fglrxinfo_tx.desktop
/home/linuxmce/fglrxinfo_tx
/usr/lib/python2.5/site-packages/RestrictedManager/handlers/fglrx.py
/usr/lib/python2.5/site-packages/RestrictedManager/handlers/fglrx.pyc
/usr/share/app-install/desktop/fglrx-driver.desktop
/usr/share/linux-restricted-modules/2.6.22-14-generic/modules.alias.override/fglrx
linuxmce@dcerouter:/var/log$

fglrx module is not loaded...

Xorg.0.log contains, see attached screenshot.

If someone can point me to some more information about installing / uninstalling / verifying ati drivers I'd be glad to do some more testing...

I've read someone advised to install version 8.4, but before testing this, I would like to gain a better understanding of the above as I should at least be able to see what drivers are loaded.. or not.

Thanks for your suggestions.

Erwin
« Last Edit: March 30, 2009, 08:06:27 pm by Lexje »