Author Topic: USB sound cards  (Read 1078 times)

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
USB sound cards
« on: February 25, 2009, 05:00:50 pm »
Hey guys, I have been sitting on a USB port sound card (actually just a usb stick) for a while and havent been able to get it to work. However I had somewhat of a breakthrough last night while chatting with Thom. I now have it working with KDE and I feel like I am getting close to success with LMCE. Here is what I have done so far.

plug the stick in (obviously)
edit the /etc/asound.conf file. Change everything  inside the quotations to "plughw:1" save and exit
edit /etc/pluto/xine.conf   Find two lines that start with audio.alsa and change after the first : to say plughw:1

reload router and you should be at the point where I am. Amarok and mplayer and Xine all play through USB on the Desktop, but I still get no sound from it when inside LMCE.

Once I get it completely figured out I will make a wiki, please post if you have successfully set up a USB sound device in LMCE.
-Krys

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: USB sound cards
« Reply #1 on: February 26, 2009, 03:42:56 pm »
Anyone have a hint for me? I feel like I am sooo close to getting this working. I think the problem lies in the fact that LMCE uses a different form of xine when it plays media and I need to find the .conf for that xine and make the same alterations.... problem is I dont know where that is at or if it even exists.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: USB sound cards
« Reply #2 on: February 26, 2009, 09:52:07 pm »
 /etc/pluto/xine.conf is the right file. I verified it in the source code.

I also verified that the problem you're having because Xine_Player is reconfiguring that file on the fly based on the settings in web admin.

Go to Web Admin > Media Director and look at Audio Settings, it is currently set to Stereo.

Change this to Manual Settings, save, reload router.

Xine_Player will now respect the settings in this file, and your changes for plughw:1 should work.

This will be an okay work-around until I can make changes to handle USB sound cards more efficiently.

-Thom

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: USB sound cards
« Reply #3 on: February 26, 2009, 10:38:59 pm »
Did as instructed and I now have sound... Thanks a Million!

one last remaining issue is I cant control the volume from LMCE. I disable the onboard sound controller and rebooted but still I have to manually go into KDE and adjust the volume labeled PCM. Also a note, for some reason it is super sensitive, when the dial is at about 5% volume it destroys my headphone speakers.

Once again, thanks a million! For now I will just use speakers that have their own vol control.
-Krys