Author Topic: Screen saver activates while watching video on hulu  (Read 4723 times)

donpaul

  • Guru
  • ****
  • Posts: 300
    • View Profile
Screen saver activates while watching video on hulu
« on: February 18, 2009, 07:35:45 pm »
Is there any way to prevent the screen saver from activating while watching video from the web? 10 minutes into a video on hulu, and the screen saver activates. I don't want to disable the screensaver.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Screen saver activates while watching video on hulu
« Reply #1 on: February 18, 2009, 09:59:34 pm »
Screen saver activates? Do you mean that it turns off your screen? When we refer to the screen saver, we are refering to the panning and zooming of random photos from your library or Flickr, which is completely different from when the Orbiter shuts down AV equipment after a timeout.. which are you referring to? The Photo Screen Saver will never interrupt anything you are doing, that is just something that happens in the background.

However, shutting down AV equipment after a timeout is normal. If LMCE decides that no media is playing or activity is happening, that is what happens. If you are going to the KDE desktop to do web browsing then this is quiet possible as LMCE doesn't see activity in the desktop. If this is the issue, you should be browsing from the Computing menu as this means LMCE can see the activity, then it won't shut down.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Screen saver activates while watching video on hulu
« Reply #2 on: February 18, 2009, 10:34:11 pm »
I think I've seen reports of the photo screen saver kicking in when you're watching youtube stuff from the computing menu.  But I never use that kind of stuff myself so I don't know for sure.
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Screen saver activates while watching video on hulu
« Reply #3 on: February 18, 2009, 10:35:19 pm »
I think I've seen reports of the photo screen saver kicking in when you're watching youtube stuff from the computing menu.  But I never use that kind of stuff myself so I don't know for sure.

oo. bizarre, never seen that to be honest, and I do that quiet a bit :)

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Screen saver activates while watching video on hulu
« Reply #4 on: February 18, 2009, 10:39:49 pm »
Maybe I'm confused with sth else then, but I think I've seen it sometimes kick in on the desktop.
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Screen saver activates while watching video on hulu
« Reply #5 on: February 18, 2009, 10:43:33 pm »
Maybe I'm confused with sth else then, but I think I've seen it sometimes kick in on the desktop.

dunno, I know I've seen firefox have problems with youtube ... the shockwave plugin, causing it to bomb back to the main screen or computing menu... but that's a shockwave thing (mainly if you full screen the video then hit the minimise when finished rather than hitting esc) but other than that I'm trying to recall any other weirdnesses....

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: Screen saver activates while watching video on hulu
« Reply #6 on: February 19, 2009, 01:10:33 am »
I am aware of it. We have to add additional logic in to keep this from happening.

-Thom

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Screen saver activates while watching video on hulu
« Reply #7 on: February 19, 2009, 01:34:04 am »
Is there any way to prevent the screen saver from activating while watching video from the web? 10 minutes into a video on hulu, and the screen saver activates. I don't want to disable the screensaver.

One solution to this would be to set the 'Timeout' field for your Orbiters to a higher value. From memory I think they default to 600 which is 600 secs. Go to Web Admin -> Show Devices Tree... then expand the Device tree for the MD so you can see the Orbiter and then click on the entry for 'Onscreen Orbiter'. now scroll down the right-hand pane until you can see the 'TimeOut' field. Make this values higher and save the change and then do a reload - this should lengthen the time before the screen saver kicks in.

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

donpaul

  • Guru
  • ****
  • Posts: 300
    • View Profile
Re: Screen saver activates while watching video on hulu
« Reply #8 on: February 19, 2009, 07:50:57 pm »
I thought about upping the timeout, but I would hate to have a 1 hour timeout. I'll have to live with it until the logic is added I guess :( Hulu is fantastic!

Thanks tschak909!

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1072
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Screen saver activates while watching video on hulu
« Reply #10 on: February 20, 2009, 10:49:22 am »
http://wiki.linuxmce.org/index.php/Screen_saver_timeout

The Wizard Orbiters page sets the same attributes as in my earlier post. What we need however is for the Computing screen to either not trigger the pss or for it a separately configurable set of attributes.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1072
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Re: Screen saver activates while watching video on hulu
« Reply #11 on: February 20, 2009, 11:02:57 am »
yeah i realized that after I read the rest of the thread. Brain running on auto pilot ;)
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius