Author Topic: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2  (Read 1967 times)

itsmeok

  • Veteran
  • ***
  • Posts: 100
    • View Profile
Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« on: February 16, 2009, 03:06:29 pm »
I am trying to follow the wiki to install the games. In the plugin instructions I get stuck:

Here is what I do and the messages I got. Basically the file that I try to copy in the last command is not there.

 linuxmce@dcerouter:~/trunk/src/lmce_game$ cd ../MAME_PlugIn
 linuxmce@dcerouter:~/trunk/src/MAME_PlugIn$ make so
 Computing dependencies for MAMEMediaStream.cpp done
 Computing dependencies for MAMEROM.cpp done
 Computing dependencies for ../Gen_Devices/MAME_PlugInBase.cpp done
 Computing dependencies for MAME_PlugIn.cpp done
 Computing dependencies for Main.cpp done
 g++ -c -I.. -I../DCE -I/usr/include/mysql -DKDE_LMCE -DDEBUG -DTHREAD_LOG -DLOG_                                                                                              ALL_QUERIES -I/opt/libxine1-pluto/include -I/opt/linphone-1.3.5/include  -Wall -                                                                                            fPIC - ggdb3 -fmessage-length=0 Main.cpp -o Main.o
 ../DCE/DeviceData_Base.h: In member function âbool DCE::DeviceData_Base::WithinC                                                                                             ategory(long int, DCE::DeviceCategory*)â:
 ../DCE/DeviceData_Base.h:397: warning: comparison between signed and unsigned in                                                                                             teger expressions
 ../DCE/DeviceData_Impl.h: In member function âint DCE::MAME_PlugIn_Data::Get_Pri                                                                                             ority()â:
 ../DCE/DeviceData_Impl.h:51: error: âstd::map<int, std::basic_string<char, std::                                                                                            char_traits<char>, std::allocator<char> >, std::less<int>, std::allocator<std::p                                                                                             air<const int, std::basic_string<char, std::char_traits<char>, std::allocator<ch                                                                                            ar> >  > > > DCE::DeviceData_Impl::m_mapParametersâ is private
 ../Gen_Devices/MAME_PlugInBase.h:98: error: within this context
 ../Media_Plugin/MediaListGrid.h: At global scope:
 ../Media_Plugin/MediaListGrid.h:143: warning: âbool FileBrowserInfoComparerLastV                                                                                             iewed(FileBrowserInfo*, FileBrowserInfo*)â defined but not used
 ../Media_Plugin/MediaListGrid.h:148: warning: âbool FileBrowserInfoComparerTrack                                                                                             (FileBrowserInfo*, FileBrowserInfo*)â defined but not used
 make: *** [Main.o] Error 1
 linuxmce@dcerouter:~/trunk/src/MAME_PlugIn$ sudo cp MAME_PlugIn.so /usr/pluto/bi                                                                                            n
 cp: cannot stat `MAME_PlugIn.so': No such file or directory

Is there anyone who has an idea why this happend.

Something that I had to change from the instructions is that to get to the directory MAME_PlugIn i had to alter the command

cd ../../MAME_PlugIn  INTO ==> cd ../MAME_PlugIn






tschak909

  • LinuxMCE God
  • ****
  • Posts: 5496
  • DOES work for LinuxMCE.
    • View Profile
Re: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« Reply #1 on: February 17, 2009, 12:27:48 am »
There is a forum posting on compiling Mame_PlugIn.so for 64-bit machines, this looks like what's happening.

This device has been replaced on 0810 with the Game Plugin and Game Player, and the installation process is much easier, but there are still bugs for me to fix.

-Thom

tailspower2001

  • Regular Poster
  • **
  • Posts: 15
    • View Profile
Re: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« Reply #2 on: February 18, 2009, 06:32:58 pm »
It's best if can get an .DEB file of MAME and keep the ROMs as an .zip flie.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5496
  • DOES work for LinuxMCE.
    • View Profile
Re: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« Reply #3 on: February 18, 2009, 06:34:42 pm »
This isn't duct taped on.

It's an actual device and media type of the system. Once installed, you put games in public/games as a zip.

Again, I do not do any development or support on the 0710 version. If you want to test, use the 0810 alpha.

-Thom

itsmeok

  • Veteran
  • ***
  • Posts: 100
    • View Profile
Re: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« Reply #4 on: February 21, 2009, 02:50:27 pm »
Thom, I have been searching the forum for the post you talk about. Do you remember which one it is. I cannot find it.

Scooter

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« Reply #5 on: March 01, 2009, 09:06:14 pm »
Hi,
I have the exact same issue, no probs until this point and then the make so fails. The processor is an amd64 but I am running the x86 install. Is there a solution for this that a non programmer would understand?
Thanks,
Phil.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5496
  • DOES work for LinuxMCE.
    • View Profile
Re: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« Reply #6 on: March 02, 2009, 12:29:15 am »
Did you follow these instructions?

http://wiki.linuxmce.org/index.php/MAME_Installation

-Thom

Scooter

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« Reply #7 on: March 02, 2009, 10:07:12 am »
Everystep of the way.

No problems until it came to compiling the MAME plugin, then make so ends with error 1 the same as the original poster.

Thanks,
Phil.
« Last Edit: March 02, 2009, 10:08:51 am by Scooter »

Scooter

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Installing games (MAME) through wiki fails on linuxmce 7.10 RC2
« Reply #8 on: March 24, 2009, 12:46:48 pm »
*BUMP*

Anyone?
Thanks,
Phil.