Author Topic: Fiire remotes in 8.10  (Read 1460 times)

cirion

  • Guru
  • ****
  • Posts: 353
    • View Profile
Fiire remotes in 8.10
« on: February 03, 2009, 01:24:11 pm »
My Fiire remote runs as a normal 2 button mouse in 8.10.
Is the software for the Fiire remotes not installed in 8.10?
Anyone know what to install?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Fiire remotes in 8.10
« Reply #1 on: February 03, 2009, 11:21:16 pm »
Strange!

Its the MCR Remote Dongle device - device template #1848 (under OnScreen Orbiter in the devices tree). If you look at the template, in the plug and play area you will see the vendor and product ID as 0c160006 which will match the output of lsusb for the device being 0c16:0006 (ie a ':' in the middle of the number above).

As I understand it, when you plug it in, the HAL device will detect it, and send a pnp device detected event to the PnP Plugin, which will then place an entry on the pnpQueue (SQL table in Pluto Main). Then it should use the info in that event (the vendor and product ID) to find that template and create a device from it.

In the template, it should specify the Pluto MCR Remote package to be installed to drive it...

cirion

  • Guru
  • ****
  • Posts: 353
    • View Profile
Re: Fiire remotes in 8.10
« Reply #2 on: February 04, 2009, 08:30:07 am »
I se no "MCR Remote Dongle device" there...
Just the following:
  Orbiter Embedded Phone
  Xine Player
  Photo Screen Saver
  MPlayer Player
  VDR

I could add it manually...

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Fiire remotes in 8.10
« Reply #3 on: February 04, 2009, 11:07:35 am »
try it...

cirion

  • Guru
  • ****
  • Posts: 353
    • View Profile
Re: Fiire remotes in 8.10
« Reply #4 on: February 05, 2009, 03:33:50 pm »
Adding the MCR Remote Dongle device manually only makes the MD's complain about something not started correctly.
The Fiire remote still works as a 2 button mouse. No other buttons work.

I have 3 dongles and 2MD's + the Core hybrid.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Fiire remotes in 8.10
« Reply #5 on: February 05, 2009, 05:23:12 pm »
Have you tried looking at the logs an/or TailDCERouter.sh to see what is actually going wrong?  I don't have one of those myself, but I'm pretty sure nobody removed the support for it (assuming that we have the needed sources in the first place of course).
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Fiire remotes in 8.10
« Reply #6 on: February 05, 2009, 08:34:18 pm »
Also, try manually installing the pluto mcr package just to be certain that it can get the package and install it OK.

sudo apt-get install pluto-mcr-remote

Then a reload.... maybe it just couldn't find the source?

cirion

  • Guru
  • ****
  • Posts: 353
    • View Profile
Re: Fiire remotes in 8.10
« Reply #7 on: February 05, 2009, 10:10:51 pm »
Code: [Select]
linuxmce@dcerouter:~$ sudo apt-get install pluto-mcr-remote
Reading package lists... Done
Building dependency tree
Reading state information... Done
pluto-mcr-remote is already the newest version.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Fiire remotes in 8.10
« Reply #8 on: February 05, 2009, 10:37:12 pm »
Well it must of pnp'd it at some point then, as it has installed the package for it... but why is the device not there then? Sorry, I'm lost!

cirion

  • Guru
  • ****
  • Posts: 353
    • View Profile
Re: Fiire remotes in 8.10
« Reply #9 on: April 29, 2009, 06:31:39 am »
Anyone know when the Fiire Remotes will work in 8.10?

A fix for the sources was made 2 months ago:
http://svn.linuxmce.org/trac.cgi/changeset/21742

Anyone know if I can edit the files myself on a 8.10 install?
I have fresh install of 8.10 Alpha 2.11

rodercot

  • Guest
Re: Fiire remotes in 8.10
« Reply #10 on: April 29, 2009, 11:06:57 am »
Anyone know when the Fiire Remotes will work in 8.10?

A fix for the sources was made 2 months ago:
http://svn.linuxmce.org/trac.cgi/changeset/21742

Anyone know if I can edit the files myself on a 8.10 install?
I have fresh install of 8.10 Alpha 2.11

 I mentioned this in another thread and here is Thom's reply, so he does not have to reply to it again...

 http://forum.linuxmce.org/index.php?topic=7820.msg52663#msg52663

 Dave
« Last Edit: April 29, 2009, 11:09:59 pm by rodercot »