Author Topic: Squeezecenter upgrade knocks core unuseable  (Read 2523 times)

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Squeezecenter upgrade knocks core unuseable
« on: February 03, 2009, 06:25:06 am »
I should know better. I upgraded Slimserver to Squeezecenter and it all seemed to work except I found later that the DHCP server was dead. Then I discovered as I was trying to restart the system that a lot of other stuff was not working. I think its a permissions problem. I know very little about permissions and access rights in linux and I do know enough to make a big mess of things. Can anyone direct me to correct settings etc. to get the low level stuff working right so I can the box running? On boot it reports that the UI is unable to connect to DCErouter.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5498
  • DOES work for LinuxMCE.
    • View Profile
Re: Squeezecenter upgrade knocks core unuseable
« Reply #1 on: February 03, 2009, 07:18:08 am »
Hey man, long time no see.

How did you upgrade to squeezecenter?

It's worth noting that our 0810 release has been upgraded to squeezecenter.

-Thom

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: Squeezecenter upgrade knocks core unuseable
« Reply #2 on: February 03, 2009, 07:38:08 am »
I'm looking forward to 810. I have been too busy working, and also not a little time with the mi casa verde stuff.

I had installed it some time ago and all was working fine. Then I noticed that mythtv had crashede. I restarted everything and all was working but I went to the KDE desktop to check settings on myth and noticed the upgrade notice on the desktop, which indicated three upgrades were available including a new version of squeezecenter. I told it to go ahead and upgrade. I didn't pay attention to the other two upgrades since they seemed very minor. The upgrade worked and squeezecenter work but about a day later I noticed that the DHCP server had stopped. And then it was downhill. I restarted an all seems pretty sick. I can't open the admin panel from inside or outside the box, it cannot connect to DCErouter on bootup etc. Perhaps when they setup the reviced UI for Squeezecenter they mucked up something that LMCE uses in apache? I'm not sure what happened but its all screwed up for now.
Before I blow it away and start over (what a pain that may be) I want to check all the easy fixes.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Squeezecenter upgrade knocks core unuseable
« Reply #3 on: February 03, 2009, 10:16:23 am »
hey 1audio, welcome back!

I upgraded to squeezecenter and its working well. (needed the latest version for my Squeezebox Boom) Thom and Zearc helped me, problem is I can't remember exactly what I did to get it working, except I had to fool the packaging system into thinking squeezecenter was slimserver.... as a result my package system is broken until I resolve some dependencies. I have a path forward on that (thanks to Zaerc) just haven't actually worked through it yet. Either way, you should be able to find some stuff I posted in the forums whilst working through this... might help.

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: Squeezecenter upgrade knocks core unuseable
« Reply #4 on: February 03, 2009, 06:06:23 pm »
It gets more mysterious. Today start of the core the core is working but squeezecenter isn't accessible. Mythweb is available. Swisscenter is available and working so Apache is working OK. The DHCP server started OK..


Here is the error message from Squeezecenter server log:
2009-02-03 08:27:06 squeezecenter_safe started.
[09-02-03 08:27:59.6539] Slim::Utils::PluginManager::enablePlugins (419) Couldn't load Slim::Plugin::PreventStandby::Plugin. Error: Plugin is incompatible with your platform.
[09-02-03 08:41:49.5451] Slim::Utils::Misc::msg (1122) Warning: [08:41:49.5442] Use of uninitialized value in concatenation (.) or string at /usr/share/squeezecenter/lib/Template/Provider.pm line 604.
[09-02-03 08:41:49.5476] Slim::Web::HTTP::_generateContentFromFile (2496) Error: file error - /usr/share/squeezecenter/HTML/Default/index.html: not found
[09-02-03 08:41:49.6273] Slim::Utils::Misc::msg (1122) Warning: [08:41:49.6265] Use of uninitialized value in concatenation (.) or string at /usr/share/squeezecenter/lib/Template/Provider.pm line 604.

The section refered to above is:
ub _load_compiled {
    my ($self, $file) = @_;
    my $compiled;

    # load compiled template via require();  we zap any
    # %INC entry to ensure it is reloaded (we don't
    # want 1 returned by require() to say it's in memory)
    delete $INC{ $file };
    eval { $compiled = require $file; };
    return $@
        ? $self->error("compiled template $compiled: $@")
        : $compiled;
}


The line starts with return $@

And the following  error seems to be in error because the file exists:
[09-02-03 08:41:49.6281] Slim::Web::HTTP::_generateContentFromFile (2496) Error: file error - /usr/share/squeezecenter/HTML/EN/settings/server/wizard.html: not found

 
if everything else is stable in my box I will leave it until 810 is ready enough to be explored. But any input will be very much appreciated.

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Squeezecenter upgrade knocks core unuseable
« Reply #5 on: February 03, 2009, 06:21:42 pm »
I upgraded to squeezecenter  to work with my squeeze boom and it worked fine.




Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: Squeezecenter upgrade knocks core unuseable
« Reply #6 on: February 04, 2009, 05:48:55 pm »
I had been using Squeezecenter for 6 months with no problem. it was a "maintainence" upgrade that knocked me out. Its working again but occasionally mysql becomes unavailable.


1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: Squeezecenter upgrade knocks core unuseable
« Reply #7 on: February 11, 2009, 07:31:46 am »
I got it sorted out. The upgrade in place didn't work right. Who knows why. But a full clean remove of slimserver and squeezecenter and then a reinstall in sequence seems to work ok for now.