Author Topic: AV Wizard picking wrong audio output  (Read 841 times)

caddywhompus

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
AV Wizard picking wrong audio output
« on: January 30, 2009, 05:57:59 pm »
I have a plethora of Compaq EVO desktops that will ultimately become MDs for my house.  They are all identical (which is nice) and testing has shown they all work flawlessly with LinuxMCE with one minor excetion.  When the AV Wizard comes up, it defaults sound to the internal PC Speaker rather than the 1/8" audio output.  I can see no way to change this behaviour, and I don't want to break any scripts.  I can see from the core admin site that the audio output is "analog stereo" but it's unclear how to set the MD to use the output rather than the internal speaker.

These Compaq Evos have the following specs:
PIII 1.4t processor
512MB ram
Onboard sound, nic, usb, and vga video (disabled)
I add in a Nvidia 5xxx or 6xxx PCI card with either vga or s-video output depending on TV

If there is any other information I can provide let me know.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3014
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: AV Wizard picking wrong audio output
« Reply #1 on: January 31, 2009, 12:23:42 pm »
Check on the Compaq (HP) site for infos, and/or maybe some BIOS settings. If all else fails, do a google search for those Compaq EVO models, plus alsa, and see if you can come up with some infos.

seth

  • Guru
  • ****
  • Posts: 485
  • A day w/o LinuxMCE is like a day w/o sunshine!
    • View Profile
Re: AV Wizard picking wrong audio output
« Reply #2 on: February 02, 2009, 01:50:53 pm »
 :)
I use one of these (actually looking for 1 more) as an MD in my Family Room. You are correct, it s the default behavior of the MD to use the internal speaker set, this is a limitation of the business class hardware that is the Evo.

What I have to do is use CTRL-ALT-F2 and get to a terminal on the MD. Login as root, run
Code: [Select]
alsamixerand mute the Headphone setting. After I do that the sound switches instantly to the external source, and then to make sure it sticks, I run
Code: [Select]
alsactl store
Once this is done it uses the correct output on concurrent reboots.

Hope that helps. And if you want to get rid of one or two of those Evo's, let me know  ;)

Regards,

Seth
".....Because Once you've LinuxMCE'd....."
System stats located at my user page:

http://wiki.linuxmce.org/index.php/User:Seth

caddywhompus

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: AV Wizard picking wrong audio output
« Reply #3 on: February 02, 2009, 04:22:41 pm »
Thank you very much Seth.  That is very helpful.  This isn't a setting that LMCE is going to over-write every time I PXE boot is it?

I bought several of the EVOs on Craigslist a few months ago exactly for this purpose.  They were originally Celeron 1.0ghz machines, but with a Bios flash they will take PIII 1.4t chips, which really wakes them up.  Up until now I was using a couple of them as MythDora frontend machines, and they work great.  Very quiet, cool and small enough to fit into the entertainment center.  Of course, you already know that. :)

I don't think I'm going to have any extra after the project is finally done.  Of the ones a bought, a couple had issues so I ended up parting a couple out to fix the rest, leaving me with 4 working units.  But if you need any parts...

the anxious

  • Regular Poster
  • **
  • Posts: 31
    • View Profile
    • My portfolio
Re: AV Wizard picking wrong audio output
« Reply #4 on: February 11, 2009, 06:54:39 pm »
:)
I use one of these (actually looking for 1 more) as an MD in my Family Room. You are correct, it s the default behavior of the MD to use the internal speaker set, this is a limitation of the business class hardware that is the Evo.

What I have to do is use CTRL-ALT-F2 and get to a terminal on the MD. Login as root, run
Code: [Select]
alsamixerand mute the Headphone setting. After I do that the sound switches instantly to the external source, and then to make sure it sticks, I run
Code: [Select]
alsactl store
Once this is done it uses the correct output on concurrent reboots.

Hope that helps. And if you want to get rid of one or two of those Evo's, let me know  ;)

Regards,

Seth

Hi,
I tried run alsamixer in my core/md but I get the message saying that alsamixer is not instaled, or something like this.. my sound on LinuxMCE are controled by kmix... I think so.. (is the one way to change volume on LinuxMCE, but only on KDE or with the control of TV).. and I can´t control with my fiire chief.. I looked for how to get this working but i have no success.. :/ Will I need instal alsamixer to control volume with my fiire chief?
thanks
djonny

« Last Edit: February 11, 2009, 06:58:28 pm by djonny »
Asus M2N-E-SLI, 2GB Kingston, HD 500GB Seagate, Hauppage PVR-500, Geforce 7300GS, Fiire Chief, Nokia N800, Samsung LN32A330J1 32", HA22, Intermatic Switches, USB UIRT, Xantech 286 double emitter,