Author Topic: Audio Genres don't appear to be working in Linux Build 2 (LinuxMCE 0810 alpha1)  (Read 911 times)

domanows

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
I just downloaded the latest release of LinuxMCE and installed it.  I am somewhat familiar with the package, but am trying to learn as much as possible. 

The Genre in Audio is not displaying any songs or artists, just a black screen.  I know there was an issue in an older version in 0710 Beta4 and a fix was released.  The ID3 tag have been set properly (I used Amarok to set them) and they come up fine in my various MP3 players. 

Can someone please help?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2989
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Hello,

could you clearify, which version you are using? LinuxMCE 0710rc2 or LinuxMCE 0810alpha1

rgds
Oliver

domanows

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Sorry about that.  I downloaded LinuxMCE 0710  off of the http://wiki.linuxmce.org/index.php/Mirrors_0710 site. 

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2989
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
When you sort by something else but genre, and select a title for playing, are you able to select the genre and get a list of files with that genre?

Also, whenever you add a new genre, you have to quick reload and regen to be able to select it in the option screen.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Can you confirm that you can actually see the genres in the web admin under media sync. Pick a file that is tagged and look at its properties. Then click on the genre property and it should list all the other media files using that attribute. This will at least confirm that the data is in the database which obviously is required before the orbiter is able to use that data in organising the screens.

domanows

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
colinjones,

Thanks so much.  I went into media sync and looked at a bunch file properties.  The following is a sample of the output.  I can see that there is a genre listed for the mp3's

 7 Seconds - 05 - My Gravity.mp3
Album: Unknown Genre: Punk Performer: 7 Seconds Title: My Gravity Track: 5
7 Seconds - 10 - First Ya Told Us.mp3
Album: Unknown Genre: Punk Performer: 7 Seconds Title: First Ya Told Us Track: 10
7 Seconds - 13 - Girl Song.mp3
Album: Unknown Genre: Punk Performer: 7 Seconds Title: Girl Song Track: 13
7 seconds - 99 red balloons.mp3
Album: Old School Genre: Punk Performer: 7 Seconds Release Date: 1988 Title: 99 Red Balloons Track: 1
7 seconds - clenched fists, black eyes.mp3
Album: The Crew Genre: Punk Performer: 7 Seconds Release Date: 1988 Title: Clenched Fists, Black Eyes
7 seconds - regress no way.mp3

Another item of interest.  Please bear with me....

1. If I Press Options/Genre/Go I get a list the List of all the Genres my mp3's use
2. When I then click on a Genre (Lets say Classic Rock) I would expect to see Eric Clapton, Pink Floyd, etc, but I see nothing
3. BUT now if I go back to Options/Performers/Go  I now only see artists from the Classic Rock Genre

This appears to be a bug right??

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
hmmm - you'll need to check that the "Classic Rock" actually has some tracks assigned to that genre first. But yes, that is essentially how it should work. For instance, from below, you should be able to click on the "Punk" genre and see each of those tracks listed. It works fine on mine. I click Classic Rock and there are 2 Eric Clapton tracks! (among others)

The other thing is, in point 3, it can be easy to get lost as to which layer you are at. It sounds like here, you haven't pressed back enough times, so you are looking at a subset of an earlier subset. When in that view, hit back a few times. Or to be sure, cancel out of the menus completely, and start again... then you won't see that behaviour.